[PATCH 0/8] Add perlcritic

  • Done
  • quality assurance status badge
Details
2 participants
  • EuAndreh
  • Christopher Baines
Owner
unassigned
Submitted by
EuAndreh
Severity
normal
E
E
EuAndreh wrote on 18 Oct 2022 03:32
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013245.32254-1-eu@euandre.org
Add the "perlcritic" package, and all the modules that it requires that
were not already packaged.

All packages were styled with './pre-inst-env guix style' and built
twice reproducibly.

Note: the new "perl-string-format" is a different package than the
existing "perl-string-formatter".

EuAndreh (8):
gnu: Add perl-config-tiny.
gnu: Add perl-pod-spell.
gnu: Add perl-readonly-xs.
gnu: Add perl-string-format.
gnu: Add perl-ppix-regexp.
gnu: Add perl-ppix-quotelike.
gnu: Add perl-ppix-utilities.
gnu: Add perl-critic.

gnu/packages/perl.scm | 245 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 245 insertions(+)

--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 1/8] gnu: Add perl-config-tiny.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-1-eu@euandre.org
* gnu/packages/perl.scm (perl-config-tiny): New variable.
---
gnu/packages/perl.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 022ca73429..d9bda9a878 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2076,6 +2076,33 @@ (define-public perl-config-ini
and writing of @code{.ini}-style configuration files.")
(license (package-license perl))))
+(define-public perl-config-tiny
+ (package
+ (name "perl-config-tiny")
+ (version "2.28")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RS/RSAVAGE/Config-Tiny-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "000mw17nb7aj341s0afqimxd53w5y0c4yk61pihqzm191lx89pqj"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-test-pod))
+ (home-page "https://metacpan.org/release/Config-Tiny")
+ (synopsis "Read/Write .ini style files with as little code as possible")
+ (description
+ "@code{Config::Tiny} is a Perl class to read and write .ini
+style configuration files with as little code as possible, reducing load time
+and memory overhead.
+
+This module is primarily for reading human written files, and anything we write
+shouldn't need to have documentation/comments. If you need something with more
+power move up to @code{Config::Simple}, @code{Config::General} or one of the
+many other @code{Config::*} modules.")
+ (license license:perl-license)))
+
(define-public perl-const-fast
(package
(name "perl-const-fast")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 2/8] gnu: Add perl-pod-spell.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-2-eu@euandre.org
* gnu/packages/perl.scm (perl-pod-spell): New variable.
---
gnu/packages/perl.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d9bda9a878..1146fecb6b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -71,6 +71,7 @@ (define-module (gnu packages perl)
#:use-module (gnu packages gtk)
#:use-module (gnu packages hurd)
#:use-module (gnu packages image)
+ #:use-module (gnu packages language)
#:use-module (gnu packages less)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl-check)
@@ -8709,6 +8710,34 @@ (define-public perl-pod-simple
used for writing documentation for Perl and for Perl modules.")
(license (package-license perl))))
+(define-public perl-pod-spell
+ (package
+ (name "perl-pod-spell")
+ (version "1.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/H/HA/HAARG/Pod-Spell-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "18wzpfn39hpw6n8g9pwh964nid8skks79i5jdcm33gf9kf5qx3r0"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-file-sharedir-install))
+ (propagated-inputs (list perl-class-tiny perl-file-sharedir
+ perl-lingua-en-inflect))
+ (home-page "https://metacpan.org/release/Pod-Spell")
+ (synopsis "Formatter for spellchecking Pod")
+ (description
+ "@code{Pod::Spell} is a Pod formatter whose output is good
+for spellchecking.
+
+@code{Pod::Spell} is rather like @code{Pod::Text}, except that it doesn't put
+much effort into actual formatting, and it suppresses things that look like Perl
+symbols or Perl jargon (so that your spellchecking program won't complain about
+mystery words like \"@code{$thing}\" or \"@code{Foo::Bar}\" or \"@code{hashref}\").")
+ (license license:artistic2.0)))
+
(define-public perl-posix-strftime-compiler
(package
(name "perl-posix-strftime-compiler")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 3/8] gnu: Add perl-readonly-xs.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-3-eu@euandre.org
* gnu/packages/perl.scm (perl-readonly-xs): New variable.
---
gnu/packages/perl.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1146fecb6b..f5a8fad4d5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8854,6 +8854,38 @@ (define-public perl-readonly
variables that should not be changed.")
(license (package-license perl))))
+(define-public perl-readonly-xs
+ (package
+ (name "perl-readonly-xs")
+ (version "1.05")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RO/ROODE/Readonly-XS-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "03gz7yp194fwah2bc36ww04hgw1qx8p6y68vvnywircrablc9rca"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-readonly))
+ (home-page "https://metacpan.org/release/Readonly-XS")
+ (synopsis "Companion module for @code{Readonly.pm}, to speed up read-only
+scalar variables")
+ (description
+ "The @code{Readonly} module is an effective way to create non-modifiable
+variables. However, it's relatively slow.
+
+The reason it's slow is that is implements the read-only-ness of variables via
+tied objects. This mechanism is inherently slow. Perl simply has to do a lot
+of work under the hood to make tied variables work.
+
+This module corrects the speed problem, at least with respect to scalar
+variables. When @code{Readonly::XS} is installed, @code{Readonly} uses it to
+access the internals of scalar variables. Instead of creating a scalar variable
+object and tying it, @code{Readonly} simply flips the @code{SvREADONLY} bit in
+the scalar's @code{FLAGS} structure.")
+ (license license:perl-license)))
+
(define-public perl-ref-util-xs
(package
(name "perl-ref-util-xs")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 4/8] gnu: Add perl-string-format.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-4-eu@euandre.org
* gnu/packages/perl.scm (perl-string-format): New variable.
---
gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f5a8fad4d5..d6e4de59fc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9464,6 +9464,30 @@ (define-public perl-string-escape
removing double-quotes, and truncating to fit within a desired length.")
(license (package-license perl))))
+(define-public perl-string-format
+ (package
+ (name "perl-string-format")
+ (version "1.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SR/SREZIC/String-Format-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y77frxzjifd4sw0j19cc346ysas1mya84rdxaz279lyin7plhcy"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/String-Format")
+ (synopsis "Format sprintf-like strings with arbitrary format definitions")
+ (description
+ "@code{String::Format} lets you define arbitrary printf-like format
+sequences to be expanded. This module would be most useful in configuration
+files and reporting tools, where the results of a query need to be formatted in
+a particular way. It was inspired by
+@url{http://www.mutt.org/doc/manual/manual.html#index-format,mutt's
+@code{index_format} and related directives}.")
+ (license license:gpl2)))
+
(define-public perl-string-formatter
(package
(name "perl-string-formatter")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 5/8] gnu: Add perl-ppix-regexp.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-5-eu@euandre.org
* gnu/packages/perl.scm (perl-ppix-regexp): New variable.
---
gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d6e4de59fc..6022720b1f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8786,6 +8786,30 @@ (define-public perl-ppi
code.")
(license license:perl-license)))
+(define-public perl-ppix-regexp
+ (package
+ (name "perl-ppix-regexp")
+ (version "0.085")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/W/WY/WYANT/PPIx-Regexp-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "07fg63ql3f7hv1ys10l8j0p562ndraq9lk66iw9y0f444j4vpw1f"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-ppi))
+ (home-page "https://metacpan.org/release/PPIx-Regexp")
+ (synopsis "Parse Perl string literals and string-literal-like things")
+ (description
+ "The purpose of the @code{PPIx-Regexp} package is to parse
+regular expressions in a manner similar to the way the @code{PPI} package parses
+Perl. This class forms the root of the parse tree, playing a role similar to
+@code{PPI::Document}.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 6/8] gnu: Add perl-ppix-quotelike.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-6-eu@euandre.org
* gnu/packages/perl.scm (perl-ppix-quotelike): New variable.
---
gnu/packages/perl.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6022720b1f..acd4db5efc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8810,6 +8810,29 @@ (define-public perl-ppix-regexp
@code{PPI::Document}.")
(license license:perl-license)))
+(define-public perl-ppix-quotelike
+ (package
+ (name "perl-ppix-quotelike")
+ (version "0.023")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/W/WY/WYANT/PPIx-QuoteLike-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08ad4d20afvi1c4xzwbfk94lmf6gwlmqkdrpjxzf0lrcklaa6xim"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-ppi perl-ppix-regexp perl-readonly))
+ (home-page "https://metacpan.org/release/PPIx-QuoteLike")
+ (synopsis "Parse Perl string literals and string-literal-like things")
+ (description
+ "@code{PPIX::QuoteLike} parses Perl string literals and things that
+are reasonably like string literals. Its real reason for being is to find
+interpolated variables for @code{Perl::Critic} policies and similar code.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 7/8] gnu: Add perl-ppix-utilities.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-7-eu@euandre.org
* gnu/packages/perl.scm (perl-ppix-utilities): New variable.
---
gnu/packages/perl.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index acd4db5efc..f602181f05 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8833,6 +8833,33 @@ (define-public perl-ppix-quotelike
interpolated variables for @code{Perl::Critic} policies and similar code.")
(license license:perl-license)))
+(define-public perl-ppix-utilities
+ (package
+ (name "perl-ppix-utilities")
+ (version "1.001000")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/EL/ELLIOTJS/PPIx-Utilities-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16yb7dnz8lgq2azs8jxj1wac60kbn16x8y4py04ci8nndww87903"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build perl-test-deep))
+ (propagated-inputs (list perl-exception-class perl-ppi perl-readonly-xs
+ perl-task-weaken))
+ (home-page "https://metacpan.org/release/PPIx-Utilities")
+ (synopsis "Extensions to PPI")
+ (description
+ "@code{PPIx::Utilities} is a collection of functions for dealing
+with @code{PPI} objects, many of which originated in @code{Perl::Critic}. They
+are organized into modules by the kind of @code{PPI} class they relate to, by
+replacing the \"@code{PPI}\" at the front of the module name with
+\"@code{PPIx::Utilities}\", e.g. functionality related to @code{PPI::Nodes} is
+in @code{PPIx::Utilities::Node}.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")
--
2.38.0
E
E
EuAndreh wrote on 18 Oct 2022 03:38
[PATCH 8/8] gnu: Add perl-critic.
(address . 58603@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221018013818.12165-8-eu@euandre.org
* gnu/packages/perl.scm (perl-critic): New variable.
---
gnu/packages/perl.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f602181f05..6b9e3f526e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2262,6 +2262,51 @@ (define-public perl-cpanel-json-xs
versa.")
(license (package-license perl))))
+(define-public perl-critic
+ (package
+ (name "perl-critic")
+ (version "1.140")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PE/PETDANCE/Perl-Critic-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1nzxpn71mrpp85yxrxlraj52q2skvf9ja887ls11d57h6smg1vmz"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build perl-test-deep))
+ (propagated-inputs (list perltidy
+ perl-exception-class
+ perl-io-string
+ perl-ppi
+ perl-ppix-regexp
+ perl-b-keywords
+ perl-config-tiny
+ perl-padwalker
+ perl-test-memory-cycle
+ perl-file-which
+ perl-list-moreutils
+ perl-module-pluggable
+ perl-pod-parser
+ perl-pod-spell
+ perl-ppix-quotelike
+ perl-ppix-utilities
+ perl-readonly
+ perl-string-format
+ perl-task-weaken))
+ (home-page "https://metacpan.org/release/Perl-Critic")
+ (synopsis "Critique Perl source code for best-practices")
+ (description
+ "@code{perlcritic} is a Perl source code analyzer. It is the
+executable front-end to the @code{Perl::Critic} engine, which attempts to
+identify awkward, hard to read, error-prone, or unconventional constructs in
+your code. Most of the rules are based on Damian Conway's book \"Perl Best
+Practices\". However, @code{perlcritic} is not limited to enforcing PBP, and it
+will even support rules that contradict Conway. All rules can easily be
+configured or disabled to your liking.")
+ (license license:perl-license)))
+
(define-public perl-crypt-cbc
(package
(name "perl-crypt-cbc")
--
2.38.0
C
C
Christopher Baines wrote on 18 Oct 2022 12:24
Re: [bug#58603] [PATCH 0/8] Add perlcritic
(name . EuAndreh)(address . eu@euandre.org)(address . 58603-done@debbugs.gnu.org)
87k04xfmz0.fsf@cbaines.net
EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (22 lines)
> Add the "perlcritic" package, and all the modules that it requires that
> were not already packaged.
>
> All packages were styled with './pre-inst-env guix style' and built
> twice reproducibly.
>
> Note: the new "perl-string-format" is a different package than the
> existing "perl-string-formatter".
>
> EuAndreh (8):
> gnu: Add perl-config-tiny.
> gnu: Add perl-pod-spell.
> gnu: Add perl-readonly-xs.
> gnu: Add perl-string-format.
> gnu: Add perl-ppix-regexp.
> gnu: Add perl-ppix-quotelike.
> gnu: Add perl-ppix-utilities.
> gnu: Add perl-critic.
>
> gnu/packages/perl.scm | 245 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 245 insertions(+)

Thanks! Pushed to master as b857d239e7975b6b474674a06e663abec610d59e.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNOfvNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfOmg//QiulLpdUOqtZ/wDxgBYYxlxKj6be5LCR
mqUDFLG/3+KvRfQVSq4So/1W1HXiMadq1vOPe2W9wdJy4O/7DxgSYCny4eYkbAw6
tPCZgsefowPtISPCZYpQLeZnsmTMvIvBlrr2dqrozDOSr+duafcaCYa9FGKoIy14
1nR+h495hBVZk2WINv+jeTiqrtXSScReH4QCg8JIA/4VXAAZ8eLsZAlid7atCNjE
rOX+tI0OVd3VcHNShTljlKTbl4RspaxGomW9++1E7F+gEdtS/RdYvpjq5WKg2zBs
HlF99Y9ozuLSgrKMGueZfZ9IATwUuHZjqz7t1Acpqh8QSuaycN8Ez+VXIDkafpv5
ZJgx38ctKmv37HBcSTxuKrpK9lP7DC5EwBUVeFrpLNPwpHJOTZ460GNvuXFU0FwH
VLdQJpSqI4nz/OV6hQEZ7kerToYd15hQraStyoCJp8N8BB9M+vXmCVK9zUWatqFw
L5R1vfl3hLSeSzNAqx/SANjkKuhl26C0q902nmkDXT6wFLNNGiAIqD0uvjoo7N9d
NPMm23RHMU0Re3Ek8QaMi+hszBzY7hiutWazU5wfQg/QZLm94awi5O6fS1Rmk0VO
rbkC3ZoHUrRkhj+L6gIS2ROWme6aW57Aaf1tZduFAhocnLmgab2+BB6OrczdCfIM
NoG/njk6o9M=
=aPfR
-----END PGP SIGNATURE-----

Closed
?