[PATCH] gnu: Fix dbus session address in home-dbus-shepherd-services and home-dbus-environment-variables

  • Done
  • quality assurance status badge
Details
4 participants
  • Sughosha
  • Christopher Baines
  • Maxim Cournoyer
  • (
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
6B8PVUNJFWE65EEQjuqmH-PLzud7XaJZQ7M1VWklTB4FboCffQez3Tn0H5rLpEcwBJk-4o7StU9b2r0QbN3OHfR_KephR_IZ21vFdd50xjc=@proton.me
* gnu/home/services/desktop.scm
(home-dbus-shepherd-services): Fix dbus session address.
(home-dbus-environment-variables): Fix dbus session address.

Currently if home-dbus-service-type is enabled, the GDM session crashes. This
fix should possibly prevent it. However, I could not test it since reconfiguring
guix home with pre-inst-env doesn't make any change and I don't know any other
method.
---
gnu/home/services/desktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
index e94e666d93..91e39af36c 100644
--- a/gnu/home/services/desktop.scm
+++ b/gnu/home/services/desktop.scm
@@ -196,7 +196,7 @@ (define (home-dbus-shepherd-services config)
(list #$(file-append (home-dbus-dbus config)
"/bin/dbus-daemon")
"--nofork" "--session"
- (format #f "--address=unix:path=~a/bus"
+ (format #f "--address=unix:path=~a/dbus.lock"
(or (getenv "XDG_RUNTIME_DIR")
(format #f "/run/user/~a"
(getuid)))))
@@ -211,7 +211,7 @@ (define (home-dbus-shepherd-services config)
(define (home-dbus-environment-variables config)
'(("DBUS_SESSION_BUS_ADDRESS"
- . "unix:path=${XDG_RUNTIME_DIR:-/run/user/$UID}/bus")))
+ . "unix:path=${XDG_RUNTIME_DIR:-/run/user/$UID}/dbus.lock")))
(define home-dbus-service-type
(service-type
--
2.38.0
( wrote 2 years ago
CNO6CEM9GTCE.207GW38OK6BRK@guix-framework
Hello,

On Mon Oct 17, 2022 at 12:43 PM BST, Sughosha via Guix-patches via wrote:
Toggle quote (2 lines)
> Currently if home-dbus-service-type is enabled, the GDM session crashes.

Oopsie. :)

Toggle quote (3 lines)
> However, I could not test it since reconfiguring guix home with pre-inst-env
> doesn't make any change and I don't know any other method.

``./pre-inst-env guix home reconfigure ~/conf/home.scm'' works for me... I'll
test it, one moment :)

-- (
Christopher Baines wrote 2 years ago
tag 58582 moreinfo
(address . control@debbugs.gnu.org)
87fsf0j9wb.fsf@cbaines.net
tags 58582 + moreinfo
quit
Maxim Cournoyer wrote 2 years ago
Re: bug#58582: [PATCH] gnu: Fix dbus session address in home-dbus-shepherd-services and home-dbus-environment-variables
(name . ()(address . paren@disroot.org)
87k023z2ma.fsf_-_@gmail.com
Hello,

"(" <paren@disroot.org> writes:

Toggle quote (13 lines)
> Hello,
>
> On Mon Oct 17, 2022 at 12:43 PM BST, Sughosha via Guix-patches via wrote:
>> Currently if home-dbus-service-type is enabled, the GDM session crashes.
>
> Oopsie. :)
>
>> However, I could not test it since reconfiguring guix home with pre-inst-env
>> doesn't make any change and I don't know any other method.
>
> ``./pre-inst-env guix home reconfigure ~/conf/home.scm'' works for me... I'll
> test it, one moment :)

Friendly ping :-)

--
Thanks,
Maxim
Sughosha wrote 2 years ago
(name . 58582@debbugs.gnu.org)(address . 58582@debbugs.gnu.org)
lWQCWjcchbJLkHtRrJaE6tewaOtZZi1YuKGjUh8g1CRqJbc_2aWqsquJwGBZxaeFAcl-pcF3lyaDIWHJb7vBzyn60qAPVqIlmEVCXgdKnuQ=@proton.me
I am not sure what had caused the problem, but now I don't have this problem anymore.

tags 58582 notabug
close 58582
quit
Sughosha wrote 1 years ago
(No Subject)
(name . control)(address . control@debbugs.gnu.org)
hWMN3251WZf1BHruqYeT8dlTc6Hdj7rQLybFTfBFP5lhPirWp5lMCsIk85xun9FM2obrgOC781vkZbH9Np0m9Hy1fwEPKmYeMFEIZ8NlRyI=@proton.me
tags 58582 notabug
close 58582
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58582@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58582
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help