[PATCH] gnu: slade: Update to 3.2.1, use new package style.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • James Smith
Owner
unassigned
Submitted by
James Smith
Severity
normal
J
J
James Smith wrote on 17 Oct 2022 00:49
(address . guix-patches@gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
20221016224921.8205-1-jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (slade): Update to 3.2.1.
[arguments]: Use G-expressions.
[phases]: Removed reset-slade.pk3-timestamp phase.
[inputs]: Remove input labels. Add lua and mpg123. Replaced wxwidgets-3.1 with
wxwidgets.
---
gnu/packages/game-development.scm | 67 ++++++++++++++-----------------
1 file changed, 30 insertions(+), 37 deletions(-)

Toggle diff (97 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index d40a97eef2..83355d9886 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
-;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020-2022 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
@@ -516,52 +516,45 @@ (define-public python-xsge
(define-public slade
(package
(name "slade")
- (version "3.1.13")
+ (version "3.2.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/sirjuddington/SLADE")
(commit version)))
- (sha256 (base32 "009yc5m6y074wfalvwbrnv2zsmaf9yhbi8hzgs973di0zqnqv011"))
+ (sha256 (base32 "11ab38nv190lpvkdba5r2gckdrk4h15pri0zzslz7zy8qzg5fm18"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
- (list "-DWX_GTK3=ON" "-DNO_WEBVIEW=ON"
- (string-append "-DWITH_WXPATH="
- (assoc-ref %build-inputs "wxwidgets") "/bin")
- (string-append "-DwxWidgets_LIBRARIES="
- (assoc-ref %build-inputs "wxwidgets") "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'reset-slade.pk3-timestamps
- ;; This is neccessary to make slade reproducible due to
- ;; <https://bugs.gnu.org/44741>. TODO: Remove on next core update
- ;; cycle.
- (lambda _
- (invoke "find" "../source/dist/res" "-exec" "touch"
- "--no-dereference" "-t" "197001010000.00" "{}"
- "+")))
- (add-after 'install 'wrap-with-x11-gdk-backend
- ;; Set GDK_BACKEND to x11 to prevent crash on Wayland.
- ;; See https://github.com/sirjuddington/SLADE/issues/1097 for details.
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-program
- (string-append (assoc-ref outputs "out")
- "/bin/slade")
- '("GDK_BACKEND" = ("x11"))))))
- #:tests? #f)) ;; No test suite.
+ (list #:configure-flags
+ #~(list "-DWX_GTK3=ON" "-DNO_WEBVIEW=ON"
+ (string-append "-DWITH_WXPATH="
+ #$(this-package-input "wxwidgets") "/bin")
+ (string-append "-DwxWidgets_LIBRARIES="
+ #$(this-package-input "wxwidgets") "/lib"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-with-x11-gdk-backend
+ ;; Set GDK_BACKEND to x11 to prevent crash on Wayland.
+ ;; See https://github.com/sirjuddington/SLADE/issues/1097 for
+ ;; details.
+ (lambda _
+ (wrap-program (string-append #$output "/bin/slade")
+ '("GDK_BACKEND" = ("x11"))))))
+ #:tests? #f)) ;; No test suite.
(inputs
- `(("bash" ,bash-minimal)
- ("curl" ,curl)
- ("fluidsynth" ,fluidsynth)
- ("freeimage" ,freeimage)
- ("ftgl" ,ftgl)
- ("glew" ,glew)
- ("gtk+" ,gtk+)
- ("sfml" ,sfml)
- ("wxwidgets" ,wxwidgets-3.1)))
+ (list bash-minimal
+ curl
+ fluidsynth
+ freeimage
+ ftgl
+ glew
+ gtk+
+ lua
+ mpg123
+ sfml
+ wxwidgets))
(native-inputs
(list pkg-config which zip))
(home-page "https://slade.mancubus.net")
--
2.38.0
E
E
Efraim Flashner wrote on 15 Nov 2022 11:31
(name . James Smith)(address . jsubuntuxp@disroot.org)(address . 58574-done@debbugs.gnu.org)
Y3Nqaq8wcETufceR@3900XT
Normally I'd split this into two, one to update the package and the
second to switch to g-exps.

Patch pushed. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmNzamoACgkQQarn3Mo9
g1FvKw/9HU0YIJAYB1aKstyAmaFv1lhk0Zv7Tqc/NH8F3u6LMO0nn/pHqPz7Pp0z
Nsq86PTyRim+tTbjZQrHscahU/7mS7buyTVwVdnp39Edm8BnU17pWmA/tGPED7PL
JW8PyZ3XWgKDZ6Mjg51u/5atVYBHeZ3VfLBw927f8T/yiMB5FuYoV6x31k4DBHU5
BtmpGp6H0R0EIB6d6Aaan55cG928t0HOojdCsex9mPPhTWYdvM2usOW2fcN1v6Gf
poNS6uNTb7PuIDGAAET2yamQkcTV3z15sLSrBZw/0gkIvNXpcwf7w/FLCHZ9qdNZ
uqNQJeNfLYRBRcp/burFJyBkDWDN1F7ueCBy9tUTM9NKXXp8otqJCI+FXnfI5Ncy
FK76wPLYUodBtQyrz5WNtLBMGDxLINsPhoVuBZ3GsXJsow7vW3XmOvt1yrxYIWGK
4wLKzEES+eT/0T2w1WWodoUOZvEoxXHRSyFxgdZhXE8FN5CxiRIBgTf9WaOBcLEA
WnWuXJDaYb6c54hM/0GO75XzH/KsHBeSz/RbOVtffS9xlDlXWuCu40ttktQ0AyL8
4U9QsWVj4uudgx1PSAEG2Y2W7XDgvE280607VvL918uJgSCAFmmxl1y2taaroJsS
KHXGCAWMU/Q4NqErMuAOYBsqFP0OoJxKHbXzxXXMl9qg3TaujKk=
=BQJr
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58574@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58574
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch