Rust 1.58.1 fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 16 Oct 2022 04:11
(address . bug-guix@gnu.org)
c2165d48-2bde-e7d9-1437-069e4d6f37c4@brendan.scot
   Compiling toml v0.5.7

error: use of deprecated associated function `std::array::IntoIter::<T,
N>::new`: use `IntoIterator::into_iter` instead
    --> src/bootstrap/lib.rs:1046:31
     |
1046 |         std::array::IntoIter::new(options).flatten()
     |                               ^^^
     |
     = note: `-D deprecated` implied by `-D warnings`

error: could not compile `bootstrap` due to previous error
failed to run:
/gnu/store/njjhb4ql1bpb1qj5ksmjgnhaxmy093nz-rust-1.60.0-cargo/bin/cargo
build --manifest-path
/tmp/guix-build-rust-1.58.1.drv-0/rustc-1.58.1-src/src/bootstrap/Cargo.toml
--frozen
Build completed unsuccessfully in 0:00:12
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "./x.py" arguments: ("-j16" "build"
"library/std" "src/tools/cargo" "src/tools/rustfmt") exit-status: 1
term-signal: #f stop-signal: #f>
phase `build' failed after 12.3 seconds
command "./x.py" "-j16" "build" "library/std" "src/tools/cargo"
"src/tools/rustfmt" failed with status 1
L
L
Ludovic Courtès wrote on 20 Oct 2022 12:36
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 58559@debbugs.gnu.org)
87sfjig4s6.fsf@gnu.org
Hi Brendan,

Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (27 lines)
>    Compiling toml v0.5.7
>
> error: use of deprecated associated function
> `std::array::IntoIter::<T, N>::new`: use `IntoIterator::into_iter`
> instead
>     --> src/bootstrap/lib.rs:1046:31
>      |
> 1046 |         std::array::IntoIter::new(options).flatten()
>      |                               ^^^
>      |
>      = note: `-D deprecated` implied by `-D warnings`
>
> error: could not compile `bootstrap` due to previous error
> failed to run:
> /gnu/store/njjhb4ql1bpb1qj5ksmjgnhaxmy093nz-rust-1.60.0-cargo/bin/cargo
> build --manifest-path
> /tmp/guix-build-rust-1.58.1.drv-0/rustc-1.58.1-src/src/bootstrap/Cargo.toml
> --frozen
> Build completed unsuccessfully in 0:00:12
> error: in phase 'build': uncaught exception:
> %exception #<&invoke-error program: "./x.py" arguments: ("-j16"
> "build" "library/std" "src/tools/cargo" "src/tools/rustfmt")
> exit-status: 1 term-signal: #f stop-signal: #f>
> phase `build' failed after 12.3 seconds
> command "./x.py" "-j16" "build" "library/std" "src/tools/cargo"
> "src/tools/rustfmt" failed with status 1

Could you share the output of ‘guix describe’ and that of ‘uname -m’ so
we can understand how to reproduce the issue?

FWIW, with a commit of today, Rust 1.58 is available on x86_64-linux:

Toggle snippet (6 lines)
$ guix time-machine --commit=4716cea6256523a8ecf90a426d675bfb7620f3e4 -- build -n -e '(@@ (gnu packages rust) rust-1.58)'
122.9 MB would be downloaded:
/gnu/store/jpnrafjr9l8yanhr2lwvdmi7w7mg1jl4-rust-1.58.1-cargo
/gnu/store/v9swg7qw0hbxw8q32wfkp418wq6r4k97-rust-1.58.1

Thanks,
Ludo’.
B
B
Brendan Tildesley wrote on 27 Oct 2022 10:18
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58559@debbugs.gnu.org)
172d2619-a55e-6458-0c0f-ae767e64c8ee@brendan.scot
On 20/10/22 20:36, Ludovic Courtès wrote:
Toggle quote (4 lines)
> Hi Brendan,
>
> Brendan Tildesley <mail@brendan.scot> skribis:
>
My apologies. Thanks to the power of rollbacks and the guix cli I was
able to determine it was a rust variant defined in a channel
I was using, and is no longer an issue any more. so case closed.
Thanks.
Toggle quote (3 lines)
>
> Thanks,
> Ludo’.
B
B
Brendan Tildesley wrote on 27 Oct 2022 10:20
Rust 1.58.1 fails to build
(address . 58559-close@debbugs.gnu.org)
4a332bf7-1856-ee27-8388-4521b5ed016e@brendan.scot
bug was due to an unofficial channel. case closed.
L
L
Ludovic Courtès wrote on 3 Nov 2022 15:50
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 58559-done@debbugs.gnu.org)
87v8nwqehm.fsf@gnu.org
Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (9 lines)
> On 20/10/22 20:36, Ludovic Courtès wrote:
>> Hi Brendan,
>>
>> Brendan Tildesley <mail@brendan.scot> skribis:
>>
> My apologies. Thanks to the power of rollbacks and the guix cli I was
> able to determine it was a rust variant defined in a channel
> I was using, and is no longer an issue any more. so case closed.

Alright, closing!

Ludo’.
Closed
?