[PATCH draft] installer: welcome: Warn when uvesafb gets used.

  • Done
  • quality assurance status badge
Details
3 participants
  • Mathieu Othacehe
  • Mathieu Othacehe
  • pelzflorian (Florian Pelz)
Owner
unassigned
Submitted by
pelzflorian (Florian Pelz)
Severity
normal
P
P
pelzflorian (Florian Pelz) wrote on 15 Oct 2022 17:39
(address . guix-patches@gnu.org)
87h7055c6g.fsf@pelzflorian.de
There will be false positives: Because the Guix installer uses the
kernel argument modprobe.blacklist=radeon,amdgpu and some AMD graphics
actually work okay according to h-node, these users will get a
false alarm.

* gnu/installer/newt/welcome.scm (run-welcome-page): Warn before showing
the welcome page.
---
gnu/installer/newt/welcome.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/installer/newt/welcome.scm b/gnu/installer/newt/welcome.scm
index 7a7ddfb7bd..762fca96eb 100644
--- a/gnu/installer/newt/welcome.scm
+++ b/gnu/installer/newt/welcome.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2022 Florian Pelz <pelzflorian@pelzflorian.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,6 +18,8 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu installer newt welcome)
+ #:use-module ((gnu build linux-modules)
+ #:select (modules-loaded))
#:use-module (gnu installer steps)
#:use-module (gnu installer utils)
#:use-module (gnu installer newt page)
@@ -121,6 +124,14 @@ (define (run-welcome-page logo)
"Run a welcome page with the given textual LOGO displayed at the center of
the page. Ask the user to choose between manual installation, graphical
installation and reboot."
+ (begin
+ (when (member "uvesafb" (modules-loaded))
+ (run-error-page (G_ "\
+This may be a false alarm, but possibly your graphics hardware does not
+work well with only free software. Expect trouble. If after installation,
+the system does not boot, perhaps you will need to add nomodeset to the
+kernel arguments and need to configure the uvesafb kernel module.")
+ (G_ "Pre-install warning")))
(run-menu-page
(G_ "GNU Guix install")
(G_ "Welcome to GNU Guix system installer!
@@ -148,3 +159,4 @@ (define (run-welcome-page logo)
(newt-finish)
(reboot))))
#:listbox-item->text car))
+ )

base-commit: d923cf1deac0b6762345d0d9e53822cbcb899365
--
2.37.3
P
P
pelzflorian (Florian Pelz) wrote on 15 Oct 2022 17:47
(address . 58549@debbugs.gnu.org)
87wn91w0k5.fsf@pelzflorian.de
P.S. This patch was sent in response to https://issues.guix.gnu.org/58357#6
It can be tested on non-affected machines by adding the word nomodeset
in GRUB to the linux boot line.

Regards,
Florian
M
M
Mathieu Othacehe wrote on 17 Oct 2022 11:40
Re: bug#58549: [PATCH draft] installer: welcome: Warn when uvesafb gets used.
(name . pelzflorian (Florian Pelz))(address . pelzflorian@pelzflorian.de)(address . 58549@debbugs.gnu.org)
87lepen5yn.fsf@gnu.org
Hello Florian,

Toggle quote (8 lines)
> + (when (member "uvesafb" (modules-loaded))
> + (run-error-page (G_ "\
> +This may be a false alarm, but possibly your graphics hardware does not
> +work well with only free software. Expect trouble. If after installation,
> +the system does not boot, perhaps you will need to add nomodeset to the
> +kernel arguments and need to configure the uvesafb kernel module.")
> + (G_ "Pre-install warning")))

This seems like a good idea to me. Perhaps we could be a bit more
specific about the "expected troubles". Is it a black screen after Linux
boot on the installed system?

Thanks,

Mathieu
P
P
pelzflorian (Florian Pelz) wrote on 24 Oct 2022 15:39
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 58549@debbugs.gnu.org)
877d0ptk5u.fsf@pelzflorian.de
Please excuse my slow response.

Mathieu Othacehe <othacehe@gnu.org> writes:
Toggle quote (12 lines)
>> + (when (member "uvesafb" (modules-loaded))
>> + (run-error-page (G_ "\
>> +This may be a false alarm, but possibly your graphics hardware does not
>> +work well with only free software. Expect trouble. If after installation,
>> +the system does not boot, perhaps you will need to add nomodeset to the
>> +kernel arguments and need to configure the uvesafb kernel module.")
>> + (G_ "Pre-install warning")))
>
> This seems like a good idea to me. Perhaps we could be a bit more
> specific about the "expected troubles". Is it a black screen after Linux
> boot on the installed system?

With my somewhat older AMD systems, that the system doesn’t boot
actually is a white lie. When using Xorg, the display locks up to a
still image (not black but the previous unrelated boot messages), but
IIRC it boots fine otherwise and can be used blindly. So in the common
case of AMD, it could be said that “the display locks up to a still
image”. Maybe that is not true in general though.

With SiS graphics on my vintage Uniwill One laptop, this would be not
true. On cold boots, the laptop goes to kind of an infinite suspend
state. On reboots, GDM just doesn’t start, but the virtual console is
usable.


Thinking about it, the false alarms are not nice, but I don’t know if
Ludo’s proposed device check https://issues.guix.gnu.org/58357#4 would
be reasonably doable and he actually wasn’t mentioning it in relation to
graphics. I think this patch is right (after fixing the indentation).
Shall I push or make more changes?

Regards,
Florian
M
M
Mathieu Othacehe wrote on 24 Oct 2022 16:20
(name . pelzflorian (Florian Pelz))(address . pelzflorian@pelzflorian.de)(address . 58549@debbugs.gnu.org)
87v8o9nw0s.fsf@gnu.org
Hello Florian,

Toggle quote (6 lines)
> Thinking about it, the false alarms are not nice, but I don’t know if
> Ludo’s proposed device check <https://issues.guix.gnu.org/58357#4> would
> be reasonably doable and he actually wasn’t mentioning it in relation to
> graphics. I think this patch is right (after fixing the indentation).
> Shall I push or make more changes?

Ludo firmware load detection seems like a good idea to me but we would
need to study the feasibility.

Your patch seems OK to me, you can go ahead.

Mathieu
M
M
Mathieu Othacehe wrote on 31 Oct 2022 09:33
control message for bug #58549
(address . control@debbugs.gnu.org)
87sfj4gzp7.fsf@meije.mail-host-address-is-not-set
close 58549
quit
?