[PATCH] gnu: Add s3cmd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Matthew James Kraai
  • Christopher Baines
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal

Debbugs page

Matthew James Kraai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20221014133701.4764-1-kraai@ftbfs.org
* gnu/packages/python-xyz.scm (python-s3cmd): New variable.
---
gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c647bd42f..3c5b247df8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,7 +75,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
-;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2020, 2022 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
@@ -16189,6 +16189,32 @@ (define-public python-magic
the same purpose: to provide Python bindings for libmagic.")
(license license:expat)))
+(define-public python-s3cmd
+ (package
+ (name "python-s3cmd")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/s3tools/s3cmd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rdgwwmmp8mdxc84bxq6k9a7v7z2qgc3df47djzs2b84gw81dglx"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-dateutil python-magic))
+ (home-page "https://s3tools.org/s3cmd")
+ (synopsis "Command line tool for S3-compatible storage services")
+ (description
+ "S3cmd is a command line tool for uploading, retrieving and managing data
+in storage services that are compatible with the Amazon Simple Storage
+Service (S3) protocol, including S3 itself. It supports rsync-like backup,
+GnuPG encryption, and more. It also supports management of Amazon's
+CloudFront content delivery network.")
+ (license license:gpl2+)))
+
(define-public python-pkgconfig
(package
(name "python-pkgconfig")
--
2.38.0
Christopher Baines wrote 2 years ago
(name . Matthew James Kraai)(address . kraai@ftbfs.org)(address . 58514-done@debbugs.gnu.org)
87v8ojaa4l.fsf@cbaines.net
Matthew James Kraai <kraai@ftbfs.org> writes:

Toggle quote (5 lines)
> * gnu/packages/python-xyz.scm (python-s3cmd): New variable.
> ---
> gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-
> 1 file changed, 27 insertions(+), 1 deletion(-)

Thanks Matthew, I've gone ahead and pushed this to master as
cf19228932eff2ede5f39f4fdc759374e3b89991.

I made a few tweaks, all around packaging this more as a tool than a
Python library. I made the inputs plain inputs rather than propagated
inputs, since that'll interfere less with users profiles, and I also
just named the package s3cmd, since the python bit is not particularly
relevant.

Thanks again,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNMTzpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdgIA/8DI//+eAuY//1so1F18YZA53bYR+9SoQL
NkVomgJEu8PU039IYvKVcybcV6xwBDBwvVtAnplFilGZV4nGpbqHB2Prclg99bfD
AeQl/neCNvemxS2DkOEdehycM7wcTOv5V9PzugWD53sLUTqNMuzih56u/LJ+SBMG
M1s57to4qD5BJkyh/dQCskcFBgIYjmQpJWGdUo8f6dJ+kVhXqsYeNWYtNs32oHzZ
Ko3YcGDKcDRIQZrqpLSpTJff4cif/dKFX+uq9DhwItxUXbgsJtrtuOmg2LAuPBEy
m+WIABjBQAKuvwKe6RRCSdOCqkNN0+F3UOKSvG9ioBPgtF/Pt/EirmlvPNqGQWoD
E6oNaUk29NWtiiWmxh7Z0ZIHcqmoVVWGGVn2ufnp8gsr5LACXceIbzA1rcNPagIk
zFDxN79rnQh21qfxDK/J/EY9jAKQm+Y8OpqwLOWcrpQ2NK165IJQOnjygiYeaKHG
YhXoHX8bsrwqMsj8szgiDYefyZQo8WV9gSCIeGp6/PHVNuEIkKmLw8hsEiUSW5cU
Y7H3MhCJVIYG7FCcFsKc7yEY/n4/SkzKfq42WP84Qrcht2G7PKtibpmHIYZkbjWn
FpWzXKKn8Upu5Eckq0qX1U/jupInJ0ps6AXNEAGX17bWv6FXmkAldH5L/GpWA/U+
HLBKY5Ns3FA=
=bT3q
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58514@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58514
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help