[PATCH] gnu: Add r-eulerr. X-Debbugs-Cc: rekado@elephly.net

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20221014104143.315-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-eulerr): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c48ef78f4c..349b98d46b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19575,6 +19575,35 @@ (define-public r-ggforce
that fills this gap.")
(license license:expat)))
+(define-public r-eulerr
+ (package
+ (name "r-eulerr")
+ (version "6.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "eulerr" version))
+ (sha256
+ (base32
+ "0lldp2319qd08y87f862gx8a77rvikcnkmdl9xgx4glynfs3hk19"))))
+ (properties `((upstream-name . "eulerr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-gensa
+ r-polyclip
+ r-polylabelr
+ r-rcpp
+ r-rcpparmadillo))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/jolars/eulerr")
+ (synopsis "Area-proportional Euler and Venn diagrams with ellipses")
+ (description
+ "This package generates area-proportional Euler diagrams using numerical
+optimization. An Euler diagram is a generalization of a Venn diagram, relaxing
+the criterion that all interactions need to be represented. Diagrams may be
+fit with ellipses and circles via a wide range of inputs and can be visualized
+in numerous ways.")
+ (license license:gpl3)))
+
(define-public r-europepmc
(package
(name "r-europepmc")

base-commit: 10d429f2fce321d8285684503094694ec3979865
--
2.37.3
Ricardo Wurmus wrote 2 years ago
[PATCH] gnu: Add r-eulerr.
(address . 58510-done@debbugs.gnu.org)
8735b9idri.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58510@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58510
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help