opam import doesn't work with ocaml_intrinsics among others

  • Done
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Csepp
  • Simon Tournier
Owner
unassigned
Submitted by
Csepp
Severity
normal
C
(name . Bug reports for GNU Guix)(address . bug-guix@gnu.org)
87fsfr4s83.fsf@riseup.net
The error might not be the same for others, I have a slightly patched
opam->guix-package function.

guix import opam ocaml_intrinsics
Backtrace:
In ice-9/boot-9.scm:
1752:10 10 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
9 (apply-smob/0 #<thunk 7ff952d2f2e0>)
In ice-9/boot-9.scm:
724:2 8 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 7 (_ #(#(#<directory (guile-user) 7ff952d34c80>)))
In guix/ui.scm:
2263:7 6 (run-guix . _)
2226:10 5 (run-guix-command _ . _)
In guix/scripts/import.scm:
92:11 4 (guix-import . _)
In guix/scripts/import/opam.scm:
105:24 3 (guix-import-opam . _)
In guix/import/opam.scm:
385:24 2 (opam->guix-package _ #:repo _ #:version _)
In guix/import/utils.scm:
290:27 1 (beautify-description #f _)
In unknown file:
0 (string-trim-both #f #<undefined> #<undefined> #<undefi…>)

ERROR: In procedure string-trim-both:
In procedure string-trim-both: Wrong type argument in position 1 (expecting string): #f
J
J
Julien Lepiller wrote on 13 Oct 2022 18:37
Re: bug#58497: opam import doesn't wo rk with ocaml_intrinsics among others
8293CA82-3DB5-420A-843F-BDF3096C6F1B@lepiller.eu
(beautify-description #f _)

Seems to be the cause. Yet, there is a description. Maybe parsing ends a bit too soon?

Le 13 octobre 2022 18:07:08 GMT+02:00, Csepp <raingloom@riseup.net> a écrit :
Toggle quote (32 lines)
>The error might not be the same for others, I have a slightly patched
>opam->guix-package function.
>
>guix import opam ocaml_intrinsics
>Backtrace:
>In ice-9/boot-9.scm:
> 1752:10 10 (with-exception-handler _ _ #:unwind? _ # _)
>In unknown file:
> 9 (apply-smob/0 #<thunk 7ff952d2f2e0>)
>In ice-9/boot-9.scm:
> 724:2 8 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
>In ice-9/eval.scm:
> 619:8 7 (_ #(#(#<directory (guile-user) 7ff952d34c80>)))
>In guix/ui.scm:
> 2263:7 6 (run-guix . _)
> 2226:10 5 (run-guix-command _ . _)
>In guix/scripts/import.scm:
> 92:11 4 (guix-import . _)
>In guix/scripts/import/opam.scm:
> 105:24 3 (guix-import-opam . _)
>In guix/import/opam.scm:
> 385:24 2 (opam->guix-package _ #:repo _ #:version _)
>In guix/import/utils.scm:
> 290:27 1 (beautify-description #f _)
>In unknown file:
> 0 (string-trim-both #f #<undefined> #<undefined> #<undefi…>)
>
>ERROR: In procedure string-trim-both:
>In procedure string-trim-both: Wrong type argument in position 1 (expecting string): #f
>
>
>
Attachment: file
C
Re: bug#58497: opam import doesn't work with ocaml_intrinsics among others
(name . Julien Lepiller)(address . julien@lepiller.eu)
87y1tfy2lf.fsf@riseup.net
Julien Lepiller <julien@lepiller.eu> writes:

Toggle quote (4 lines)
> (beautify-description #f _)
>
> Seems to be the cause. Yet, there is a description. Maybe parsing ends a bit too soon?

That might explain issue 58112 as well. I have a workaround that gives
#f for description.
S
S
Simon Tournier wrote on 11 Oct 2023 11:02
(name . Csepp)(address . raingloom@riseup.net)(address . 58497@debbugs.gnu.org)
86lec9lefr.fsf@gmail.com
Hi,

It is about bug#58497 [1], and I cannot reproduce. I think the reported
bug had been fixed. I am in favor to close. WDYT?


On Thu, 13 Oct 2022 at 18:07, Csepp <raingloom@riseup.net> wrote:

Toggle quote (3 lines)
> guix import opam ocaml_intrinsics
> Backtrace:

Using Guix 6113e05, I get:

Toggle snippet (18 lines)
$ guix import opam ocaml_intrinsics
(package
(name "ocaml-intrinsics")
(version "0.16.0")
(source no-source-information)
(build-system dune-build-system)
(propagated-inputs (list ocaml-dune-configurator))
(properties `((upstream-name . "ocaml_intrinsics")))
(home-page "https://github.com/janestreet/ocaml_intrinsics")
(synopsis "Intrinsics")
(description
"This package provides functions to invoke amd64 instructions (such as
clz,popcnt,rdtsc,rdpmc) when available, or compatible software implementation on
other targets.")
(license license:expat))


Cheers,
simon
C
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
cucr0lz5zbv.fsf@riseup.net
Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (36 lines)
> Hi,
>
> It is about bug#58497 [1], and I cannot reproduce. I think the reported
> bug had been fixed. I am in favor to close. WDYT?
>
> 1: https://issues.guix.gnu.org/issue/58497
>
> On Thu, 13 Oct 2022 at 18:07, Csepp <raingloom@riseup.net> wrote:
>
>> guix import opam ocaml_intrinsics
>> Backtrace:
>
> Using Guix 6113e05, I get:
>
> --8<---------------cut here---------------start------------->8---
> $ guix import opam ocaml_intrinsics
> (package
> (name "ocaml-intrinsics")
> (version "0.16.0")
> (source no-source-information)
> (build-system dune-build-system)
> (propagated-inputs (list ocaml-dune-configurator))
> (properties `((upstream-name . "ocaml_intrinsics")))
> (home-page "https://github.com/janestreet/ocaml_intrinsics")
> (synopsis "Intrinsics")
> (description
> "This package provides functions to invoke amd64 instructions (such as
> clz,popcnt,rdtsc,rdpmc) when available, or compatible software implementation on
> other targets.")
> (license license:expat))
> --8<---------------cut here---------------end--------------->8---
>
>
> Cheers,
> simon

Yup, seems to "work" now, although that no-source-information thing is
still pretty irritating, but it happens infrequently enough to not
matter too much.
?