[PATCH 0/2] gnu: Add coturn

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Thomas Albers Raviola
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Thomas Albers Raviola
Severity
normal

Debbugs page

Thomas Albers Raviola wrote 2 years ago
(address . guix-patches@gnu.org)
87v8on20jf.fsf@alpha.mail-host-address-is-not-set
Hello,

the following patch series adds coturn to guix. Some notes:

- for some reason libevent is being compiled without openssl, so I had
to define a variant for coturn to use.

- gnu/packages/libevent.scm still used the old package-inputs syntax. I
am not sure if this is intentional, so I kept the old syntax for the
file even though it is deprecated.

- I'm not very good at describing packages, if someone has any
recomendations I can send a new patch.

Regards,
Thomas
Thomas Albers wrote 2 years ago
[PATCH 1/2] gnu: Add libevent-with-openssl
(address . 58496@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20221013154334.19906-1-thomas@thomaslabs.org
* gnu/packages/libevent.scm (libevent-with-openssl): New variable.
---
gnu/packages/libevent.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index d807315906..e0ba2b3d5b 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -76,6 +76,17 @@ (define-public libevent
loop.")
(license bsd-3)))
+(define-public libevent-with-openssl
+ (package
+ (inherit libevent)
+ (name "libevent-with-openssl")
+ (inputs
+ `(("openssl" ,openssl)
+ ,@(package-inputs libevent)))
+ (arguments
+ ;; This skips some of the tests which fail on armhf and aarch64.
+ '(#:configure-flags '("--disable-libevent-regress")))))
+
(define-public libev
(package
(name "libev")
--
2.38.0
Thomas Albers wrote 2 years ago
[PATCH 2/2] gnu: Add coturn
(address . 58496@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20221013154334.19906-2-thomas@thomaslabs.org
* gnu/packages/telephony.scm (coturn): New variable.
---
gnu/packages/telephony.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 5a7c3821ad..13feedbb2e 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Demis Balbach <db@minikn.xyz>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages file)
@@ -89,6 +91,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages readline)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages libevent)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
@@ -894,3 +897,32 @@ (define-public libtgvoip
telephony functionality into custom Telegram clients.")
(home-page "https://github.com/zevlg/libtgvoip")
(license license:unlicense)))
+
+(define-public coturn
+ (package
+ (name "coturn")
+ (version "4.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coturn/coturn")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "152v2lnjj9b3w61d8aak7hmi9riw9cjs5g54g1gfpzlyk4c2jw21"))))
+ (inputs
+ (list openssl
+ sqlite
+ libevent-with-openssl
+ hiredis))
+ (native-inputs
+ (list pkg-config))
+ (build-system gnu-build-system)
+ (synopsis "Implementation of a TURN and STUN server for VoIP")
+ (description
+ "This package provides a VoIP media traffic NAT traversal server and
+gateway. It implements the STUN (Session Traversal Utilities for NAT) and
+TURN (Traversal Using Relays around NAT) server protocols.")
+ (home-page "https://github.com/coturn/coturn")
+ (license license:bsd-3)))
--
2.38.0
Ludovic Courtès wrote 2 years ago
Re: bug#58496: [PATCH 0/2] gnu: Add coturn
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 58496@debbugs.gnu.org)
87tu3u3cjx.fsf_-_@gnu.org
Hi Thomas,

Thomas Albers <thomas@thomaslabs.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/libevent.scm (libevent-with-openssl): New variable.

I change (package (inherit libevent) …) to (package/inherit libevent …)
here, to preserve the ‘replacement’ field, if any.

I think we can change merge it with libevent and also update to the
“new” input style on the ‘core-updates’ branch.

Toggle quote (2 lines)
> * gnu/packages/telephony.scm (coturn): New variable.

Applied, thanks!

Ludo’.
Vagrant Cascadian wrote 2 years ago
Re: [bug#58496] [PATCH 0/2] gnu: Add coturn
(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)(address . 58496-done@debbugs.gnu.org)
878r9pp5hw.fsf@wireframe
On 2022-10-13, Thomas Albers Raviola wrote:
Toggle quote (5 lines)
> the following patch series adds coturn to guix. Some notes:
>
> - for some reason libevent is being compiled without openssl, so I had
> to define a variant for coturn to use.

Both coturn and libevent-with-openssl were added to guix:

9ed4251d70fb62e176f927129934a76a3dad2d64 gnu: Add libevent-with-openssl.
d117d225d99a99984b4cce082f5f1bdd18efc003 gnu: Add coturn.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPK47AAKCRDcUY/If5cW
qukqAQDLKoDIngGmgHQYnnHi81mkz0dtyANsBevTcCD38U/KnAD+L0oa794Vi+k8
MlQ6HHeblfh+ozy1kMFk7i0Yc8rpdAk=
=24Fo
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58496@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58496
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help