[PATCH] gnu: lziprecover: Fix cross-compilation.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
20221013124451.24923-1-mail@cbaines.net
* gnu/packages/comression.scm (lziprecover)[arguments]: Set CXX when cross
compiling.
---
gnu/packages/compression.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 684979018c..ba9f838130 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -653,6 +653,12 @@ (define-public lziprecover
(base32
"0wmmyi03fv2lflsir5ldrsv04q57k3hmlqajzb1m3p86gwbh967j"))))
(build-system gnu-build-system)
+ (arguments
+ ;; The configure script doesn't recognise the --build or --host
+ ;; arguments, so set CXX here
+ `(,@(if (%current-target-system)
+ `(#:make-flags (list ,(string-append "CXX=" (cxx-for-target))))
+ '())))
(home-page "https://www.nongnu.org/lzip/lziprecover.html")
(synopsis "Recover and decompress data from damaged lzip files")
(description
--
2.37.3
Christopher Baines wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 58492-done@debbugs.gnu.org)
87zgdvaa9g.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (6 lines)
> * gnu/packages/comression.scm (lziprecover)[arguments]: Set CXX when cross
> compiling.
> ---
> gnu/packages/compression.scm | 6 ++++++
> 1 file changed, 6 insertions(+)

Pushed to master as c3e103129d1fac8460e4e01e46749a0a72248ead.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNMTotfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfx2hAAk/7i1lueenlYTBVwAmmf6o0Wz0Qau0Uh
1ZVe0UsVx4VlVoZgl80XMB/TmzqvMwi1HZy5ZTjbjmBiR3qwUlrv36p2pjh5e5oe
HptuK8eaSAe0evNF2PNZX4SWXOGFckGuI2WicIPIgISMdh4lOIy4DK+BD3WptxNZ
o7NJ4Tqf+4DD7t4ElTIdrIU5AJaUIzYuDjoqoZtF2SGt2GD5IdqzIc+d5IAn44mp
GlmlRPSZzv++QxEFpXTg4mNpyENnUXFGM8C+W0sniDRbsceFsk1zrERmnoQqmVGj
D1ZKqc9rNSrGinImBJ63XqZxi2WMuqrg7rCZN5PHHO0rdQxyeHgx8vbNpJToJ1TI
DBLV8Iqy6erRuMJe597i45GM2QfXJlDfzhaZeZbpx0jqcsqosxIema9/1uZ9l/BZ
rP16lD2zSxTVFJSvy+dO2yrpsq6EbtrodyVXUsffbiXbJGBy/AF3oqxg5x/6ZSEY
Af+TicuvhGeK1cEwZrDVeMw5iMK0O9ym+Prkj5/HQ5xlh1y4LULQn6cA8IRjMDu1
Oi8kSDoMNKnBopQFIj6LjCwdnA95DuT8v9quPdml7uEJQTsgEJl2CWXWBMLQJi+D
ygO5mZBEVDrJO8tJ1gP2khcbvVTDWUlp33/SlWojCYvBbyy2QQkt0j0K5lhgvTnB
5SCU7aHXQCE=
=veql
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58492@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58492
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help