[PATCH] gnu: lzip: Fix cross-compilation.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
20221013123746.23004-1-mail@cbaines.net
Previously the package would build, but the binaries would be build for the
host system, rather than the target.

* gnu/packages/compression.scm (lzip)[arguments]: Set CXX when cross
compiling.
---
gnu/packages/compression.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 684979018c..dd0caa10ab 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -632,6 +632,12 @@ (define-public lzip
(base32
"0j59hx72258334rmkwn57ahr6s69nlrx0a5ip1jw2fbiwr12sd63"))))
(build-system gnu-build-system)
+ (arguments
+ ;; The configure script doesn't recognise the --build or --host
+ ;; arguments, so set CXX here
+ `(,@(if (%current-target-system)
+ `(#:make-flags (list ,(string-append "CXX=" (cxx-for-target))))
+ '())))
(home-page "https://www.nongnu.org/lzip/lzip.html")
(synopsis "Lossless data compressor based on the LZMA algorithm")
(description
--
2.37.3
Christopher Baines wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 58491-done@debbugs.gnu.org)
874jw3bowk.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (9 lines)
> Previously the package would build, but the binaries would be build for the
> host system, rather than the target.
>
> * gnu/packages/compression.scm (lzip)[arguments]: Set CXX when cross
> compiling.
> ---
> gnu/packages/compression.scm | 6 ++++++
> 1 file changed, 6 insertions(+)

Pushed to master as 69bbb720db7a77b4a8cd2973fb8e9a794b3213d3.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNMTitfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xdobw//ewYAsvrUM1QlKG38OWKNHO5FV331snr7
cIidb4QPRBf1Gq0stu1jhTkVqHWp/5v49Wuo5BbO5wtVvFdmAAUk7N12qYmvi+0E
3W5GGy1f17PF4xLnhW+w16BgwSlYIBiVAus0BYS2xXwRS1cwAw85PpZUfsC4TdlH
ygcBybHxAiCi9hL0nN/k8NAetRMOrTO3LZi4QORbLx6nYhpdnNI30EMnc1IyAwxk
/UDkCRs7SreXYKjlMO6OionpsaYzX87Ko72HMYeUfxIf0JAynIA512VMyFXueTmg
cv1VaArjVSXpmwqzHqx9xdT7tHBMPwmgaRhjbTcd7wQI7HVRYxqYmigVIg9CW/k5
5+lVXcsA/ImnREyapIJdTtID1ykbN+3MHr1ONBbfmejnmXyA+gQd3ztIM3ZSnk7O
1pD2nBD97oz6rtHbzDB3GgHlt5NL6wIKLIzqhFJG4VB/itQOamY022lZdgK9pThE
RvMm9t24hHkaTvqUrDshfxY4My/22cGCCB3Lqm0Z9SaccFtb6jmWx5rX4h+ldIi4
bj14lcZfVj9yzh4RSnvOrbfl8ubaIElkhtKxH2ijFKONYkV9r3qi9+D2YxhUTHBp
7gd7K9bBGCGwo5sfV0X2m2ToJ2ABrShSKdm4g0WjFbwGvHCSyOhiLQUnUI6Sx7pi
1rWdDwj2IlQ=
=0v+0
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58491@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58491
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help