[PATCH] gnu: gnome: Include aarch64 in librsvg-for-system.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 13 Oct 2022 12:20
(address . guix-patches@gnu.org)
20221013102048.22966-1-mail@cbaines.net
Since the staging merge, librsvg has been buildable for aarch64.

* gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
---
gnu/packages/gnome.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 09a991b14c..ff9d95c244 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3753,8 +3753,10 @@ (define* (librsvg-for-system #:optional
(system (or (%current-target-system)
(%current-system))))
;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
- ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
- (if (string-prefix? "x86_64-" system)
+ ;; on x86_64 and aarch64 so far, use the ancient C version on other
+ ;; platforms (FIXME).
+ (if (or (string-prefix? "x86_64-" system)
+ (string-prefix? "aarch64-" system))
librsvg
librsvg-2.40))
--
2.37.3
L
L
Ludovic Courtès wrote on 23 Oct 2022 15:10
(name . Christopher Baines)(address . mail@cbaines.net)(address . 58488@debbugs.gnu.org)
8735be4rex.fsf@gnu.org
Hi Chris,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (4 lines)
> Since the staging merge, librsvg has been buildable for aarch64.
>
> * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.

[...]

Toggle quote (7 lines)
> + ;; on x86_64 and aarch64 so far, use the ancient C version on other
> + ;; platforms (FIXME).
> + (if (or (string-prefix? "x86_64-" system)
> + (string-prefix? "aarch64-" system))
> librsvg
> librsvg-2.40))

Looks like a reasonable workaround to me. Go for it!

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 3 Nov 2022 16:32
(name . Christopher Baines)(address . mail@cbaines.net)(address . 58488@debbugs.gnu.org)
874jvgoxxw.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (22 lines)
> Since the staging merge, librsvg has been buildable for aarch64.
>
> * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
> ---
> gnu/packages/gnome.scm | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 09a991b14c..ff9d95c244 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -3753,8 +3753,10 @@ (define* (librsvg-for-system #:optional
> (system (or (%current-target-system)
> (%current-system))))
> ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
> - ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
> - (if (string-prefix? "x86_64-" system)
> + ;; on x86_64 and aarch64 so far, use the ancient C version on other
> + ;; platforms (FIXME).
> + (if (or (string-prefix? "x86_64-" system)
> + (string-prefix? "aarch64-" system))

With https://issues.guix.gnu.org/58661 now fixed, I think you can go
ahead and push this one, no?

Ludo’.
C
C
Christopher Baines wrote on 3 Nov 2022 17:46
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58488-done@debbugs.gnu.org)
87bkpom1ed.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (27 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Since the staging merge, librsvg has been buildable for aarch64.
>>
>> * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
>> ---
>> gnu/packages/gnome.scm | 6 ++++--
>> 1 file changed, 4 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> index 09a991b14c..ff9d95c244 100644
>> --- a/gnu/packages/gnome.scm
>> +++ b/gnu/packages/gnome.scm
>> @@ -3753,8 +3753,10 @@ (define* (librsvg-for-system #:optional
>> (system (or (%current-target-system)
>> (%current-system))))
>> ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
>> - ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
>> - (if (string-prefix? "x86_64-" system)
>> + ;; on x86_64 and aarch64 so far, use the ancient C version on other
>> + ;; platforms (FIXME).
>> + (if (or (string-prefix? "x86_64-" system)
>> + (string-prefix? "aarch64-" system))
>
> With <https://issues.guix.gnu.org/58661> now fixed, I think you can go
> ahead and push this one, no?

Indeed, thanks for the reminder, I've pushed to master as
754f260753fb6ebe28325616bc08336a184e4621.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNj8GpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfdEhAAs6k37blnGRM18+dzqqFYPlQhOTNvIYah
sTw4RGKFvr2Aaeg8LE2lhYt83RlaovLFt/0MxXU2+S8auW91Xx6fAguN+xTmUI91
vrUZvpWu9jBi09ft2DRemmmfapPt4MSQLIFKMMosYD8epG8johlhzjA3zXfBVzAP
NehTzv+ag851qSaVH/IYhJ29gXpiOCNJlwwuJj4O0+YFJ78QW6Q0QNvBamLQMNAE
E7jjaTV0FAuZynDa8lRJaZXCRKAMQO3ejRldlPjAFgQlrWxvqWjMHZG9diei017v
dO2tj9VHwr7uXhcrVtHS+/iMbUPc82u3LK4pmbjRIwcxEcN2nTYBoOl9Ov6ejrFR
sMWBsbbENGCRiMVuzGtUE6c9fKlUieRdoLEXKtdFeokX7t/KybGlgpi9gMndvqkE
FIzqluySOTVaWkuuLJoITvUmP4/4rWBcDhDztkbpq7DZm6Y8i8Pwy3GsIrGLSwFT
corZ+Wo88HT2Tjh3RtlgmF6gLLqKIcrVWGRCsYEW4QPOwhZ5tnlyFqeMe6iVcied
n63IGi73UW3GVwZ8TMtfiBBUhsGoc9oRZ/jMl2DjyNb1vUQRN1Q3rUq34XTyCb0V
1tLgZJcKvBWqSWpJb4rZFtpFRCpIJcaEQV5d1UtwdYnZIW3gG4q9nJonkM5SstPd
CWmENIffFCU=
=+/xt
-----END PGP SIGNATURE-----

Closed
?