[PATCH 0/1] gnu: home: home-dbus-service-type: Fix make-forkexec-constructor call.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Ludovic Courtès
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20221013064725.6638-1-paren@disroot.org
This fixes a stupid mistake I made with the home-dbus-service-type, where I
tried to use #~ inside another #~.

( (1):
gnu: home: home-dbus-service-type: Fix make-forkexec-constructor call.

gnu/home/services/desktop.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--
2.38.0
(
[PATCH 1/1] gnu: home: home-dbus-service-type: Fix make-forkexec-constructor call.
(address . 58484@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20221013064825.6731-1-paren@disroot.org
* gnu/home/services/desktop.scm (home-dbus-shepherd-services)[start]
<#:environment-variables>: Use a quote instead of a gexp.
---
gnu/home/services/desktop.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
index 6549efd8df..e94e666d93 100644
--- a/gnu/home/services/desktop.scm
+++ b/gnu/home/services/desktop.scm
@@ -201,7 +201,7 @@ (define (home-dbus-shepherd-services config)
(format #f "/run/user/~a"
(getuid)))))
#:environment-variables
- #~(list "DBUS_VERBOSE=1")
+ '(list "DBUS_VERBOSE=1")
#:log-file
(format #f "~a/dbus.log"
(or (getenv "XDG_LOG_HOME")
--
2.38.0
A
A
Andrew Tropin wrote on 14 Oct 2022 09:11
(name . ()(address . paren@disroot.org)
87v8omlw01.fsf@trop.in
On 2022-10-13 07:48, guix-patches@gnu.org wrote:

Toggle quote (4 lines)
> * gnu/home/services/desktop.scm (home-dbus-shepherd-services)[start]
> <#:environment-variables>: Use a quote instead of a gexp.
> ---

It's possible to type arbitrary text after ---, which won't be added to
commit message or affect a patch. Just in case you would like to send
one email instead of two, this trick can be used.

Toggle quote (17 lines)
> gnu/home/services/desktop.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
> index 6549efd8df..e94e666d93 100644
> --- a/gnu/home/services/desktop.scm
> +++ b/gnu/home/services/desktop.scm
> @@ -201,7 +201,7 @@ (define (home-dbus-shepherd-services config)
> (format #f "/run/user/~a"
> (getuid)))))
> #:environment-variables
> - #~(list "DBUS_VERBOSE=1")
> + '(list "DBUS_VERBOSE=1")
> #:log-file
> (format #f "~a/dbus.log"
> (or (getenv "XDG_LOG_HOME")

Applied, pushed, thank you :)

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmNJC78ACgkQIgjSCVjB
3rDmpg/+Nxtl2FBkTpLmcpbpljvde4eyrsxydoJ/GF+loo6ussfZU5/d056TMRCJ
u7sgnCI8/Va6PhnBRySwu96YbSG8jU5sfSYUfO5YA5uHLY2RuM8ZQuLoVpTc061U
HPVaMS5UxF5CptFQI7DZET9aSG0WjAZMzmjSivJzh2MB43l7Eh2fzXHmyStJDC4A
Yerr7R/sECHBp4eNwwNAg3sAYWzrY1ha2bzzcMlBody/XhcHUWG2lRSaYvr8neFT
aLYzO0v1wasXHAbGyjebjpmitYIoqlW2MhkwYy3ehe9iXy4E2KqyFXbQ1yB/6h3F
ijplaBX23y9AP+3o8yjRiMpf+8NCTlNRhKkTiIppnlwiUfz0cDXLp5rxmaAcZqk+
gETEMSrBsYXjjYhj+gXc0cw4L94IercGNK+NLF29DBomOj10z/yKvg0fV4C/dbrG
4RgkyPnSoexDuSBvKLd1n68xj4uuOWG1rjWSuyWX3knAV61YGiSwlY+/LYGABi6i
WKA0RF/0Ba237FqW6wBAYbDgjom/PCE56R6hoj00oYgkJpLQTWpRCitwnu/pgcRP
Q74IY70H8jGrJ/+EpjBwpQ3n77OpoO+jcvK+mrJuDr3a32RjPsUqMZY/D4AmRFsS
eKPzGABWmsS63aT24ugJ3qID7gw676IhpyvvGIKNejOgMCvZsP4=
=TAZs
-----END PGP SIGNATURE-----

(
CNLGK4XKXK3S.36RQBI73A01QL@guix-framework
On Fri Oct 14, 2022 at 8:11 AM BST, Andrew Tropin wrote:
Toggle quote (2 lines)
> Applied, pushed, thank you :)

Thanks! :)

-- (
(
CNLGODL57543.69F8NQRX0MN3@guix-framework
On Fri Oct 14, 2022 at 8:11 AM BST, Andrew Tropin wrote:
Toggle quote (4 lines)
> It's possible to type arbitrary text after ---, which won't be added to
> commit message or affect a patch. Just in case you would like to send
> one email instead of two, this trick can be used.

I know, but I prefer to use the --cover-letter feature to generate the leading email :)

-- (
L
L
Ludovic Courtès wrote on 23 Oct 2022 15:09
control message for bug #58484
(address . control@debbugs.gnu.org)
877d0q4rg0.fsf@gnu.org
close 58484
quit
?