perl-gtk3 blocking widget

  • Open
  • quality assurance status badge
Details
One participant
  • Julien Lepiller
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 13 Oct 2022 08:14
(address . bug-guix@gnu.org)
20221013081453.0665eb2c@sybil.lepiller.eu
Hi Guix!

I was trying to use a perl software that uses gtk3. Its main window
does not show up and it seems to get stuck. I tried to come up with a
reproducer. In guix shell perl perl-gtk3:

```
#!/usr/bin/env perl

use strict;
use warnings;
use diagnostics;
use feature ':5.14';
use Gtk3 '-init';
use Glib qw/TRUE FALSE/;

my $window = Gtk3::Window->new('toplevel');
$window->set_title("Basic Check Boxes");
$window->set_position("mouse");
$window->set_default_size(400, 200);
$window->set_border_width(5);
$window->signal_connect (delete_event => sub { Gtk3->main_quit });

my $vbox = Gtk3::Box->new("vertical", 5);
$window->add($vbox);

say "hello";

my $entry = Gtk3::Entry->new;

say "hello again";

Gtk3->main;
```

says "hello" but gets stuck when creating the entry. I get some error
messages, but it doesn't prevent perl-gtk3 from showing relatively
complex windows: I get the same errors with a script like, but the
window is properly shown:


any perl expert around? :)
?