[PATCH] gnu: Add erlang-jsx.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Christopher Baines
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221011221921.25399-1-jgart@dismail.de
* gnu/packages/erlang.scm (erlang-jsx): New variable.
---
gnu/packages/erlang.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index ede46f3a1c..0e9d79f2ee 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020-2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Oskar Köök <oskar@maatriks.ee>
;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -499,6 +500,23 @@ (define-public erlang-proper
testing of stateful systems.")
(license license:gpl3+)))
+(define-public erlang-jsx
+ (package
+ (name "erlang-jsx")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (hexpm-uri "jsx" version))
+ (sha256
+ (base32
+ "1wr7jkxm6nlgvd52xhniav64xr9rml2ngb35rwjwqlqvq7ywhp0c"))))
+ (build-system rebar-build-system)
+ (synopsis "Streaming, evented JSON parsing toolkit")
+ (description
+"An Erlang application for consuming, producing and manipulating json.")
+ (home-page "https://hexdocs.pm/jsx/")
+ (license license:expat)))
+
(define-public erlang-providers
(package
(name "erlang-providers")
--
2.38.0
C
C
Christopher Baines wrote on 12 Dec 2022 23:52
(name . jgart)(address . jgart@dismail.de)
87o7s8p72y.fsf@cbaines.net
jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/erlang.scm (erlang-jsx): New variable.
> ---
> gnu/packages/erlang.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)

Thanks, I fixed the indentation for the description line and I changed
the home-page URL to one that works, and pushed this to master as
e4fd04fb92e2da769ca521eba877bbcd936f290e.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmOXsOVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdDzhAAoRo7O7cKgipsxIbOnfKTPRpcdnXTsVFn
911xacaO0d5JzXJAtawBzr5tF+OnLtpgx1zFVXcCsoa62zeta6IBKJNZdyYfhHWQ
g6gvczryIeIh6qpjt5BqJftrRzoSl3fCYaJvWYMo8fPWknviKd1LVisd+Jkdy2R6
8ChhEYOKPTq2nim1czZbFt4reWb5SGnZIvwqLKryTVz4+vc/VBLEIfmVdXn45csL
dcygB8iMae3sb2tXzX3y+Uw1FW5N2K0CCEEfz3pdz/UrN5JguXduMwwiQbPms7rV
fR0UGgHmlpewt6FxXjX9DiQDKC+cU603Lt08XzZrDWb8FDBqeSqVwa8WpZAuoK6y
3iFtjvquuFOX/sN28FFTfLs9NdBx2mNh5I3FV4OJg1ie+Q7BM48oBYk/7n8nWIsh
zichoPHH6o6R5oUUID/zNn0nxnE5bA/XybzYH6OLiW7+Sc8kZEgNPf5fc7Fyg62o
Qxh2ZlNLTXiCfT0MWOqjmJmPKUKa7+JrGPFw7X7/j72ZQzn5yF/IE8uNVK70fdw7
JOEDrmdsELfvU7N0Cn6dA1MCt9q2GDfqAYhBfZBuswleT5JCXmCNMMxr1Ig4QVZ4
7CFxPI905EDNMAy3Jx5o19V8JLmw0jhYhIoWdQJ7yQZKA61w5dVnNu1ufk7MPMfw
LMeSTx+g1kI=
=QU5G
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 58458@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58458
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch