simon wrote 2 years ago
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
From: Simon Streit <simon@netpanic.org>
* gnu/packages/mpd.scm (mcg): Update to 3.1.
[native-inputs]: Use the new inputs style. Add "desktop-file-utils",
"gettext-minimal".
[inputs]: Add "python".
[build-system]: Change to meson-build-system.
[arguments]<#:imported-modules,#:modules>: Remove. <#:glib-or-gtk?>: Add #t.
Delete custom phase 'glib-or-gtk-wrap.
---
gnu/packages/mpd.scm | 53 ++++++++++++++++++++++----------------------
1 file changed, 26 insertions(+), 27 deletions(-)
Toggle diff (74 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index edec855fff..9a7bbbfd1d 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -483,31 +483,32 @@ (define-public cantata
(define-public mcg
(package
(name "mcg")
- (version "2.1.2")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://gitlab.com/coderkun/mcg")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "01iqxydssxyi4s644dwl64vm7xhn0szd99hdpywbipvb7kwp5196"))))
- (build-system python-build-system)
- (native-inputs
- `(("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
- (inputs
- (list avahi dconf gsettings-desktop-schemas gtk+ python-pygobject))
+ (version "3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/coderkun/mcg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "087d3gvx8z1yj7rg9d9h1x02vkw57h4v6xf5pxqyhqyk2435kk17"))))
+ (build-system meson-build-system)
+ (native-inputs (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ `(,gtk+ "bin")
+ pkg-config))
+ (inputs (list avahi
+ bash-minimal
+ dconf
+ gsettings-desktop-schemas
+ gtk+
+ python
+ python-pygobject))
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
- ,@%python-build-system-modules)
- #:modules ((guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
- (guix build utils))
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-program
@@ -516,9 +517,7 @@ (define-public mcg
"/bin/mcg")))
(wrap-program prog
`("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))
- (add-after 'wrap-program 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
(synopsis "Covergrid for the MPD")
(description
"mcg (CoverGrid) is a client for the Music Player Daemon (MPD), focusing
--
2.37.2