[PATCH] gnu: Add hiredis

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Baines
  • (
  • Thomas Albers
Owner
unassigned
Submitted by
Thomas Albers
Severity
normal

Debbugs page

Thomas Albers wrote 2 years ago
(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20221011091949.9962-1-thomas@thomaslabs.org
* gnu/packages/databases.scm (hiredis): New variable.
---
gnu/packages/databases.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cf07832df7..b372423a77 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2515,6 +2516,29 @@ (define-public ruby-redis
(home-page "https://github.com/redis/redis-rb")
(license license:expat)))

+(define-public hiredis
+ (package
+ (name "hiredis")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redis/hiredis")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ ;; needed for testing
+ (list redis))
+ (synopsis "Minimalistic C client library for the Redis database")
+ (description "Library for sending commands and receiving replies to and
+from a Redis server. It comes with a synchronous API, asynchronous API and
+reply parsing API. Only the binary-safe Redis protocol is supported.")
+ (home-page "https://github.com/redis/hiredis")
+ (license license:bsd-3)))
+
(define-public go-github-com-cupcake-rdb
(package
(name "go-github-com-cupcake-rdb")
--
2.37.3
( wrote 2 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 58432@debbugs.gnu.org)
CNJ01EMJODL7.2MCNVFFNBPKE2@guix-framework
Heya Thomas,

Looks mostly good, just a few nitpicks:

On Tue Oct 11, 2022 at 10:19 AM BST, Thomas Albers via Guix-patches via wrote:
Toggle quote (3 lines)
> +(define-public hiredis
> + (package
> + (name "hiredis")
^
We usually have two spaces of indentation here.

Toggle quote (2 lines)
> + (source (origin
> + (method git-fetch)
^
Here too.

Toggle quote (3 lines)
> + (sha256
> + (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))

Put the hash string on a new line.

Toggle quote (4 lines)
> + (description "Library for sending commands and receiving replies to and
> +from a Redis server. It comes with a synchronous API, asynchronous API and
> +reply parsing API. Only the binary-safe Redis protocol is supported.")

"This package provides a library for ..." is probably better.

-- (
Thomas Albers wrote 2 years ago
[PATCH] gnu: Add hiredis
(address . 58432@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20221011130834.1592-1-thomas@thomaslabs.org
* gnu/packages/databases.scm (hiredis): New variable.
---
gnu/packages/databases.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cf07832df7..8523c084e4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2494,6 +2495,31 @@ (define-public redis
(home-page "https://redis.io/")
(license license:bsd-3)))

+(define-public hiredis
+ (package
+ (name "hiredis")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redis/hiredis")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ ;; needed for testing
+ (list redis))
+ (synopsis "Minimalistic C client library for the Redis database")
+ (description "This package provides a library for sending commands and
+receiving replies to and from a Redis server. It comes with a synchronous
+API, asynchronous API and reply parsing API. Only the binary-safe Redis
+protocol is supported.")
+ (home-page "https://github.com/redis/hiredis")
+ (license license:bsd-3)))
+
(define-public ruby-redis
(package
(name "ruby-redis")
--
2.37.3
Thomas Albers Raviola wrote 2 years ago
(name . ()(address . paren@disroot.org)(address . 58432@debbugs.gnu.org)
87h70aec5p.fsf@thomaslabs.org
Thanks ( for the observations. I have sent a new patch with the
corrections.
( wrote 2 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 58432@debbugs.gnu.org)
CNJ4T2ZOI18E.3ACQVRW2IW7Q0@guix-framework
LGTM :)

-- (
Christopher Baines wrote 2 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 58432-done@debbugs.gnu.org)
87r0zc8259.fsf@cbaines.net
Thomas Albers via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/databases.scm (hiredis): New variable.
> ---
> gnu/packages/databases.scm | 28 +++++++++++++++++++++++++++-
> 1 file changed, 27 insertions(+), 1 deletion(-)

Thanks both, I've pushed this to master as
cc58a0c62739d93c1d22a9930f11abdb0bd7ac04.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNH5CJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfDeA//dbcQOrdvfJabjwE2Iyw6dnWf40RmnFoD
th5nssiLnNUoaBzYJVAfWsXCnk5vF95PXEk3jIvDjGzDkAlxemBIWCbcnZQE5Bhw
4NFjTfyl8NJWwFfy7Y8hNqJjOlA36dzs9JAYKfKrercoLOfHZEMoVG7mOfgvQjeT
J2PgGmo9qetYyqhLxNQ1X9mnOXL9t8DDZC6ZwyV9k2d6FfzOtcrvePhZvG2opwU5
skmYKTfwK3+wCAnMPSrPmyZ0PCrN9haMkKkJPIHukIk2fEmlWCJImyCAY8HfL0kT
9UEoER854SQawNX+2noamuS9l8NjBjdvEJaOV0wF/VSBcRJUynmGPZE2AGpuN5mM
1QDEx8H7qgIBpB4n241bkPtypd449LRClBtQ7h12uqrym0GiuNJcDb5ij4h1WeSX
yfBpG3bjzSQtHctHddWZrJutEdUXcv1ZmfAsKZIYEaWn1nHJIelsQj5YrLwqulup
b2GAVj0FElK5ofLoRfWlkCn+PgcT5HkDQfhOD3y/uK+MxTQx7TMA0qy9l4HijhEV
BLxNlaad4CRL357MzoUQFNOtEsMSyjFn1fXH2cf0HheLUW1GmS0o1wpo9wq/S9sm
PQngGIn5T7tO793YXitBYuHJHKiGBMAFb4rwPxY6ThorXsBtlLUNDqZVaxshcWVC
XVWSpAMeB2Y=
=BbSn
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58432@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58432
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help