Thomas Albers wrote 2 years ago
(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
* gnu/packages/databases.scm (hiredis): New variable.
---
gnu/packages/databases.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)
Toggle diff (42 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cf07832df7..b372423a77 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2515,6 +2516,29 @@ (define-public ruby-redis
(home-page "https://github.com/redis/redis-rb")
(license license:expat)))
+(define-public hiredis
+ (package
+ (name "hiredis")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redis/hiredis")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ ;; needed for testing
+ (list redis))
+ (synopsis "Minimalistic C client library for the Redis database")
+ (description "Library for sending commands and receiving replies to and
+from a Redis server. It comes with a synchronous API, asynchronous API and
+reply parsing API. Only the binary-safe Redis protocol is supported.")
+ (home-page "https://github.com/redis/hiredis")
+ (license license:bsd-3)))
+
(define-public go-github-com-cupcake-rdb
(package
(name "go-github-com-cupcake-rdb")
--
2.37.3