(address . bug-guix@gnu.org)
Hi,
Someone reported yesterday on IRC [1] that they didn't get the same
canonical path for the pass (from `password-store`) binary if they built
it directly or in a profile with `fontconfig` added. I managed to
isolate the issue down to the following:
Toggle snippet (14 lines)
(let ((right (with-store store (run-with-store store (package->derivation
(specification->package
"password-store")))))
(wrong (with-store store (run-with-store store (mbegin %store-monad
(package->derivation
(specification->package
"texlive-bin"))
(package->derivation
(specification->package
"password-store")))))))
(pk right)
(pk wrong))
Both derivations differ even though they ideally should be identical,
apparently git doesn't appear in the same place in the grafting
derivation.
I've tried to debug the grafting code but to no avail yet. Does anyone
have any idea?
--
Josselin Poiret