Installer script no longer works with `yes` utility

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonas Freimuth
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jonas Freimuth
Severity
normal

Debbugs page

Jonas Freimuth wrote 2 years ago
(address . bug-guix@gnu.org)
9e3dc221-9013-d58a-402b-696b117a99a6@posteo.de
Package: guix

Version: 1.4.0

Severity: important

Heyo,

I use the github `guix-install-action`
runs the `guix-install.sh` script non-interactively, via the yes utility:

```{bash}

bash -c 'yes | bash guix-install.sh'

```

However, since commit `6a2e303d3a49baf7c222a70b91f453e9efd456c6`
this apparently causes the entire action to hang (leading to eventual
termination by github).

I confirmed this behaviour by running the "Download", "Fetch Key", and
"Install Guix" steps of the `guix-install-action` as root on a WSL2
instance of Ubuntu20.04 (using todays wsl rootfs from

Running

```{bash}

sudo --preserve-env=GUIX_BINARY_FILE_NAME -- bash -c 'bash guix-install.sh'

```

instead of

```{bash}

sudo --preserve-env=GUIX_BINARY_FILE_NAME -- bash -c 'yes | bash
guix-install.sh'

```

i.e. running the script interactively works fine.

Is this intended, or is there another suggested way to run the
`guix-install.sh` script non-interactively?

Best wishes,

Jonas
Attachment: file
Maxim Cournoyer wrote 2 years ago
(name . Jonas Freimuth)(address . jonas.freimuth@posteo.de)(address . 58417-done@debbugs.gnu.org)
87mta2cpnh.fsf@gmail.com
Hi,

Jonas Freimuth <jonas.freimuth@posteo.de> writes:

Toggle quote (17 lines)
> Package: guix
>
> Version: 1.4.0
>
> Severity: important
>
> Heyo,
>
> I use the github `guix-install-action`
> (https://github.com/PromyLOPh/guix-install-action), which internally
> runs the `guix-install.sh` script non-interactively, via the yes
> utility:
>
> ```{bash}
>
> bash -c 'yes | bash guix-install.sh'

This should be fixed with e46bb5fd5a. Please report back if it there
are still issues.

Thanks for reporting the issue, and apologies for the breakage!

--
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58417@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58417
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help