Jonas Freimuth wrote 2 years ago
(address . bug-guix@gnu.org)
Package: guix
Version: 1.4.0
Severity: important
Heyo,
I use the github `guix-install-action`
(https://github.com/PromyLOPh/guix-install-action),which internally
runs the `guix-install.sh` script non-interactively, via the yes utility:
```{bash}
bash -c 'yes | bash guix-install.sh'
```
However, since commit `6a2e303d3a49baf7c222a70b91f453e9efd456c6`
this apparently causes the entire action to hang (leading to eventual
termination by github).
I confirmed this behaviour by running the "Download", "Fetch Key", and
"Install Guix" steps of the `guix-install-action` as root on a WSL2
instance of Ubuntu20.04 (using todays wsl rootfs from
Running
```{bash}
sudo --preserve-env=GUIX_BINARY_FILE_NAME -- bash -c 'bash guix-install.sh'
```
instead of
```{bash}
sudo --preserve-env=GUIX_BINARY_FILE_NAME -- bash -c 'yes | bash
guix-install.sh'
```
i.e. running the script interactively works fine.
Is this intended, or is there another suggested way to run the
`guix-install.sh` script non-interactively?
Best wishes,
Jonas