[PATCH] gnu: Add nbfc-linux

  • Done
  • quality assurance status badge
Details
2 participants
  • florhizome
  • Ludovic Courtès
Owner
unassigned
Submitted by
florhizome
Severity
normal
F
F
florhizome wrote on 8 Oct 2022 21:38
(address . guix-patches@gnu.org)
871qrit8bc.fsf@posteo.net
This patch adds the nbfc-linux package, containing tools for fan control.
F
F
florhizome wrote on 11 Oct 2022 19:19
(address . 58392@debbugs.gnu.org)(name . florhizome)(address . florhizome@posteo.net)
b6c455bdcf37806eff52cf1d3d0bd45bbece564e.1665508797.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

---
gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2a2b1614f9..5b58313f69 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5886,6 +5886,43 @@ (define-public freefall
feature, and a laptop with an accelerometer. It has no effect on SSDs.")
(license license:gpl2)))
+
+(define-public nbfc-linux
+ (let ((version "0.1.7")
+ (commit "4c2b75e4a875459e86a9892319889ff945e9cadf")
+ (revision "0"))
+ (package
+ (name "nbfc-linux")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nbfc-linux/nbfc-linux")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mmyfaigrh3fd5v11a8p38km4m02qzsfx8yh72g0z405bzhqn5jk"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config))
+ (propagated-inputs (list python dmidecode))
+ (synopsis "NoteBook FanControl ported to Linux")
+ (description
+ "This is a C port of Stefan Hirschmann's NoteBook FanControl.
+
+ It provides the same utilities with the same interfaces as the original NBFC,
+ although the implementation differs.")
+ (home-page "https://github.com/nbfc-linux/nbfc-linux")
+ (license license:gpl3+))))
+
(define-public thinkfan
(package
(name "thinkfan")

base-commit: 40a42c4348635f186553938015f7e6a06be1e10c
--
2.37.3
L
L
Ludovic Courtès wrote on 18 Oct 2022 14:54
(address . florhizome@posteo.net)(address . 58392-done@debbugs.gnu.org)
87bkq9nvg0.fsf_-_@gnu.org
Hi,

florhizome@posteo.net skribis:

Toggle quote (5 lines)
> From: florhizome <florhizome@posteo.net>
>
> ---
> gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++

Applied with a commit log and the cosmetic changes below.

Thanks!

Ludo’.
Toggle diff (17 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 015d957df5..864c379eac 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5924,10 +5924,9 @@ (define-public nbfc-linux
(propagated-inputs (list python dmidecode))
(synopsis "NoteBook FanControl ported to Linux")
(description
- "This is a C port of Stefan Hirschmann's NoteBook FanControl.
-
- It provides the same utilities with the same interfaces as the original NBFC,
- although the implementation differs.")
+ "This package provides a C port of NoteBook FanControl (NBFC), a fan
+control service for notebooks. It provides the same utilities with the same
+interfaces as the original NBFC, although the implementation differs.")
(home-page "https://github.com/nbfc-linux/nbfc-linux")
(license license:gpl3+))))
Closed
?