[PATCH] cpprestsdk: New package

  • Open
  • quality assurance status badge
Details
One participant
  • Jacob Hrbek
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
J
J
Jacob Hrbek wrote on 9 Oct 2022 09:28
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
VkkHyatpaLGV8IsAK1J2aSkgbMq2AAd1qYbm33inOK64DR9fw98FpFX0gApiKbEHq1wOH_3CJABui0tFtnW52DBwIGjXVJgYVFKWdh3cMSk=@rixotstudio.cz
wheee
Attachment: file
J
J
Jacob Hrbek wrote on 9 Oct 2022 09:30
(address . 58391@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221009073008.27151-1-kreyren@rixotstudio.cz
---
gnu/packages/cpp.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d03e0bc7e1..027b1ed2af 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Attila Lendvai <attila@lendvai.name>
;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Jacob 'Kreyren' Hrbek <kreyren@rixotstudio.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -885,6 +886,36 @@ (define-public cpplint
and make @code{cpplint} usable in wider contexts.")
(license license:bsd-3)))

+(define-public cpprestsdk
+ (package
+ (name "cpprestsdk")
+ (home-page "https://github.com/microsoft/cpprestsdk")
+ (version "2.10.18")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07qyip57wyzpmlgyz1fri4ljmla7ar3isddvfkm8hzv6q35bx2rn"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;4 tests fail
+ #:phases (modify-phases %standard-phases
+ ;; Microsoft doesn't know how to write a code without errors
+ (add-after 'unpack 'disable-Werror
+ (lambda _
+ (substitute* "Release/CMakeLists.txt"
+ (("WERROR ON CACHE")
+ "WERROR OFF CACHE")) #t)))))
+ (native-inputs (list boost openssl zlib))
+ (synopsis "API for cloud-based client-server communication")
+ (description "C++ REST API to connect and interact with servers")
+ (license license:expat)))
+
(define-public reproc
(package
(name "reproc")
--
2.37.3
?