giac 1.9.0-21 fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 3 Oct 2022 16:34
(name . bug-guix)(address . bug-guix@gnu.org)
87ill1j7r4.fsf@gmail.com
Hi,

The build of giac fails like:

Toggle snippet (61 lines)
libtool: compile: g++ -DHAVE_CONFIG_H -I. -I.. -DIN_GIAC -I. -I.. -I. -I.. -g -O2 -fno-strict-aliasing -DGIAC_GENERIC_CONSTANTS -DTIMEOUT -DHAVE_LIBMICROPYTHON -fpermissive -DQUICKJS -MT alg_ext.lo -MD -MP -MF .deps/alg_ext.Tpo -c alg_ext.cc -o alg_ext.o >/dev/null 2>&1
pari.cc:752:17: error: typedef ‘giac::PFGEN’ is initialized (use ‘decltype’ instead)
752 | typedef GEN (*PFGEN)(ANYARG);
| ^~~~~
pari.cc:752:24: error: ‘ANYARG’ was not declared in this scope
752 | typedef GEN (*PFGEN)(ANYARG);
| ^~~~~~
pari.cc: In function ‘giac::gen giac::in_pari(const giac::gen&, const giac::context*)’:
pari.cc:829:19: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
829 | argvec[k]= (GEN) v[j].val;
| ^~~~~~~~~~~~~~
pari.cc:847:19: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
847 | argvec[k]=(long int*)(pos -1);
| ^~~~~~~~~~~~~~~~~~~
pari.cc:855:17: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
855 | argvec[k]=(long int*) v[j].val;
| ^~~~~~~~~~~~~~~~~~~~
pari.cc:883:16: error: ‘PFGEN’ was not declared in this scope; did you mean ‘GEN’?
883 | res = ((PFGEN)call)(_ARGS_);
| ^~~~~
| GEN
pari.cc:883:22: error: expected ‘)’ before ‘call’
883 | res = ((PFGEN)call)(_ARGS_);
| ~ ^~~~
| )
pari.cc:887:20: error: expected primary-expression before ‘int’
887 | m = (long)((int (*)(ANYARG))call)(_ARGS_);
| ^~~
pari.cc:887:20: error: expected ‘)’ before ‘int’
887 | m = (long)((int (*)(ANYARG))call)(_ARGS_);
| ~^~~
| )
pari.cc:887:49: error: expected ‘)’ before ‘;’ token
887 | m = (long)((int (*)(ANYARG))call)(_ARGS_);
| ~ ^
| )
pari.cc:891:14: error: expected primary-expression before ‘long’
891 | m = ((long (*)(ANYARG))call)(_ARGS_);
| ^~~~
pari.cc:891:14: error: expected ‘)’ before ‘long’
891 | m = ((long (*)(ANYARG))call)(_ARGS_);
| ~^~~~
| )
pari.cc:891:44: error: expected ‘)’ before ‘;’ token
891 | m = ((long (*)(ANYARG))call)(_ARGS_);
| ~ ^
| )
pari.cc:895:10: error: expected primary-expression before ‘void’
895 | ((void (*)(ANYARG))call)(_ARGS_);
| ^~~~
pari.cc:895:10: error: expected ‘)’ before ‘void’
895 | ((void (*)(ANYARG))call)(_ARGS_);
| ~^~~~
| )
pari.cc:895:40: error: expected ‘)’ before ‘;’ token
895 | ((void (*)(ANYARG))call)(_ARGS_);
| ~ ^
| )
make[2]: *** [Makefile:814: pari.lo] Error 1

--
Thanks,
Maxim
N
N
Nicolas Goaziou wrote on 7 Oct 2022 22:17
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 58274-done@debbugs.gnu.org)
87o7unv16a.fsf@nicolasgoaziou.fr
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (7 lines)
> The build of giac fails like:
>
> --8<---------------cut here---------------start------------->8---
> libtool: compile: g++ -DHAVE_CONFIG_H -I. -I.. -DIN_GIAC -I. -I.. -I. -I.. -g -O2 -fno-strict-aliasing -DGIAC_GENERIC_CONSTANTS -DTIMEOUT -DHAVE_LIBMICROPYTHON -fpermissive -DQUICKJS -MT alg_ext.lo -MD -MP -MF .deps/alg_ext.Tpo -c alg_ext.cc -o alg_ext.o >/dev/null 2>&1
> pari.cc:752:17: error: typedef ‘giac::PFGEN’ is initialized (use ‘decltype’ instead)
> 752 | typedef GEN (*PFGEN)(ANYARG);

Fixed. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58274@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58274
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch