[PATCH v2] gnu: Add emacs-circadian.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Nicolas Goaziou
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)
20221003063755.80268-1-kiasoc5@disroot.org
* gnu/packages/emacs-xyz.scm (emacs-circadian): New variable.
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 788c31bca4..45df75eb90 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19526,6 +19526,35 @@ (define-public emacs-ts
timestamps by providing a @code{ts} struct.")
(license license:gpl3+)))
+(define-public emacs-circadian
+ (package
+ (name "emacs-circadian")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/guidoschmidt/circadian.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wpsykmai3idz0bgfl07hwl9nr4x9sgprvqgw8jln4dz2wf5gdic"))))
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "ert-runner")))
+ (build-system emacs-build-system)
+ (native-inputs
+ (list emacs-el-mock emacs-ert-runner))
+ (home-page "https://github.com/guidoschmidt/circadian.el")
+ (synopsis "Theme-switching for Emacs based on daytime")
+ (description "Circadian may reduce eye strain by automatically switching
+between light and dark themes based on daytime. It is inspired by color
+temperature shifting tools and brightness adaption software.")
+ ;; The LICENSE file is expat, but the sole ".el" file is explicitly GPL3+.
+ (license (list license:gpl3+
+ license:expat))))
+
(define-public emacs-peg
(package
(name "emacs-peg")

base-commit: ab6931483be544b7debb9496f694b593af7e0c0f
--
2.37.3
Nicolas Goaziou wrote 2 years ago
(name . kiasoc5 via Guix-patches via)(address . guix-patches@gnu.org)
87pmf7mu5m.fsf@nicolasgoaziou.fr
Hello,

kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-circadian): New variable.

Applied. Thank you!

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58266@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58266
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help