(name . Guix Patches)(address . guix-patches@gnu.org)
- Jon 3 Oct 2022 03:09
- Jon 3 Oct 2022 03:30
- Jon 3 Oct 2022 03:30
- Lon 3 Oct 2022 09:06
- Con 1 Nov 2022 16:46
[PATCH 1/2] gnu: Add emacs-meme.
J
[PATCH 1/2] gnu: Add emacs-imgur-el.
(address . 58263@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221003013029.23585-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-imgur-el): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9ba87652f3..5049824bce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -552,6 +552,29 @@ (define-public emacs-telephone-line
configuration language which makes it trivial to write your own themes.")
(license license:gpl3+))))
+(define-public emacs-imgur-el
+ (let ((commit "e179f5e3411d8eb3773e436e391e432c52e8b911")
+ (revision "0"))
+ (package
+ (name "emacs-imgur-el")
+ (version (git-version "20220125" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/larsmagne/imgur.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hkfwz5278vd3cap95656n2a5a4qkd66r7gzlg4zjq2f45f9b9bx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/larsmagne/imgur.el")
+ (synopsis "Simple library for uploading pictures to imgur")
+ (description
+"@code{emacs-imgur-el} is a simple library for uploading pictures to imgur.")
+ (license license:gpl2+))))
+
(define-public emacs-terminal-here
(package
(name "emacs-terminal-here")
--
2.37.3
J
[PATCH 2/2] gnu: Add emacs-meme.
(address . 58263@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221003013029.23585-2-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-meme): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5049824bce..72a9e52043 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -552,6 +552,30 @@ (define-public emacs-telephone-line
configuration language which makes it trivial to write your own themes.")
(license license:gpl3+))))
+(define-public emacs-meme
+ (let ((commit "0a0ca8f6babaca3fea94f308f8d58f5186eba920")
+ (revision "0"))
+ (package
+ (name "emacs-meme")
+ (version (git-version "20220125" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/larsmagne/meme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0c30qx0dmd9hym7m2kvjw39vq6b8n51hwhdks48sb7hsb069l039"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-imgur-el))
+ (home-page "https://github.com/larsmagne/meme")
+ (synopsis "Emacs meme generator")
+ (description "@code{emacs-meme} provides a meme generator for Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-imgur-el
(let ((commit "e179f5e3411d8eb3773e436e391e432c52e8b911")
(revision "0"))
--
2.37.3
L
de480ea76993e03be9fa666f7f8604ce0c6429d6.camel@ist.tugraz.at
Am Sonntag, dem 02.10.2022 um 20:30 -0500 schrieb jgart:
Toggle quote (20 lines)
> * gnu/packages/emacs-xyz.scm (emacs-meme): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 5049824bce..72a9e52043 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -552,6 +552,30 @@ (define-public emacs-telephone-line
> configuration language which makes it trivial to write your own
> themes.")
> (license license:gpl3+))))
>
> +(define-public emacs-meme
> + (let ((commit "0a0ca8f6babaca3fea94f308f8d58f5186eba920")
> + (revision "0"))
> + (package
> + (name "emacs-meme")
> + (version (git-version "20220125" revision commit))
We don't do melpa versions. Since this one seems to be missing any
version info whatsoever, use "0".
Toggle quote (19 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/larsmagne/meme")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> "0c30qx0dmd9hym7m2kvjw39vq6b8n51hwhdks48sb7hsb069l039"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-imgur-el))
> + (home-page "https://github.com/larsmagne/meme")
> + (synopsis "Emacs meme generator")
> + (description "@code{emacs-meme} provides a meme generator for
> Emacs.")
> + (license license:gpl2+))))
Note that this package asks you to install non-free fonts. In general,
the customizability of both this and imgur.el is too low to really call
it an emacs package imho (and the way emacs-meme handles fonts is not
up to par with what emacs faces can do). I spare you a full code
review, but rest assured that both packages should undergo some more
revisions before distro packaging.
Cheers
?