[PATCH] gnu: python-pydyf: Update to 0.3.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221002231057.18056-1-mike@rohleder.de
* gnu/packages/pdf.scm (python-pydyf): Update to 0.3.0.
[arguments]: Add phases to replace build and install phases.
[native-inputs]: Add python-flit-core, python-pypa-build.
---
gnu/packages/pdf.scm | 20 ++++++++++++++++----
1 file changed, 16 insertions(+), 4 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d698450656..10de484ecb 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2019 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2019,2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
@@ -727,24 +727,36 @@ (define-public podofo
(define-public python-pydyf
(package
(name "python-pydyf")
- (version "0.1.2")
+ (version "0.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pydyf" version))
(sha256
- (base32 "0b30g3hhxw1bg18r9ax85i1dkg8vy1y1wzas0bg0bxblh7j5sbqy"))))
+ (base32 "18q43g5d9455msipcgd5fvnh8m4a2rz189slzfg80yycjw66rshs"))))
(build-system python-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda _
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output whl))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv" "-c" "/dev/null")))))))
(propagated-inputs (list python-pillow))
- (native-inputs (list ghostscript python-pytest))
+ (native-inputs
+ (list ghostscript
+ python-flit-core
+ python-pypa-build
+ python-pytest))
(home-page "https://github.com/CourtBouillon/pydyf")
(synopsis "Low-level PDF generator")
(description "@code{pydyf} is a low-level PDF generator written in Python
--
2.37.3
Ludovic Courtès wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 58259-done@debbugs.gnu.org)
878rlmy04x.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (4 lines)
> * gnu/packages/pdf.scm (python-pydyf): Update to 0.3.0.
> [arguments]: Add phases to replace build and install phases.
> [native-inputs]: Add python-flit-core, python-pypa-build.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58259@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58259
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help