[PATCH] gnu: celluloid: Do not install icon cache.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221001225644.14960-1-mike@rohleder.de

* gnu/packages/video.scm (celluloid)[arguments]: Add phase
disable-postinstall-script so postinstall-script does nothing.
[native-inputs]: Remove gtk:bin.
---
gnu/packages/video.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6a14a85b74..f22c145b8f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -785,12 +785,19 @@ (define-public celluloid
(sha256
(base32 "0ns9xh582c8kajw4v2x5ap5jfiba3gxywqc2klc0v6fc3id1gqii"))))
(build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-postinstall-script
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
(native-inputs
(list
desktop-file-utils ; for update-desktop-database
intltool
`(,glib "bin") ; for glib-compile-resources
- `(,gtk "bin") ; for gtk-update-icon-cache
pkg-config
python-wrapper)) ; for generate-authors.py
(inputs
--
2.37.3
Efraim Flashner wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 58237-done@debbugs.gnu.org)
Yz7fjQO2ZB7XZqPr@3900XT
Thanks. Patch pushed!

Make sure to check celluloid to see if it does indeed fix bug 58207.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmM+340ACgkQQarn3Mo9
g1Fx6g/9Fyow0PI5ipHyYO5uXoJVUW71KvhFrcbEEhN5GhA5qRwuTUcQYERxu38x
3/z/YWcRne6ydRwgtV8M2o6nmndeSNE/AMrw1rHlikGirWehPz4JCUzsNj39hOrf
FnPpOiMtPUyVIaR/T6tmYId+Xmi2MMTSOk7Coc58QIOdbyKiATr43YwpWJijCLEj
Sy0CA9c2f5bne9gYmVTpDhG83rggTsyVEpA+bnwE78ERpIqarl/sdtUf3Kcvjv8o
N0Uyxd+izwq5idNMTL3iG8O3/fulvz/t3B7wNSerkagw6IrDkVEBeF8/qdDI5hJH
9V7bhikcLCf+HcCWO1Ql+tYo5OR1Srnh4HS1B+Gli0teGyX+D4GrPYwCOKGKFho/
/qzYnCRbsAzCfUNMqhcAsxlr5AR5DmqZOlEiVO5P+L4NDXC0xXo3Ciq+tAUyb11L
Enu/iEXe3Wpb4wyRvqHW4pQouOPeTxzuCe4SYRwFmsKzSMKzQaGpgwDyPkvnsZ7c
JmClhvnKEB54C0JIL1uPxMRLngdCMahCx+JD+QdiWh+x/8IQ4BUjALLqWHu5rO3J
Orp1e7LGASKzw94CfGklPty9VnXJwUvLreGkKjrXtdfGx5a+T/sARowXDSaS4IYd
Vu8ed9FM/0z1TR+KGHBRnnk0ON8/1fyqzDKQwnS9cE2De5t6atA=
=jy+v
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58237@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58237
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help