Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/video.scm (celluloid)[arguments]: Add phase
disable-postinstall-script so postinstall-script does nothing.
[native-inputs]: Remove gtk:bin.
---
gnu/packages/video.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
Toggle diff (27 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6a14a85b74..f22c145b8f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -785,12 +785,19 @@ (define-public celluloid
(sha256
(base32 "0ns9xh582c8kajw4v2x5ap5jfiba3gxywqc2klc0v6fc3id1gqii"))))
(build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-postinstall-script
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
(native-inputs
(list
desktop-file-utils ; for update-desktop-database
intltool
`(,glib "bin") ; for glib-compile-resources
- `(,gtk "bin") ; for gtk-update-icon-cache
pkg-config
python-wrapper)) ; for generate-authors.py
(inputs
--
2.37.3