Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)
Sharlatan Hellseher (1):
gnu: Add splash (astronomy)
gnu/packages/astronomy.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
base-commit: 225e00bd1925487fb045d9184fd249d93accad08
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 6d1a68bbcfd2cbb355fdcec051a105b54e535812 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 1 Oct 2022 16:42:12 +0100
Subject: [PATCH 1/1] gnu: Add splash (astronomy)
* gnu/packages/astronomy.scm (splas): New variable.
---
gnu/packages/astronomy.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
Toggle diff (57 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 13ffdd74d3..a040d16db1 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -591,6 +591,50 @@ (define-public sextractor
crowded star fields.")
(license license:gpl3+)))
+(define-public splash
+ (package
+ (name "splash")
+ (version "3.5.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danieljprice/splash")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "12s3w96wzd4zpxw4adzhalkr57fgdk7cjp6bj596jnd87pz3rhyd"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; FIXME: Tests failed
+ ;; Issue submited upstream https://github.com/danieljprice/splash/issues/67
+ ;;
+ ;; make: *** No rule to make target 'test_interpolate3D.o', needed by 'test1'. Stop.
+ ;;
+ (list #:tests? #f
+ #:parallel-build? #f ;parallel build fails
+ #:make-flags #~(list "SYSTEM=gfortran" "PREFIX="
+ (string-append "GIZA_DIR="
+ #$(this-package-input "giza"))
+ (string-append "DESTDIR="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'create-install-dirrectories
+ (lambda _
+ (mkdir-p (string-append #$output "/bin")))))))
+ (native-inputs (list gfortran pkg-config perl python-wrapper))
+ (inputs (list cairo cfitsio giza))
+ (home-page "https://users.monash.edu.au/~dprice/splash/")
+ (synopsis
+ "Astrophysical visualisation tool for smoothed particle hydrodynamics")
+ (description
+ "SPLASH is a free and open source visualisation tool for Smoothed Particle
+Hydrodynamics (SPH) simulations in one, two and three dimensions, developed
+mainly for astrophysics. It uses a command-line menu but data can be manipulated
+interactively in the plotting window.")
+ (license license:gpl2+)))
+
(define-public skymaker
(package
(name "skymaker")
--
2.37.3