curl: Enable sftp and scp protocols.

  • Open
  • quality assurance status badge
Details
2 participants
  • elaexuotee
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
elaexuotee
Severity
normal
E
E
elaexuotee wrote on 1 Oct 2022 10:28
(address . bug-guix@gnu.org)
28RFBJCTKG6BF.27U4995JD8SM4@wilsonb.com
Apparently, our curl is compiled without libssl2 support enabled,

$ curl scp://...
curl: (1) Protocol "scp" not supported or disabled in libcurl

This patch fixes that.
From 7d90bdbd6377ca29387d0482eefc5f051ff524ed Mon Sep 17 00:00:00 2001
From: "B. Wilson" <elaexuotee@wilsonb.com>
Date: Sat, 1 Oct 2022 17:00:44 +0900
Subject: [PATCH] curl: Enable sftp and scp protocols.
To: bug-guix@gnu.org

---
gnu/packages/curl.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index d82d94abff..29f70f1abe 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,7 +77,7 @@ (define-public curl
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
- (inputs (list gnutls libidn mit-krb5
+ (inputs (list gnutls libidn libssh2 mit-krb5
`(,nghttp2 "lib") zlib))
(native-inputs
`(("nghttp2" ,nghttp2)
@@ -100,6 +101,8 @@ (define-public curl
#:configure-flags (list "--with-gnutls"
(string-append "--with-gssapi="
(assoc-ref %build-inputs "mit-krb5"))
+ (string-append "--with-libssh2="
+ (assoc-ref %build-inputs "libssh2"))
"--disable-static")
#:phases
(modify-phases %standard-phases
--
2.37.3
T
T
Tobias Geerinckx-Rice wrote on 1 Oct 2022 13:53
(no subject)
(name . GNU Debbugs)(address . control@debbugs.gnu.org)
87v8p3dakx.fsf@nckx
tag 58215 + patch
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 58215@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58215
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch