Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/emacs-xyz.scm (emacs-nov-el): Update to 0.4.0.
[arguments]: Use gexps.
---
gnu/packages/emacs-xyz.scm | 22 +++++++++++-----------
1 file changed, 11 insertions(+), 11 deletions(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6d9d0d6a8f..5b8bbd5e5c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18554,7 +18554,7 @@ (define-public emacs-esxml
(define-public emacs-nov-el
(package
(name "emacs-nov-el")
- (version "0.3.4")
+ (version "0.4.0")
(source
(origin
(method git-fetch)
@@ -18564,18 +18564,18 @@ (define-public emacs-nov-el
(file-name (git-file-name name version))
(sha256
(base32
- "0va9xjrq30cv5kb59a4rq5mcm83ggnv774r8spmskff3hj8012wf"))))
+ "10507fdfx02wb3j7g34w4ii8rgnjbmriq63ir6x1agf38s3i9p52"))))
(build-system emacs-build-system)
(arguments
- `(#:emacs ,emacs ;need libxml
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'embed-path-to-unzip
- (lambda _
- (substitute* "nov.el"
- (("\\(executable-find \"unzip\"\\)")
- (string-append "\"" (which "unzip") "\"")))
- #t)))))
+ (list
+ #:emacs emacs ;need libxml
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'embed-path-to-unzip
+ (lambda _
+ (substitute* "nov.el"
+ (("\\(executable-find \"unzip\"\\)")
+ (string-append "\"" (which "unzip") "\""))))))))
(propagated-inputs
(list emacs-dash emacs-esxml))
(inputs
--
2.37.3