[PATCH 0/4] gnu: pantalaimon: Update to 0.10.5

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221001042726.28433-1-mike@rohleder.de
I want to package https://github.com/8go/matrix-commanderwhich needs a newer
matrix-nio. This needs newer version of python-aiohttp-socks which needs
newer python-socks. After testing the deps of python-socks, pantalaimon needs
a bump, electrum and weechat-matrix build.

Michael Rohleder (4):
gnu: python-socks: Update to 2.0.3.
gnu: python-aiohttp-socks: Update to 0.7.1.
gnu: python-matrix-nio: Update to 0.20.0.
gnu: pantalaimon: Update to 0.10.5.

gnu/packages/matrix.scm | 15 ++++++++-------
gnu/packages/python-web.scm | 12 ++++++------
2 files changed, 14 insertions(+), 13 deletions(-)

--
2.37.3
Michael Rohleder wrote 2 years ago
[PATCH 1/4] gnu: python-socks: Update to 2.0.3.
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221001042726.28433-2-mike@rohleder.de
* gnu/packages/python-web.scm (python-socks): Update to 2.0.3.
[arguments]<#:phases>: Remove trailing #t.
---
gnu/packages/python-web.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94544e1e74..f1eb4fb7b5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6555,14 +6555,14 @@ (define-public python-socketio
(define-public python-socks
(package
(name "python-socks")
- (version "1.2.4")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-socks" version))
(sha256
(base32
- "1n6xb18jy41ybgkmamakg6psp3qididd45qknxiggngaiibz43kx"))))
+ "12msk06c0glljcrx1byd78xgv05lxw81vknqwhn8ccs7an7cmag3"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; tests not included
@@ -6571,8 +6571,7 @@ (define-public python-socks
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "tests/" "-s"))
- #t)))))
+ (invoke "pytest" "tests/" "-s")))))))
(propagated-inputs
(list python-async-timeout python-curio python-trio))
(native-inputs
--
2.37.3
Michael Rohleder wrote 2 years ago
[PATCH 2/4] gnu: python-aiohttp-socks: Update to 0.7.1.
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221001042726.28433-3-mike@rohleder.de
* gnu/packages/python-web.scm (python-aiohttp-socks): Update to 0.7.1.
---
gnu/packages/python-web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f1eb4fb7b5..2983381cc2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 msimonin <matthieu.simonin@inria.fr>
+;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -432,14 +433,14 @@ (define-public python-aiohttp
(define-public python-aiohttp-socks
(package
(name "python-aiohttp-socks")
- (version "0.6.0")
+ (version "0.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiohttp_socks" version))
(sha256
(base32
- "04w010bvi719ifpc3sshav95k10hf9nq8czn9yglkj206yxcypdr"))))
+ "06il43dv6qm858af841vq9qadw6h7qsfs06nnwagmwqyi72cl592"))))
(build-system python-build-system)
(propagated-inputs
(list python-aiohttp python-attrs python-socks))
--
2.37.3
Michael Rohleder wrote 2 years ago
[PATCH 3/4] gnu: python-matrix-nio: Update to 0.20.0.
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221001042726.28433-4-mike@rohleder.de
* gnu/packages/matrix.scm (python-matrix-nio): Update to 0.20.0.
[native-inputs]: Add python-pytest-asyncio.
[propagated-inputs]: Changed python-jsonschema to python-jsonschema-next.
---
gnu/packages/matrix.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 2ba6d8ba1f..8e543f0a91 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
@@ -158,13 +158,13 @@ (define-public synapse
(define-public python-matrix-nio
(package
(name "python-matrix-nio")
- (version "0.18.7")
+ (version "0.20.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "matrix-nio" version))
(sha256
- (base32 "0cw4y6dx8n8hynxqlzzkj8p34nfbc2xryvmkr5yhmja31y4rks4k"))))
+ (base32 "1ycrp48b15nm2d3w3qpzps21czl3gbikadl10sncbzr9wdwn44g4"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -191,6 +191,7 @@ (define-public python-matrix-nio
("python-hpack" ,python-hpack)
("python-faker" ,python-faker)
("python-pytest-aiohttp" ,python-pytest-aiohttp)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)
("python-aioresponses" ,python-aioresponses)
("python-pytest-benchmark" ,python-pytest-benchmark)
("python-toml" ,python-toml)
@@ -206,7 +207,7 @@ (define-public python-matrix-nio
(file-name (git-file-name name version))
(sha256
(base32
- "152prkndk53pfxm4in4xak4hwzyaxlbp6wv2zbk2xpzgyy9bvn3s"))))))
+ "10j8g3ns3v1ghdn262dxg50ayaczdp1hj97pj4ydw02bncqhddpd"))))))
(propagated-inputs
(list python-aiofiles
python-aiohttp
@@ -216,7 +217,7 @@ (define-public python-matrix-nio
python-future
python-h11
python-h2
- python-jsonschema
+ python-jsonschema-next
python-logbook
python-olm
python-peewee
--
2.37.3
Michael Rohleder wrote 2 years ago
[PATCH 4/4] gnu: pantalaimon: Update to 0.10.5.
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221001042726.28433-5-mike@rohleder.de
* gnu/packages/matrix.scm (pantalaimon): Update to 0.10.5.
---
gnu/packages/matrix.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 8e543f0a91..d5e0060c04 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -235,7 +235,7 @@ (define-public python-matrix-nio
(define-public pantalaimon
(package
(name "pantalaimon")
- (version "0.10.3")
+ (version "0.10.5")
(source
(origin
(method git-fetch)
@@ -245,7 +245,7 @@ (define-public pantalaimon
(file-name (git-file-name name version))
(sha256
(base32
- "153d8083lj3qqirbv5q1d3igzd61a5kyzfk7xmv29sd3jbs8ysm9"))))
+ "16ask8v00654q307c55q5gnm8hrj40gibpab5zl52v4i0bgl9j68"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.37.3
Efraim Flashner wrote 2 years ago
Re: [bug#58211] [PATCH 0/4] gnu: pantalaimon: Update to 0.10.5
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 58211-done@debbugs.gnu.org)
YznU2BRqPt5SEVJO@3900XT
On Sat, Oct 01, 2022 at 06:27:22AM +0200, Michael Rohleder wrote:
Toggle quote (15 lines)
> I want to package https://github.com/8go/matrix-commanderwhich needs a newer
> matrix-nio. This needs newer version of python-aiohttp-socks which needs
> newer python-socks. After testing the deps of python-socks, pantalaimon needs
> a bump, electrum and weechat-matrix build.
>
> Michael Rohleder (4):
> gnu: python-socks: Update to 2.0.3.
> gnu: python-aiohttp-socks: Update to 0.7.1.
> gnu: python-matrix-nio: Update to 0.20.0.
> gnu: pantalaimon: Update to 0.10.5.
>
> gnu/packages/matrix.scm | 15 ++++++++-------
> gnu/packages/python-web.scm | 12 ++++++------
> 2 files changed, 14 insertions(+), 13 deletions(-)

Everything looks good to me. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmM51NgACgkQQarn3Mo9
g1HvgA/9G8yrUdHs52s6k822cqs1tvXLFeP9OCgTLr3rXu36vuAKl2qC0neioBmd
Z9EL3pfW8yMBZ1227A9VG36AIQKIQgeoYs39e/5uxOIvCD7vgIJfQ5KZHxFQTdDk
9tDUq3fDxmV6GTSLsNrqR5XQeQicesvg6XXlBQRVUTakycay1cLtKjJ5KDcB0thI
Dff/2pbgJ9eS+R49tzclVhuih9pchr2iXN50+7THxSI/KKagPL/HKLj3jagiW8sh
qnNH79Ni9UcgS513IqX6XcC+aBS9Fp5aa3Tq+qHp4zwHV80GZ2VfO7ADumtzLG0A
OidA7KEjr/fhbyjqElnNX7nDtNgeFhnOPox62LxUbReOZoDOBjDdlVkVD0TiQJ+K
hwlszkxnxOcWWQW+OJSQJKx2KNX4AuOBWHdQYchWnoZ4KpRnbOssnlofJG17oThR
/fU4RzPOJALV06xj7np2lBG6L2NlhfcrT0EPm2y+GKaVy1ipiND1G1cl4nUlYHrM
Gt440tMiYjMd9iGUPRrsxxlysKGEn01Mc33kOTpZHstvd8aYAae/7pV27Y88Zq3m
C7LBdx/6LcWuk5Rd6rtbyzCB+nof7vRAKkxU5dazOnrVypFHCLGBiIuXhJTp6MkK
6pVl2fd7XkA9ZLR2PHIKid1s3vHU01ugz/RlCo3dIcWsy/oj2Vs=
=enl8
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58211@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58211
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help