Sergey Trofimov wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
I've noticed that despite openssl is listed as an input - it's not actually enabled by default.
Fixing that using a configure flag. W/o this change I was not able to use cache_peer with tls enabled.
---
gnu/packages/networking.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3d9ba4fc8d..3489c3b96a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2010,7 +2010,7 @@ (define-public squid
'(#:configure-flags
;; disable -march=native in build for reproducibility; see
;; https://wiki.squid-cache.org/KnowledgeBase/IllegalInstructionError
- (list "--disable-arch-native")
+ (list "--disable-arch-native" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'build 'fix-true-path
--
2.37.3