[PATCH] gnu: bemenu: Update to 0.6.10, use new package style.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
0e05c782c1daa781f1617a6b7faf56f68da5f294.1664521850.git.kiasoc5@disroot.org
* gnu/packages/xdisorg.scm (bemenu): Update to 0.6.10.
[arguments]: Use G-expressions. Use #$output instead of assoc-ref.
[inputs]: Remove labels.
---
gnu/packages/xdisorg.scm | 39 ++++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 19 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9908f29191..cc94cc0c95 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -313,7 +313,7 @@ (define-public autorandr
(define-public bemenu
(package
(name "bemenu")
- (version "0.6.4")
+ (version "0.6.10")
(source
(origin
(method git-fetch)
@@ -322,27 +322,28 @@ (define-public bemenu
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "18vplvnymgc6576sdh84lm5rlwyb9d038plqpjs638hzskf4q577"))))
+ (base32 "0i2pv3qnb0l2ryvj9ycf9d5rng6yfk0kpjkq8hy6g956672wdzx6"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "CFLAGS=-O2 -fPIC"
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (list
+ #:tests? #f
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ "CFLAGS=-O2 -fPIC"
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib")
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(inputs
- `(("cairo" ,cairo)
- ("libx11" ,libx11)
- ("libxkbcomon" ,libxkbcommon)
- ("libxinerama" ,libxinerama)
- ("ncurses" ,ncurses)
- ("pango" ,pango)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
+ (list cairo
+ libx11
+ libxkbcommon
+ libxinerama
+ ncurses
+ pango
+ wayland
+ wayland-protocols))
(native-inputs
(list doxygen pkg-config))
(home-page "https://github.com/Cloudef/bemenu")

base-commit: 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337
--
2.37.3
Ludovic Courtès wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 58188-done@debbugs.gnu.org)
87bkqejast.fsf@gnu.org
kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/xdisorg.scm (bemenu): Update to 0.6.10.
> [arguments]: Use G-expressions. Use #$output instead of assoc-ref.
> [inputs]: Remove labels.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58188@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58188
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help