[PATCH 3/3] gnu: Add ocaml-ipaddr.

  • Open
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
Merged with
R
R
raingloom wrote on 29 Sep 2022 18:47
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20220929164718.16973-3-raingloom@riseup.net
* gnu/packages/ocaml-mirage.scm (ocaml-ipaddr): New variable.
---
This is the first of a number of packages needed to get MirageOS building under Guix.

gnu/packages/ocaml-mirage.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/ocaml-mirage.scm b/gnu/packages/ocaml-mirage.scm
index b1389507d5..488d46fcf5 100644
--- a/gnu/packages/ocaml-mirage.scm
+++ b/gnu/packages/ocaml-mirage.scm
@@ -92,3 +92,16 @@ (define-public ocaml-macaddr
`Macaddr_sexp` library
@end itemize")
(license license:isc)))
+
+(define-public ocaml-ipaddr
+ ;; same repo and versions as ocaml-macaddr
+ (package
+ (inherit ocaml-macaddr)
+ (name "ocaml-ipaddr")
+ (arguments (ipaddr-arguments "macaddr"))
+ (propagated-inputs (list ocaml-macaddr ocaml-domain-name))
+ (synopsis
+ "Library for manipulation of IP (and MAC) address representations")
+ (description
+ "IP address types with serialization, supporting a wide range of RFCs.")
+ (license license:isc)))
--
2.37.3
C
C
Christopher Baines wrote on 21 Nov 2022 14:50
(no subject)
(name . GNU Debbugs)(address . control@debbugs.gnu.org)
87a64kv2kn.fsf@cbaines.net
merge 58172 58173 58174
thanks
C
C
Christopher Baines wrote on 21 Nov 2022 15:52
tag 58173 moreinfo
(address . control@debbugs.gnu.org)
877czo742f.fsf@cbaines.net
tags 58173 + moreinfo
quit
?