[PATCH] gnu: Add emacs-circadian.

  • Done
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • Nicolas Goaziou
  • Maxim Cournoyer
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 29 Sep 2022 06:22
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
95dbafb1ebd166bb70758e94285a966e66d43caa.1664425321.git.kiasoc5@disroot.org
* gnu/packages/emacs-xyz.scm (emacs-circadian): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5d49c2925..c8bd2e9aa0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19526,6 +19526,28 @@ (define-public emacs-ts
timestamps by providing a @code{ts} struct.")
(license license:gpl3+)))
+(define-public emacs-circadian
+ (package
+ (name "emacs-circadian")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://stable.melpa.org/packages/circadian-"
+ version ".el"))
+ (sha256
+ (base32
+ "1pypy9bhg4lmmjjj0yqvlqs478i84x3awgzzjzdmrj1jlqbbvdj7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/guidoschmidt/circadian.el")
+ (synopsis "Theme-switching for Emacs based on daytime")
+ (description "emacs-circadian tries to help reduce eye strain that
+may arise from the difference of the display brightness and surrounding
+light by automatically switching between light and dark themes. It is
+inspired by color temperature shifting tools and brightness adaption
+software.")
+ (license license:expat)))
+
(define-public emacs-peg
(package
(name "emacs-peg")

base-commit: 45eac6cdf5c8d9d7b0c564b105c790d2d2007799
--
2.37.3
N
N
Nicolas Goaziou wrote on 29 Sep 2022 11:48
(name . kiasoc5 via Guix-patches via)(address . guix-patches@gnu.org)
87v8p6bjem.fsf@nicolasgoaziou.fr
Hello,

kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-circadian): New variable.

Thank you.

Toggle quote (6 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://stable.melpa.org/packages/circadian-"
> + version ".el"))

Tarballs from Stable MELPA are not considered stable (!). Could you use
GitHub as upstream?

Toggle quote (8 lines)
> + (sha256
> + (base32
> + "1pypy9bhg4lmmjjj0yqvlqs478i84x3awgzzjzdmrj1jlqbbvdj7"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/guidoschmidt/circadian.el")
> + (synopsis "Theme-switching for Emacs based on daytime")
> + (description "emacs-circadian tries to help reduce eye strain that

Circadian reduces eye strain…

or

Circadian may reduce…

In any case the project is named Circadian, "emacs-circadian" being the
name of the Guix variable bound to the package.

Toggle quote (6 lines)
> +may arise from the difference of the display brightness and surrounding
> +light by automatically switching between light and dark themes. It is
> +inspired by color temperature shifting tools and brightness adaption
> +software.")
> + (license license:expat)))

Licensing is ambiguous. The LICENSE file is expat, but the sole ".el"
file is explicitly GPL3+. So I guess this would be (list gpl3+ expat).

Could you also activate tests for this package? See for example
"emacs-go-mode" for an example. You will need to add emacs-el-mock
and emacs-ert-runner to the list of native inputs.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
M
M
Maxim Cournoyer wrote on 8 Oct 2022 06:36
control message for bug #58156
(address . control@debbugs.gnu.org)
871qrj2apj.fsf@gmail.com
tags 58156 + moreinfo
quit
K
K
kiasoc5 wrote on 9 Nov 2022 08:52
close 58156
(address . control@debbugs.gnu.org)
19603325-1eff-5b8a-7853-887249a38c8a@disroot.org
close 58156
thanks

Resolved in 58266
?