Some progresses indeed, but still failing during compile time this time :
(base) mhaefele@mdlspc113:m2-mms-hpc (master)*$ guix build --no-substitutes \
$(guix gc --derivers /gnu/store/r658y3cgpnf99nxjxqgjiaizx20ac4k0-guile-2.2.4)
[...]
configure: summary of build options:
Version: GNU MP 6.0.0
Host type: none-unknown-linux-gnu
ABI: standard
Install prefix: /gnu/store/n4xapbpjryd69dia5yxmz4ah5k6iwhjb-gcc-cross-boot0-5.5.0
Compiler: gcc -std=gnu99
Static libraries: yes
Shared libraries: no
[...]
g++ -g -O2 -DIN_GCC -DCROSS_DIRECTORY_STRUCTURE -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing
-Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros
-Wno-overlength-strings -DHAVE_CONFIG_H -static-libstdc++ -static-libgcc
-Wl,-rpath=/gnu/store/8zqhf670igizfl895hnhhmx9vz6zyzsj-glibc-bootstrap-0/lib -Wl,-dynamic-linker
-Wl,/gnu/store/8zqhf670igizfl895hnhhmx9vz6zyzsj-glibc-bootstrap-0/lib/ld-linux-x86-64.so.2 -o cc1 c/c-lang.o c-family/stub-objc.o
attribs.o c/c-errors.o c/c-decl.o c/c-typeck.o c/c-convert.o c/c-aux-info.o c/c-objc-common.o c/c-parser.o c/c-array-notation.o
c-family/c-common.o c-family/c-cppbuiltin.o c-family/c-dump.o c-family/c-format.o c-family/c-gimplify.o c-family/c-lex.o
c-family/c-omp.o c-family/c-opts.o c-family/c-pch.o c-family/c-ppoutput.o c-family/c-pragma.o c-family/c-pretty-print.o
c-family/c-semantics.o c-family/c-ada-spec.o c-family/c-cilkplus.o c-family/array-notation-common.o c-family/cilk.o
c-family/c-ubsan.o i386-c.o glibc-c.o \
cc1-checksum.o libbackend.a main.o libcommon-target.a libcommon.a ../libcpp/libcpp.a ../libdecnumber/libdecnumber.a
libcommon.a ../libcpp/libcpp.a ../libbacktrace/.libs/libbacktrace.a ../libiberty/libiberty.a ../libdecnumber/libdecnumber.a
-L/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/./gmp/.libs
-L/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/./mpfr/src/.libs
-L/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/./mpc/src/.libs -lmpc -lmpfr -lgmp -rdynamic -ldl -L../zlib -lz
g++ -g -O2 -DIN_GCC -DCROSS_DIRECTORY_STRUCTURE -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing
-Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros
-Wno-overlength-strings -DHAVE_CONFIG_H -static-libstdc++ -static-libgcc
-Wl,-rpath=/gnu/store/8zqhf670igizfl895hnhhmx9vz6zyzsj-glibc-bootstrap-0/lib -Wl,-dynamic-linker
-Wl,/gnu/store/8zqhf670igizfl895hnhhmx9vz6zyzsj-glibc-bootstrap-0/lib/ld-linux-x86-64.so.2 -o cc1plus \
cp/cp-lang.o c-family/stub-objc.o cp/call.o cp/decl.o cp/expr.o cp/pt.o cp/typeck2.o cp/class.o cp/decl2.o cp/error.o
cp/lex.o cp/parser.o cp/ptree.o cp/rtti.o cp/typeck.o cp/cvt.o cp/except.o cp/friend.o cp/init.o cp/method.o cp/search.o
cp/semantics.o cp/tree.o cp/repo.o cp/dump.o cp/optimize.o cp/mangle.o cp/cp-objcp-common.o cp/name-lookup.o cp/cxx-pretty-print.o
cp/cp-cilkplus.o cp/cp-gimplify.o cp/cp-array-notation.o cp/lambda.o cp/vtable-class-hierarchy.o cp/constexpr.o cp/cp-ubsan.o
attribs.o incpath.o c-family/c-common.o c-family/c-cppbuiltin.o c-family/c-dump.o c-family/c-format.o c-family/c-gimplify.o
c-family/c-lex.o c-family/c-omp.o c-family/c-opts.o c-family/c-pch.o c-family/c-ppoutput.o c-family/c-pragma.o
c-family/c-pretty-print.o c-family/c-semantics.o c-family/c-ada-spec.o c-family/c-cilkplus.o c-family/array-notation-common.o
c-family/cilk.o c-family/c-ubsan.o i386-c.o glibc-c.o cc1plus-checksum.o libbackend.a main.o libcommon-target.a libcommon.a
../libcpp/libcpp.a ../libdecnumber/libdecnumber.a libcommon.a ../libcpp/libcpp.a ../libbacktrace/.libs/libbacktrace.a
../libiberty/libiberty.a ../libdecnumber/libdecnumber.a -L/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/./gmp/.libs
-L/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/./mpfr/src/.libs
-L/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/./mpc/src/.libs -lmpc -lmpfr -lgmp -rdynamic -ldl -L../zlib -lz
collect2: error: ld returned 1 exit status
make[2]: *** [../../gcc-5.5.0/gcc/c/Make-lang.in:71: cc1] Error 1
make[2]: *** Waiting for unfinished jobs....
collect2: error: ld returned 1 exit status
make[2]: *** [../../gcc-5.5.0/gcc/lto/Make-lang.in:71: lto1] Error 1
collect2: error: ld returned 1 exit status
make[2]: *** [../../gcc-5.5.0/gcc/cp/Make-lang.in:99: cc1plus] Error 1
make[2]: Leaving directory '/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build/gcc'
make[1]: *** [Makefile:4105: all-gcc] Error 2
make[1]: Leaving directory '/tmp/guix-build-gcc-cross-boot0-5.5.0.drv-0/build'
make: *** [Makefile:859: all] Error 2
Backtrace:
In ice-9/boot-9.scm:
157: 12 [catch #t #<catch-closure c900a0> ...]
In unknown file:
?: 11 [apply-smob/1 #<catch-closure c900a0>]
In ice-9/boot-9.scm:
63: 10 [call-with-prompt prompt0 ...]
In ice-9/eval.scm:
432: 9 [eval # #]
In ice-9/boot-9.scm:
2320: 8 [save-module-excursion #<procedure cc1b80 at ice-9/boot-9.scm:3961:3 ()>]
3966: 7 [#<procedure cc1b80 at ice-9/boot-9.scm:3961:3 ()>]
1645: 6 [%start-stack load-stack #<procedure cbd2c0 at ice-9/boot-9.scm:3957:10 ()>]
1650: 5 [#<procedure cc3060 ()>]
In unknown file:
?: 4 [primitive-load "/gnu/store/1ybknnj20hqz1mnzi3my0hpd3mj7gpjz-gcc-cross-boot0-5.5.0-guile-builder"]
In ice-9/eval.scm:
387: 3 [eval # ()]
In srfi/srfi-1.scm:
830: 2 [every1 #<procedure 155dc40 at
/gnu/store/lpals6qq7ccbdldzamis7x9mv2p7g4sb-module-import/guix/build/gnu-build-system.scm:795:9 (expr)> ...]
In /gnu/store/lpals6qq7ccbdldzamis7x9mv2p7g4sb-module-import/guix/build/gnu-build-system.scm:
799: 1 [#<procedure 155dc40 at /gnu/store/lpals6qq7ccbdldzamis7x9mv2p7g4sb-module-import/guix/build/gnu-build-system.scm:795:9
(expr)> #]
In /gnu/store/lpals6qq7ccbdldzamis7x9mv2p7g4sb-module-import/guix/build/utils.scm:
616: 0 [invoke "make" "-j" ...]
/gnu/store/lpals6qq7ccbdldzamis7x9mv2p7g4sb-module-import/guix/build/utils.scm:616:6: In procedure invoke:
/gnu/store/lpals6qq7ccbdldzamis7x9mv2p7g4sb-module-import/guix/build/utils.scm:616:6: Throw to key `srfi-34' with args
`(#<condition &invoke-error [program: "make" arguments: ("-j" "8"
"LDFLAGS=-Wl,-rpath=/gnu/store/8zqhf670igizfl895hnhhmx9vz6zyzsj-glibc-bootstrap-0/lib -Wl,-dynamic-linker
-Wl,/gnu/store/8zqhf670igizfl895hnhhmx9vz6zyzsj-glibc-bootstrap-0/lib/ld-linux-x86-64.so.2" "BOOT_CFLAGS=-O2 -g0") exit-status: 2
term-signal: #f stop-signal: #f] 1e4ef00>)'.
builder for `/gnu/store/dd5vn44jf5w5wa1bx2v5n4mbvm577b4r-gcc-cross-boot0-5.5.0.drv' failed with exit code 1
build of /gnu/store/dd5vn44jf5w5wa1bx2v5n4mbvm577b4r-gcc-cross-boot0-5.5.0.drv failed
View build log at '/var/log/guix/drvs/dd/5vn44jf5w5wa1bx2v5n4mbvm577b4r-gcc-cross-boot0-5.5.0.drv.bz2'.
cannot build derivation `/gnu/store/01217q7g5wi7g0x9vx4w6429dvcbnlf8-gcc-cross-boot0-wrapped-5.5.0.drv': 1 dependencies couldn't
be built
cannot build derivation `/gnu/store/zlarpjla570axb9hi6c78njaf4y9ffci-glibc-2.28.drv': 1 dependencies couldn't be built
building /gnu/store/a5r02gf0s745bbb28mhbx3sfka2ddnd3-perl-boot0-5.28.0.drv...
cannot build derivation `/gnu/store/16c8c8hm1qdn6xz8014939mirc7c4d4j-guile-2.2.4.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/16c8c8hm1qdn6xz8014939mirc7c4d4j-guile-2.2.4.drv' failed
Not yet given up !!
Thanks for diving in this ocean of code and trying to make it manageable with a reproducible process to build it :)
BTW I am watching the videos of the very interesting event organized for the ten years of guix. The presentation of Efraim
Flashner stunted me. 40h of compile just for rust from the bootstrap on a RISC-V but still GHz processor. How can these things
work in the end ... ? Life, as the single negentropic known process should play its role here as well. The minimalism wished by
Pjotr Prins is the way to go if we want to keep the illusion of controlling what we are doing.
Thanks for your work guys :)
Mat