[PATCH 0/2] Update bloomberg-bde.

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 28 Sep 2022 15:12
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1664219254.git.code@greghogan.com
The current version of bloomberg-bde fails to compile with gcc-11, the
new default on the core-updates branch.

Sucessfully builds on master and core-updates. No dependent packages.

Greg Hogan (2):
gnu: bloomberg-bde-tools: Update to 3.107.0.0.
gnu: bloomberg-bde: Update to 3.108.0.1.

gnu/packages/cpp.scm | 26 +++++++++++---------------
1 file changed, 11 insertions(+), 15 deletions(-)

--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:14
[PATCH 2/2] gnu: bloomberg-bde: Update to 3.108.0.1.
(address . 58143@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
da37d8c6edbaed1001352e355a8b4d69f88b74e0.1664219254.git.code@greghogan.com
* gnu/packages/cpp.scm (bloomberg-bde): Update to 3.108.0.1.
[source](origin): Update test deletion list.
---
gnu/packages/cpp.scm | 20 ++++++++------------
1 file changed, 8 insertions(+), 12 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index aa986557a8..4cde47e1f2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1782,11 +1782,11 @@ (define-public bloomberg-bde-tools
(license license:asl2.0))))
(define-public bloomberg-bde
- (let ((commit "b6bcc0e24a5862bf77aea7edd831dedf50e21d64"))
+ (let ((commit "86f9391332c87b896817a3b5a8f1c3ff113178b6"))
(package
(name "bloomberg-bde")
;; Recent releases are not tagged so commit must be used for checkout.
- (version "3.98.0.0")
+ (version "3.108.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1795,7 +1795,7 @@ (define-public bloomberg-bde
(file-name (git-file-name name version))
(sha256
(base32
- "0y3lipi1lj9qazgc935851r2qsx5aq3vvc4y52jq57riyz8wg3ma"))
+ "024psi9kv9069fga3y5y37b322871jpnm7xgdg1gl8s929y8czyl"))
(patches
(search-patches
"bloomberg-bde-cmake-module-path.patch"))
@@ -1809,18 +1809,14 @@ (define-public bloomberg-bde
;; Delete failing tests.
(for-each
delete-file
- (list "groups/bal/ball/ball_asyncfileobserver.t.cpp"
- "groups/bal/ball/ball_fileobserver2.t.cpp"
+ (list "groups/bal/ball/ball_fileobserver2.t.cpp"
"groups/bal/ball/ball_recordstringformatter.t.cpp"
"groups/bal/balst/balst_stacktraceutil.t.cpp"
- "groups/bdl/bdlmt/bdlmt_eventscheduler.t.cpp"
- "groups/bdl/bdlmt/bdlmt_timereventscheduler.t.cpp"
"groups/bdl/bdls/bdls_filesystemutil.t.cpp"
- "groups/bsl/bslh/bslh_hashpair.t.cpp"
- "groups/bsl/bsls/bsls_platform.t.cpp"
- "groups/bsl/bsls/bsls_stackaddressutil.t.cpp"
- "groups/bsl/bsls/bsls_stopwatch.t.cpp"
- "groups/bsl/bslstl/bslstl_function_invokerutil.t.cpp"))
+ "groups/bsl/bslh/bslh_hash.t.cpp"
+ "groups/bsl/bslstl/bslstl_deque.1.t.cpp"
+ "groups/bsl/bslstl/bslstl_deque.2.t.cpp"
+ "groups/bsl/bslstl/bslstl_deque.3.t.cpp"))
#t))))
(build-system cmake-build-system)
(arguments
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:14
[PATCH 1/2] gnu: bloomberg-bde-tools: Update to 3.107.0.0.
(address . 58143@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
6892cb2c4cc233ede670650d594a4981d2b4237c.1664219254.git.code@greghogan.com
* gnu/packages/cpp.scm (bloomberg-bde-tools): Update to 3.107.0.0.
---
gnu/packages/cpp.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d03e0bc7e1..aa986557a8 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1755,11 +1755,11 @@ (define-public simdjson
(license license:asl2.0)))
(define-public bloomberg-bde-tools
- (let ((commit "094885bd177e0159232d4e6a060a04edb1edd786"))
+ (let ((commit "9932ac566f454f66c0024d1dcf6e41a6a482ebf5"))
(package
(name "bloomberg-bde-tools")
;; Recent releases are not tagged so commit must be used for checkout.
- (version "3.97.0.0")
+ (version "3.107.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1768,7 +1768,7 @@ (define-public bloomberg-bde-tools
(file-name (git-file-name name version))
(sha256
(base32
- "0mbbai73z8amh23ah3wy35kmy612380yr5wg89mic60qwqmpqb02"))
+ "1ms0ws5mxzl3vykx4jbl8n8p771y980jpmc8xvf3m3wpd1rkjrnm"))
(patches
(search-patches
"bloomberg-bde-tools-fix-install-path.patch"))))
--
2.37.3
M
M
Maxim Cournoyer wrote on 28 Sep 2022 21:10
Re: bug#58143: [PATCH 0/2] Update bloomberg-bde.
(name . Greg Hogan)(address . code@greghogan.com)(address . 58143@debbugs.gnu.org)
87v8p7tiw3.fsf_-_@gmail.com
Hello,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (6 lines)
> * gnu/packages/cpp.scm (bloomberg-bde): Update to 3.108.0.1.
> [source](origin): Update test deletion list.
> ---
> gnu/packages/cpp.scm | 20 ++++++++------------
> 1 file changed, 8 insertions(+), 12 deletions(-)

Oof, this took a long time to build, and eventually failed with one
test:

Toggle snippet (23 lines)
s_baltst_testtaggedvalueutil = 0.05 sec*proc (1 test)
s_baltst_testtaggedvalueutil.t = 0.05 sec*proc (1 test)

Total Test time (real) = 922.80 sec

The following tests FAILED:
806 - bsls_timeutil.t (Failed)
Errors while running CTest
make: *** [Makefile:93: test] Error 8

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("test") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 923.9 seconds
command "make" "test" failed with status 2
builder for `/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' failed with exit code 1
@ build-failed /gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv - 1 builder for `/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' failed with exit code 1
derivation '/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' offloaded to 'localhost' failed: build of `/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' failed
build of /gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv failed
View build log at
'/var/log/guix/drvs/y6/08pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv'.

Could you please report it upstream (if not already) and disable it?

Thank you,

Maxim
M
M
Maxim Cournoyer wrote on 8 Oct 2022 06:38
control message for bug #58143
(address . control@debbugs.gnu.org)
87zge70w29.fsf@gmail.com
tags 58143 + moreinfo
quit
G
G
Greg Hogan wrote on 17 May 2023 17:16
[PATCH v2 0/2] Update bloomberg-bde.
(address . 58143@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230517151618.267854-1-code@greghogan.com
I submitted upstream a number of logs for failing tests, several of
which were reproduced and patched. Here, I have continued adding to the
deletion list any test which has failed during a build.

This v2 of the patch also updates the package versions and restricts the
builds to x86_64-linux.

Greg Hogan (2):
gnu: bloomberg-bde-tools: Update to 3.118.0.0.
gnu: bloomberg-bde: Update to 3.118.0.1.

gnu/packages/cpp.scm | 28 +++++++++++--------
.../bloomberg-bde-cmake-module-path.patch | 14 ++++------
2 files changed, 22 insertions(+), 20 deletions(-)

--
2.40.1
G
G
Greg Hogan wrote on 17 May 2023 17:16
[PATCH v2 1/2] gnu: bloomberg-bde-tools: Update to 3.118.0.0.
(address . 58143@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230517151618.267854-2-code@greghogan.com
* gnu/packages/cpp.scm (bloomberg-bde-tools): Update to 3.118.0.0.
---
gnu/packages/cpp.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 34ae9ef70e..8698951ad2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1993,11 +1993,11 @@ (define-public simdjson
(license license:asl2.0)))
(define-public bloomberg-bde-tools
- (let ((commit "094885bd177e0159232d4e6a060a04edb1edd786"))
+ (let ((commit "f63dfe9114cd7df29623bd01f644b9f654253972"))
(package
(name "bloomberg-bde-tools")
;; Recent releases are not tagged so commit must be used for checkout.
- (version "3.97.0.0")
+ (version "3.118.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2006,7 +2006,7 @@ (define-public bloomberg-bde-tools
(file-name (git-file-name name version))
(sha256
(base32
- "0mbbai73z8amh23ah3wy35kmy612380yr5wg89mic60qwqmpqb02"))
+ "1a5sw4xjwd222na3zkflm2gkmzhnfq17i8qapyaxszpiayf3hw6v"))
(patches
(search-patches
"bloomberg-bde-tools-fix-install-path.patch"))))
--
2.40.1
G
G
Greg Hogan wrote on 17 May 2023 17:16
[PATCH v2 2/2] gnu: bloomberg-bde: Update to 3.118.0.1.
(address . 58143@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230517151618.267854-3-code@greghogan.com
* gnu/packages/cpp.scm (bloomberg-bde): Update to 3.118.0.1.
[source](origin): Update test deletion list.
[arguments]<#:configure-flags>: Update from C++17 to C++20.
[supported-systems]: Only support x86_64-linux.
* gnu/packages/patches/bloomberg-bde-cmake-module-path.patch: Rebase.
---
gnu/packages/cpp.scm | 22 +++++++++++--------
.../bloomberg-bde-cmake-module-path.patch | 14 +++++-------
2 files changed, 19 insertions(+), 17 deletions(-)

Toggle diff (97 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8698951ad2..88d0dde561 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2020,11 +2020,11 @@ (define-public bloomberg-bde-tools
(license license:asl2.0))))
(define-public bloomberg-bde
- (let ((commit "b6bcc0e24a5862bf77aea7edd831dedf50e21d64"))
+ (let ((commit "77a0f39d538c20ae28bece9a81cac99a9e1df95d"))
(package
(name "bloomberg-bde")
;; Recent releases are not tagged so commit must be used for checkout.
- (version "3.98.0.0")
+ (version "3.118.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2033,7 +2033,7 @@ (define-public bloomberg-bde
(file-name (git-file-name name version))
(sha256
(base32
- "0y3lipi1lj9qazgc935851r2qsx5aq3vvc4y52jq57riyz8wg3ma"))
+ "0nw5clkc9yipd03kijh4c8lxi9zkxfxcjhszl1xzwvgz8xmpampf"))
(patches
(search-patches
"bloomberg-bde-cmake-module-path.patch"))
@@ -2050,26 +2050,28 @@ (define-public bloomberg-bde
(list "groups/bal/ball/ball_asyncfileobserver.t.cpp"
"groups/bal/ball/ball_fileobserver2.t.cpp"
"groups/bal/ball/ball_recordstringformatter.t.cpp"
+ "groups/bal/balst/balst_stacktraceresolver_filehelper.t.cpp"
"groups/bal/balst/balst_stacktraceutil.t.cpp"
"groups/bdl/bdlmt/bdlmt_eventscheduler.t.cpp"
"groups/bdl/bdlmt/bdlmt_timereventscheduler.t.cpp"
"groups/bdl/bdls/bdls_filesystemutil.t.cpp"
+ "groups/bsl/bslh/bslh_hash.t.cpp"
"groups/bsl/bslh/bslh_hashpair.t.cpp"
"groups/bsl/bsls/bsls_platform.t.cpp"
"groups/bsl/bsls/bsls_stackaddressutil.t.cpp"
"groups/bsl/bsls/bsls_stopwatch.t.cpp"
+ "groups/bsl/bsls/bsls_timeutil.t.cpp"
+ "groups/bsl/bslstl/bslstl_deque.1.t.cpp"
+ "groups/bsl/bslstl/bslstl_deque.2.t.cpp"
+ "groups/bsl/bslstl/bslstl_deque.3.t.cpp"
"groups/bsl/bslstl/bslstl_function_invokerutil.t.cpp"))
#t))))
(build-system cmake-build-system)
(arguments
`(#:parallel-tests? #f ; Test parallelism may fail inconsistently.
;; Set UFID to build shared libraries. Flag descriptions can be found at
- ;; https://bloomberg.github.io/bde-tools/reference/bde_repo.html#ufid
- #:configure-flags ,(match %current-system
- ((or "i686-linux" "armhf-linux")
- ''("-DUFID=opt_dbg_exc_mt_32_shr_cpp17"))
- (_
- ''("-DUFID=opt_dbg_exc_mt_64_shr_cpp17")))
+ ;; https://bloomberg.github.io/bde-tools/bbs/reference/bbs_build_configuration.html#ufid
+ #:configure-flags '("-DUFID=opt_dbg_exc_mt_64_shr_cpp20")
#:phases
(modify-phases %standard-phases
;; Explicitly build tests separate from the main build.
@@ -2089,6 +2091,8 @@ (define-public bloomberg-bde
concepts (like dates and times), and building blocks for developing
multi-threaded applications and network applications.")
(home-page "https://github.com/bloomberg/bde")
+ ;; Out-of-memory on i686-linux, compile errors with non-x86.
+ (supported-systems '("x86_64-linux"))
(license license:asl2.0))))
(define-public gulrak-filesystem
diff --git a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
index b08ca5eac0..7743863cf8 100644
--- a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
+++ b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
@@ -4,13 +4,11 @@ locating the bloomberg-bde-tools CMake modules.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1,8 +1,6 @@
- cmake_minimum_required(VERSION 3.15)
+@@ -14,6 +14,7 @@ else()
+ if (NOT CMAKE_MODULE_PATH)
+ message(FATAL "Please specify path to BDE cmake modules.")
+ endif()
++ string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
--if (NOT CMAKE_MODULE_PATH)
-- message(FATAL "Please specify path to BDE cmake modules.")
--endif()
-+string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
-
- get_filename_component(repoName ${CMAKE_CURRENT_LIST_DIR} NAME)
+ include(bde_workspace)
--
2.40.1
L
L
Ludovic Courtès wrote on 17 Aug 2023 18:59
Re: bug#58143: [PATCH 0/2] Update bloomberg-bde.
(name . Greg Hogan)(address . code@greghogan.com)(address . 58143-done@debbugs.gnu.org)
87msypvc43.fsf_-_@gnu.org
Hi,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (3 lines)
> gnu: bloomberg-bde-tools: Update to 3.118.0.0.
> gnu: bloomberg-bde: Update to 3.118.0.1.

Finally applied, thanks!

Ludo’.
Closed
?