[PATCH 0/7] Update tealdeer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 28 Sep 2022 15:00
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1664369656.git.code@greghogan.com
tealdeer is broken on master. I have not been able to build this
upgraded version of tealdeer without using the exact version match for
rust-clap. Guix currently packages the beta version of clap v3, with
tealdeer depending on the release candiate (the current release of clap
is v3.2.22).

Greg Hogan (7):
gnu: Add rust-pager-0.16.
gnu: rust-pager-0.15: Inherit from rust-pager-0.16.
gnu: Add rust-textwrap-0.14.
gnu: rust-textwrap-0.12: Inherit from rust-textwrap-0.14.
gnu: Add rust-clap-derive-3.0.0-rc.11.
gnu: Add rust-clap-3.0.0-rc.11.
gnu: tealdeer: Update to 1.5.0.

gnu/packages/crates-io.scm | 123 +++++++++++++++++++++++++++++--------
gnu/packages/rust-apps.scm | 23 +++----
2 files changed, 111 insertions(+), 35 deletions(-)

--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 1/7] gnu: Add rust-pager-0.16.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
6b364139f9784dfa946e61c75ca3cbc203cce5b3.1664369656.git.code@greghogan.com
* gnu/packages/crates-io.scm (rust-pager-0.16): New variable.
---
gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f83d7fff6d..a8cf5e5444 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41692,6 +41692,28 @@ (define-public rust-page-size-0.4
memory page size.")
(license (list license:expat license:asl2.0))))
+(define-public rust-pager-0.16
+ (package
+ (name "rust-pager")
+ (version "0.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "pager" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10188qgnsz988g30fvl4whkljh2zl4gpbp6kc48bpywpbhd23695"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-errno" ,rust-errno-0.2)
+ ("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://gitlab.com/imp/pager-rs.git")
+ (synopsis "Helps pipe your output through an external pager")
+ (description
+ "This package pipes your Rust output through an external pager.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-pager-0.15
(package
(name "rust-pager")
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 2/7] gnu: rust-pager-0.15: Inherit from rust-pager-0.16.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
f2ff940c8fa798b8a43021701d84a60066bbb998.1664369656.git.code@greghogan.com
* gnu/packages/crates-io.scm (rust-pager-0.15): Inherit from
rust-pager-0.16.
---
gnu/packages/crates-io.scm | 13 ++-----------
1 file changed, 2 insertions(+), 11 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a8cf5e5444..1cda57c42e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41716,6 +41716,7 @@ (define-public rust-pager-0.16
(define-public rust-pager-0.15
(package
+ (inherit rust-pager-0.16)
(name "rust-pager")
(version "0.15.0")
(source
@@ -41726,17 +41727,7 @@ (define-public rust-pager-0.15
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0a35mg68s0p63ya2k5hsg620c4llkjw2fx1sfi0laz4pz8myv75n"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-errno" ,rust-errno-0.2)
- ("rust-libc" ,rust-libc-0.2))))
- (home-page "https://gitlab.com/imp/pager-rs.git")
- (synopsis "Helps pipe your output through an external pager")
- (description
- "This package pipes your Rust output through an external pager.")
- (license (list license:asl2.0 license:expat))))
+ "0a35mg68s0p63ya2k5hsg620c4llkjw2fx1sfi0laz4pz8myv75n"))))))
(define-public rust-palette-0.5
(package
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 3/7] gnu: Add rust-textwrap-0.14.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
787eab571f6843fbe7d47e094c7d188249bb02f3.1664369657.git.code@greghogan.com
* gnu/packages/crates-io.scm (rust-textwrap-0.14): New variable.
---
gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1cda57c42e..a1b94bf957 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -64605,6 +64605,35 @@ (define-public rust-text-size-1
(description "This package provides a newtypes for text offsets")
(license (list license:expat license:asl2.0))))
+(define-public rust-textwrap-0.14
+ (package
+ (name "rust-textwrap")
+ (version "0.14.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "textwrap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "106xjfzfpk3nj51fx9slf9kyir7xjwvpqm003v9ardgq5b8whrh0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-hyphenation" ,rust-hyphenation-0.8)
+ ("rust-smawk" ,rust-smawk-0.3)
+ ("rust-terminal-size" ,rust-terminal-size-0.1)
+ ("rust-unicode-linebreak" ,rust-unicode-linebreak-0.1)
+ ("rust-unicode-width" ,rust-unicode-width-0.1))))
+ (home-page "https://github.com/mgeisler/textwrap")
+ (synopsis "Library for word wrapping, indenting, and dedenting strings")
+ (description
+ "Textwrap is a small library for word wrapping, indenting, and dedenting
+strings. You can use it to format strings (such as help and error messages)
+for display in commandline applications. It is designed to be efficient and
+handle Unicode characters correctly.")
+ (license license:expat)))
+
(define-public rust-textwrap-0.12
(package
(name "rust-textwrap")
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 4/7] gnu: rust-textwrap-0.12: Inherit from rust-textwrap-0.14.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
f546ea7c6edc73918b836c7b5ffc4e77f15f7a8e.1664369657.git.code@greghogan.com
* gnu/packages/crates-io.scm (rust-textwrap-0.12): Inherit from
rust-textwrap-0.14.
---
gnu/packages/crates-io.scm | 16 +++-------------
1 file changed, 3 insertions(+), 13 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a1b94bf957..8c8e958418 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -64636,6 +64636,7 @@ (define-public rust-textwrap-0.14
(define-public rust-textwrap-0.12
(package
+ (inherit rust-textwrap-0.14)
(name "rust-textwrap")
(version "0.12.1")
(source
@@ -64647,22 +64648,11 @@ (define-public rust-textwrap-0.12
(sha256
(base32
"12978qmkl5gcp94lxndpvp9qxq8mxp7hm9xbrw3422dgikchhc10"))))
- (build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-hyphenation" ,rust-hyphenation-0.8)
("rust-terminal-size" ,rust-terminal-size-0.1)
- ("rust-unicode-width" ,rust-unicode-width-0.1))))
- (home-page
- "https://github.com/mgeisler/textwrap")
- (synopsis "Library for word wrapping, indenting, and dedenting strings")
- (description
- "Textwrap is a small library for word wrapping, indenting, and dedenting
-strings. You can use it to format strings (such as help and error messages)
-for display in commandline applications. It is designed to be efficient and
-handle Unicode characters correctly.")
- (license license:expat)))
+ ("rust-unicode-width" ,rust-unicode-width-0.1))))))
(define-public rust-textwrap-0.11
(package
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 5/7] gnu: Add rust-clap-derive-3.0.0-rc.11.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
50c20384e696c89a1c3f50a932582e87e972bebb.1664369657.git.code@greghogan.com
* gnu/packages/crates-io.scm (rust-clap-derive-3.0.0-rc.11): New
variable.
---
gnu/packages/crates-io.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8c8e958418..557298bcdd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11550,6 +11550,19 @@ (define-public rust-clap-derive-3
derive crate.")
(license (list license:expat license:asl2.0))))
+(define-public rust-clap-derive-3.0.0-rc.11
+ (package
+ (inherit rust-clap-derive-3)
+ (name "rust-clap-derive")
+ (version "3.0.0-rc.11")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "clap_derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c4rfzx4sczyajgishwbp9231i7a6p9ai2ahacillykp74krkncc"))))))
+
(define-public rust-clap-3
(package
(name "rust-clap")
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 6/7] gnu: Add rust-clap-3.0.0-rc.11.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
b594ce30f950e26cfb12728dcd357145036d71c7.1664369657.git.code@greghogan.com
* gnu/packages/crates-io.scm (rust-clap-3.0.0-rc.11) New variable.
---
gnu/packages/crates-io.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 557298bcdd..025e30d184 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11603,6 +11603,36 @@ (define-public rust-clap-3
Command Line Argument Parser.")
(license (list license:expat license:asl2.0))))
+(define-public rust-clap-3.0.0-rc.11
+ (package
+ (inherit rust-clap-3)
+ (name "rust-clap")
+ (version "3.0.0-rc.11")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "clap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19qihvgiczr8nwrbpkc42ijk24q9f965c2iahpnzy2cz4z3l7wp6"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-atty" ,rust-atty-0.2)
+ ("rust-backtrace" ,rust-backtrace-0.3)
+ ("rust-bitflags" ,rust-bitflags-1)
+ ("rust-clap-derive" ,rust-clap-derive-3.0.0-rc.11)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-os-str-bytes" ,rust-os-str-bytes-6)
+ ("rust-strsim" ,rust-strsim-0.10)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-terminal-size" ,rust-terminal-size-0.1)
+ ("rust-textwrap" ,rust-textwrap-0.14)
+ ("rust-unicase" ,rust-unicase-2)
+ ("rust-yaml-rust" ,rust-yaml-rust-0.4))
+ #:cargo-development-inputs
+ (("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-regex" ,rust-regex-1))))))
+
(define-public rust-clap-2
(package
(inherit rust-clap-3)
--
2.37.3
G
G
Greg Hogan wrote on 28 Sep 2022 15:03
[PATCH 7/7] gnu: tealdeer: Update to 1.5.0.
(address . 58142@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
b28a3a72f1db76757f5eb8db77382341ea33537b.1664369657.git.code@greghogan.com
* gnu/packages/rust-apps.scm (tealdeer): Update to 1.5.0.
[arguments]<#:cargo-test-flags>: Skip new network tests.
<#:cargo-inputs>: Add rust-clap, rust-zip; update rust-env-logger,
rust-pager, rust-reqwest.
<#:cargo-development-inputs>: Update rust-assert-cmd, rust-predicates;
remove rust-remove-dir-all.
---
gnu/packages/rust-apps.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 74581bc1e5..d68a83d015 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1739,7 +1739,7 @@ (define-public swayhide
(define-public tealdeer
(package
(name "tealdeer")
- (version "1.4.1")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
@@ -1748,7 +1748,7 @@ (define-public tealdeer
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0cwf46k2rszcpydrqajnm4dvhggr3ms7sjma0jx02ch4fjicxch7"))))
+ "118hmrz58x1s0cgsg2dka7mq9rb01p5ivrd4njd03dnabhndihs6"))))
(build-system cargo-build-system)
(arguments
`(#:phases
@@ -1775,31 +1775,32 @@ (define-public tealdeer
"--skip=test_markdown_rendering"
"--skip=test_spaces_find_command"
"--skip=test_autoupdate_cache"
+ "--skip=test_cache_location_not_a_directory"
+ "--skip=test_create_cache_directory_path"
"--skip=test_update_cache")
#:cargo-inputs
(("rust-ansi-term" ,rust-ansi-term-0.12)
("rust-app-dirs2" ,rust-app-dirs2-2)
("rust-atty" ,rust-atty-0.2)
+ ("rust-clap" ,rust-clap-3.0.0-rc.11)
("rust-docopt" ,rust-docopt-1)
- ("rust-env-logger" ,rust-env-logger-0.7)
+ ("rust-env-logger" ,rust-env-logger-0.9)
("rust-flate2" ,rust-flate2-1)
("rust-log" ,rust-log-0.4)
- ("rust-pager" ,rust-pager-0.15)
- ("rust-reqwest" ,rust-reqwest-0.10)
+ ("rust-pager" ,rust-pager-0.16)
+ ("rust-reqwest" ,rust-reqwest-0.11)
("rust-serde" ,rust-serde-1)
("rust-serde-derive" ,rust-serde-derive-1)
("rust-tar" ,rust-tar-0.4)
("rust-toml" ,rust-toml-0.5)
("rust-walkdir" ,rust-walkdir-2)
- ("rust-xdg" ,rust-xdg-2))
+ ("rust-xdg" ,rust-xdg-2)
+ ("rust-zip" ,rust-zip-0.5))
#:cargo-development-inputs
- (("rust-assert-cmd" ,rust-assert-cmd-1)
+ (("rust-assert-cmd" ,rust-assert-cmd-2)
("rust-escargot" ,rust-escargot-0.5)
("rust-filetime" ,rust-filetime-0.2)
- ("rust-predicates" ,rust-predicates-1)
- ;; This earlier version is required to fix a bug.
- ;; Remove rust-remove-dir-all-0.5.2 when tealdeer gets upgraded
- ("rust-remove-dir-all" ,rust-remove-dir-all-0.5.2)
+ ("rust-predicates" ,rust-predicates-2)
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs
(list pkg-config))
--
2.37.3
M
M
Maxim Cournoyer wrote on 28 Sep 2022 20:09
Re: bug#58142: [PATCH 0/7] Update tealdeer.
(name . Greg Hogan)(address . code@greghogan.com)(address . 58142@debbugs.gnu.org)
87r0zvv09c.fsf_-_@gmail.com
Hi Greg,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (28 lines)
> * gnu/packages/crates-io.scm (rust-clap-derive-3.0.0-rc.11): New
> variable.
> ---
> gnu/packages/crates-io.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 8c8e958418..557298bcdd 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -11550,6 +11550,19 @@ (define-public rust-clap-derive-3
> derive crate.")
> (license (list license:expat license:asl2.0))))
>
> +(define-public rust-clap-derive-3.0.0-rc.11
> + (package
> + (inherit rust-clap-derive-3)
> + (name "rust-clap-derive")
> + (version "3.0.0-rc.11")
> + (source (origin
> + (method url-fetch)
> + (uri (crate-uri "clap_derive" version))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0c4rfzx4sczyajgishwbp9231i7a6p9ai2ahacillykp74krkncc"))))))
> +

Not only is 3.0.0-rc.11 old, but 3.0.0 was released since, which ought
to be compatible. Can't we use a newer version, or at least 3.0.0? If
not, please report the issue to tealdeer, as it's silly to hard-peg
dependencies on old RC releases.

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 28 Sep 2022 20:10
(name . Greg Hogan)(address . code@greghogan.com)(address . 58142@debbugs.gnu.org)
87mtajv07g.fsf_-_@gmail.com
Hi,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (2 lines)
> * gnu/packages/crates-io.scm (rust-clap-3.0.0-rc.11) New variable.

Same comment as my previous one here; new versions are available and
should be used, or at least the stable one that followed the RCs.

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 8 Oct 2022 06:38
control message for bug #58142
(address . control@debbugs.gnu.org)
87y1tr0w24.fsf@gmail.com
tags 58142 + moreinfo
quit
G
G
Greg Hogan wrote on 7 Nov 2022 18:57
Re: bug#58142: [PATCH 0/7] Update tealdeer.
(address . 58142-done@debbugs.gnu.org)
CA+3U0Znc5SXDVPdAko5p5eh6HDZgnE88SLgqzcYXPMLEOa1LHQ@mail.gmail.com

Closed
?