(address . guix-patches@gnu.org)
Hi,
we provide a `guix serach`-based package search to our users and noticed
that searching for “ggplot2” yields the package r-ggplot2 on position
11 only – when it should be the first. Looking at other potential
search terms (haven, shiny, ape, renv, here, ini, setuptools) reveals
similar issues.
I propose we also score the unprefixed package name, so SCORE can award
bonus points for a full string match. I don’t like that we have to
maintain a list of common prefixes for this and that package names are
scored twice now, but I can’t think of a better solution right now.
Cheers,
Lars
* guix/ui.scm (%package-metrics): Increase score for PACKAGE-NAME and
add score for unprefixed package name.
---
guix/ui.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)
Toggle diff (46 lines)
diff --git a/guix/ui.scm b/guix/ui.scm
index dad2b853ac..55b596ed35 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -1655,7 +1655,38 @@ (define (regexp->score regexp)
(define %package-metrics
;; Metrics used to compute the "relevance score" of a package against a set
;; of regexps.
- `((,package-name . 4)
+ `((,package-name . 8)
+
+ ;; For packages with a language prefix (namespaces), also compare the
+ ;; unprefixed name, so searching for “ggplot2” yields
+ ;; r-ggplot2 as first result instead of other, higher-ranked packages,
+ ;; which contain “ggplot2” in their description alot.
+ (,(lambda (package)
+ (let ((namespaces (list "cl-"
+ "ecl-"
+ "emacs-"
+ "ghc-"
+ "go-"
+ "guile-"
+ "java-"
+ "julia-"
+ "node-"
+ "ocaml-"
+ "perl-"
+ "python-"
+ "r-"
+ "ruby-"
+ "rust-"
+ "sbcl-"
+ "texlive-"))
+ (name (package-name package)))
+ (fold (lambda (prefix accum)
+ (if (string-prefix? prefix name)
+ (cons (substring name (string-length prefix)) accum)
+ accum))
+ '()
+ namespaces)))
+ . 4)
;; Match against uncommon outputs.
(,(lambda (package)
--
2.35.1