[PATCH] gnu: swaylock-effects: Update to 1.6.10, use G-expressions.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
7d4d96f74baaaa61ec873829660ab4b35648ce5f.1664258790.git.kiasoc5@disroot.org
* gnu/packages/wm.scm (swaylock-effects): Update to 1.6.10.
[source]: Switch from commit to release tag.
[arguments]: Use G-expressions.
[home-page]: Switch to maintained fork.
---
gnu/packages/wm.scm | 47 ++++++++++++++++++---------------------------
1 file changed, 19 insertions(+), 28 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 310e62a00d..5699e42540 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1675,36 +1675,27 @@ (define-public swaylock
(license license:expat))) ; MIT license
(define-public swaylock-effects
- ;; Latest release is from November 2020, but doesn't support disabling SSE.
- (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
- (revision "1"))
- (package
- (inherit swaylock)
- (name "swaylock-effects")
- (version (git-version "1.6-3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mortie/swaylock-effects")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
- (arguments
- `(#:configure-flags '("-Dsse=false")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-meson
- (lambda _
- (substitute* "meson.build"
- (("'-mtune=native',") "")))))))
- (synopsis "Screen locking utility for Wayland compositors with effects")
- (description "@code{Swaylock-effects} is a fork of swaylock with additional
+ (package
+ (inherit swaylock)
+ (name "swaylock-effects")
+ (version "1.6.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jirutka/swaylock-effects")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d8ri7bzwfr53ybgf23acz57wyhcl2f1nqprcda1v9bzfgsqfk2n"))))
+ (arguments
+ (list #:configure-flags #~'("-Dsse=false")))
+ (synopsis "Screen locking utility for Wayland compositors with effects")
+ (description "@code{Swaylock-effects} is a fork of swaylock with additional
features, such as the ability to take a screenshot as the background image,
display a clock or apply image manipulation techniques to the background image.")
- (home-page "https://github.com/mortie/swaylock-effects"))))
+ (home-page "https://github.com/jirutka/swaylock-effects")))
(define-public swaybg
(package

base-commit: 754ce586e013582b0f6d28337fdc46db35395997
--
2.37.3
宋文武 wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 58107-done@debbugs.gnu.org)
871qrw6x65.fsf@envs.net
kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (5 lines)
> * gnu/packages/wm.scm (swaylock-effects): Update to 1.6.10.
> [source]: Switch from commit to release tag.
> [arguments]: Use G-expressions.
> [home-page]: Switch to maintained fork.

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58107@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58107
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help