[PATCH] gnu: blueman: Update to 2.3.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Mathieu Othacehe
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
8e9065b22c74bfbb1d572cb336102a6cd535ea7f.1664169324.git.kiasoc5@disroot.org
* gnu/packages/networking.scm (blueman): Update to 2.3.2.
[native-inputs]: Remove input labels.
[inputs]: Likewise.
---
gnu/packages/networking.scm | 50 ++++++++++++++++++-------------------
1 file changed, 25 insertions(+), 25 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 825170cc54..3d9ba4fc8d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -867,14 +867,14 @@ (define-public nanomsg
(define-public blueman
(package
(name "blueman")
- (version "2.2.3")
+ (version "2.3.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/blueman-project/blueman/releases"
"/download/" version "/blueman-" version ".tar.xz"))
(sha256
- (base32 "1s86w4mklzr8hvbgl3nkg8jycl6grww533dhzw8gdn5glqfpkpbf"))))
+ (base32 "1bjh0cx9j2akygiqyxm7g0q74jyx9hpgf186gv3m31vks5zpvkw4"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags (list "--enable-polkit"
@@ -942,30 +942,30 @@ (define-public blueman
(map (lambda (prog) (string-append libexec prog))
'("mechanism" "rfcomm-watcher"))))))))))
(native-inputs
- `(("cython" ,python-cython)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk+:bin" ,gtk+ "bin")
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list python-cython
+ `(,glib "bin")
+ gobject-introspection
+ `(,gtk+ "bin")
+ intltool
+ pkg-config))
(inputs
- `(("bluez" ,bluez)
- ("dbus" ,dbus)
- ("librsvg" ,librsvg)
- ("glib" ,glib)
- ("gtk+" ,gtk+)
- ("iproute2" ,iproute)
- ("iptables" ,iptables)
- ("net-tools" ,net-tools)
- ("pango" ,pango)
- ("polkit" ,polkit)
- ("ppp" ,ppp)
- ("pulseaudio" ,pulseaudio)
- ("pycairo" ,python-pycairo)
- ("pygobject" ,python-pygobject)
- ("python" ,python-wrapper)
- ("libappindicator" ,libappindicator)
- ("libnm" ,network-manager)))
+ (list bluez
+ dbus
+ librsvg
+ glib
+ gtk+
+ iproute
+ iptables
+ net-tools
+ pango
+ polkit
+ ppp
+ pulseaudio
+ python-pycairo
+ python-pygobject
+ python-wrapper
+ libappindicator
+ network-manager))
(synopsis "GTK+ Bluetooth manager")
(description "Blueman is a Bluetooth management utility using the Bluez
D-Bus backend. It is designed to be easy to use for most common Bluetooth

base-commit: 754ce586e013582b0f6d28337fdc46db35395997
--
2.37.3
Mathieu Othacehe wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 58085-done@debbugs.gnu.org)
87a66l9oyc.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/networking.scm (blueman): Update to 2.3.2.

Applied, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58085@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58085
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help