[PATCH] gnu: vim-nerdcommenter: Update to 2.6.0, use G-expressions.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Mathieu Othacehe
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
c79011dc16fc8ab415bb8319dbf417db71bc548b.1664082929.git.kiasoc5@disroot.org
* gnu/packages/vim.scm (vim-nerdcommenter): Update to 2.6.0.
[source]: Use release tag.
[arguments]: Use G-expressions.
---
gnu/packages/vim.scm | 49 ++++++++++++++++++++++----------------------
1 file changed, 24 insertions(+), 25 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f379543599..a6250f71de 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1375,30 +1375,29 @@ (define-public vim-nerdtree
(license license:wtfpl2)))
(define-public vim-nerdcommenter
- (let ((commit "a65465d321f2f8a74b2ffa540b9b87563f7e12e8")
- (revision "1"))
- (package
- (name "vim-nerdcommenter")
- (version (git-version "2.5.2" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/preservim/nerdcommenter")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "00ir65iv8jfbgzjmj7332fmydh0qhabbhx8zbvd3j6pgfxqpaafw"))))
- (build-system copy-build-system)
- (arguments
- '(#:install-plan
- '(("autoload" "share/vim/vimfiles/")
- ("doc" "share/vim/vimfiles/")
- ("plugin" "share/vim/vimfiles/"))))
- (home-page "https://github.com/preservim/nerdcommenter")
- (synopsis "Vim plugin for easy commenting of code")
- (description
- "NERD commenter is a Vim plugin that provides many different commenting
+ (package
+ (name "vim-nerdcommenter")
+ (version "2.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/nerdcommenter")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ka2rqn7rby55aps3iblh1dcqxm7m7qx72mpkz6y2aaj8mkj0zyd"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~`(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/nerdcommenter")
+ (synopsis "Vim plugin for easy commenting of code")
+ (description
+ "NERD commenter is a Vim plugin that provides many different commenting
operations and styles which are invoked via key mappings and a menu. These
operations are available for most filetypes.")
- (license license:cc0))))
+ (license license:cc0)))

base-commit: cbe8391d7c570a12416acfbfbbb818404d8b9203
--
2.37.3
Mathieu Othacehe wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 58062-done@debbugs.gnu.org)
877d1p9otx.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/vim.scm (vim-nerdcommenter): Update to 2.6.0.

Applied, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58062@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58062
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help