[PATCH 0/1] Add emacs-orgmd

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Maxime Devos
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 25 Sep 2022 02:37
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220925003750.631327-1-plattfot@posteo.net
An Emacs' Org mode watchlist manager and OMDb API client.

Fredrik Salomonsson (1):
gnu: Add emacs-orgmdb.

gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)


base-commit: fc07082fe3d750c85282c4aa57d01a36ebe9296b
--
2.37.3
F
F
Fredrik Salomonsson wrote on 25 Sep 2022 02:49
[PATCH 1/1] gnu: Add emacs-orgmdb.
(address . 58055@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220925004957.635421-1-plattfot@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-orgmdb): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0e3e0be3b8..5572564b6d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6010,6 +6010,32 @@ (define-public emacs-org-now
their original location with another.")
(license license:gpl3+))))
+(define-public emacs-orgmdb
+ (package
+ (name "emacs-orgmdb")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isamert/orgmdb.el")
+ (commit "66c13abdb84e0f0a31bae6cfda27478771d58d8e")))
+ (sha256
+ (base32
+ "1hvxha0ih9jhvwj07l6jnpf2vzhgvb6ii73g49c8saxld61l0frf"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list
+ emacs-s
+ emacs-dash
+ emacs-org))
+ (home-page "https://github.com/isamert/orgmdb.el")
+ (synopsis "An Emacs' Org mode watchlist manager and OMDb API client")
+ (description "This package adds tools for managing your watchlist in Emacs' Org
+mode and some functions for interacting with the OMDb API.")
+ (license license:gpl3+)))
+
(define-public emacs-rich-minority
(package
(name "emacs-rich-minority")
--
2.37.3
N
N
Nicolas Goaziou wrote on 25 Sep 2022 15:18
(name . Fredrik Salomonsson)(address . plattfot@posteo.net)(address . 58055-done@debbugs.gnu.org)
87v8pbtwvw.fsf@nicolasgoaziou.fr
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-orgmdb): New variable.

Thank you. I applied the patch with the following changes:

Toggle quote (6 lines)
> + (propagated-inputs
> + (list
> + emacs-s
> + emacs-dash
> + emacs-org))

I reordered inputs alphabetically.

Toggle quote (3 lines)
> + (synopsis "An Emacs' Org mode watchlist manager and OMDb API client")

I removed the article "An".

Regards,
--
Nicolas Goaziou
Closed
M
M
Maxime Devos wrote on 25 Sep 2022 19:40
Re: [bug#58055] [PATCH 0/1] Add emacs-orgmd
0ac7bd43-1928-8662-c4e6-dcf1d59c2073@telenet.be
On 25-09-2022 02:37, Fredrik Salomonsson wrote:
Toggle quote (10 lines)
> An Emacs' Org mode watchlist manager and OMDb API client.
>
> Fredrik Salomonsson (1):
> gnu: Add emacs-orgmdb.
>
> gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
>
> base-commit: fc07082fe3d750c85282c4aa57d01a36ebe9296b
Have you tested this in a pure environment? Going by
it requires 'fd' to work, but 'fd is not mentioned in the propagated
inputs and neither is it mentioned in the 'inputs' + appropriate
substitute*.
I recommend the latter, and in the future having a quick look at the
source code to see if it invokes some software (Emacs additions are
usually short).
Greetings,
Maxime.
Attachment: OpenPGP_signature
N
N
Nicolas Goaziou wrote on 25 Sep 2022 21:10
(name . Maxime Devos)(address . maximedevos@telenet.be)
87zgens21n.fsf@nicolasgoaziou.fr
Hello,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (18 lines)
> On 25-09-2022 02:37, Fredrik Salomonsson wrote:
>> An Emacs' Org mode watchlist manager and OMDb API client.
>> Fredrik Salomonsson (1):
>> gnu: Add emacs-orgmdb.
>> gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
>> 1 file changed, 26 insertions(+)
>> base-commit: fc07082fe3d750c85282c4aa57d01a36ebe9296b
>
> Have you tested this in a pure environment? Going by
> <https://github.com/isamert/orgmdb.el/blob/66c13abdb84e0f0a31bae6cfda27478771d58d8e/orgmdb.el#L663>,
> it requires 'fd' to work, but 'fd is not mentioned in the propagated
> inputs and neither is it mentioned in the 'inputs' + appropriate
> substitute*.
>
> I recommend the latter, and in the future having a quick look at the
> source code to see if it invokes some software (Emacs additions are
> usually short).

Fixed in 31593237f6aa82ce29e0ecf1911e64713e21ddcb. Thanks for the heads up.

Regards,
--
Nicolas Goaziou
Closed
?