[PATCH 0/1] Add emacs-cpreproc-houdini

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 25 Sep 2022 02:04
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220925000415.620870-1-plattfot@posteo.net
A package that uses my emacs-cpreproc to make it easier to develop C++ code
that uses openvdb in Emacs.

Fredrik Salomonsson (1):
gnu: Add emacs-cpreproc-openvdb.

gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)


base-commit: fc07082fe3d750c85282c4aa57d01a36ebe9296b
--
2.37.3
F
F
Fredrik Salomonsson wrote on 25 Sep 2022 02:07
[PATCH 1/1] gnu: Add emacs-cpreproc-openvdb.
(address . 58053@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220925000756.621513-1-plattfot@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-cpreproc-openvdb): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0e3e0be3b8..bef9542f80 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23542,6 +23542,32 @@ (define-public emacs-cpreproc
versions of third party libraries or @code{C++} standards.")
(license license:gpl3+)))
+(define-public emacs-cpreproc-openvdb
+ (package
+ (name "emacs-cpreproc-openvdb")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~plattfot/cpreproc-openvdb")
+ (commit version)))
+ (sha256
+ (base32
+ "0n1y8cxx6xipvip8y6nk9ig1dpjdksz77956wlql3lhqcrcn5hzg"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list
+ emacs-cpreproc))
+ (home-page "https://sr.ht/~plattfot/cpreproc")
+ (synopsis "Create preprocessor macros for @code{C++} that uses @code{openvdb}.")
+ (description
+ "Aim for this project is to make it easier to generate preprocessor
+macros from Emacs for @code{C++} code that uses @code{openvdb} and
+needs to be build against multiple incompatible versions of it.")
+ (license license:gpl3+)))
+
(define-public emacs-org-brain
(package
(name "emacs-org-brain")
--
2.37.3
N
N
Nicolas Goaziou wrote on 25 Sep 2022 15:18
(name . Fredrik Salomonsson)(address . plattfot@posteo.net)(address . 58053-done@debbugs.gnu.org)
87zgentwxc.fsf@nicolasgoaziou.fr
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-cpreproc-openvdb): New variable.

Thank you. I applied your patch.

Toggle quote (6 lines)
> + (synopsis "Create preprocessor macros for @code{C++} that uses @code{openvdb}.")
> + (description
> + "Aim for this project is to make it easier to generate preprocessor
> +macros from Emacs for @code{C++} code that uses @code{openvdb} and
> +needs to be build against multiple incompatible versions of it.")

Nitpick: I removed the, IMO, unnecessary Texinfo markup around C++ and
OpenVDB. I also removed the final full stop.

Regards,
--
Nicolas Goaziou
Closed
?