[PATCH] gnu: services: certbot: Add missing activation directory

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mája Tomášek
Owner
unassigned
Submitted by
Mája Tomášek
Severity
normal
M
M
Mája Tomášek wrote on 23 Sep 2022 12:27
(address . guix-patches@gnu.org)
87pmfm2xoo.fsf@disroot.org
When trying to run certbot, the mcron command fails, as
/etc/letsencrypt/live is missing. This patch Adds it into the certbot
activation service.

---
gnu/services/certbot.scm | 2 ++
1 file changed, 2 insertions(+)

diff --git a/gnu/services/certbot.scm b/gnu/services/certbot.scm
index 1c819bef48..7dfdad9874 100644
--- a/gnu/services/certbot.scm
+++ b/gnu/services/certbot.scm
@@ -154,6 +154,7 @@ (define (certbot-renewal-jobs config)
(define (certbot-activation config)
(let* ((certbot-directory "/var/lib/certbot")
+ (certbot-cert-directory "/etc/letsencrypt/live")
(script (in-vicinity certbot-directory "renew-certificates"))
(message (format #f (G_ "~a may need to be run~%") script)))
(match config
@@ -164,6 +165,7 @@ (define (certbot-activation config)
(use-modules (guix build utils))
(mkdir-p #$webroot)
(mkdir-p #$certbot-directory)
+ (mkdir-p #$certbot-cert-directory)
(copy-file #$(certbot-command config) #$script)
(display #$message)))))))
--
2.37.3
L
L
Ludovic Courtès wrote on 29 Sep 2022 22:56
(name . Mája Tomášek)(address . maya.tomasek@disroot.org)(address . 58024-done@debbugs.gnu.org)
87ill599xs.fsf@gnu.org
Hi,

Mája Tomášek <maya.tomasek@disroot.org> skribis:

Toggle quote (4 lines)
> When trying to run certbot, the mcron command fails, as
> /etc/letsencrypt/live is missing. This patch Adds it into the certbot
> activation service.

I adjusted the commit log to follow our conventions and applied it.

Thanks!

Ludo’.
Closed
?