[PATCH 0/2] python-protontricks: New packages + python-vdf dependency

  • Done
  • quality assurance status badge
Details
3 participants
  • Jacob Hrbek
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
J
J
Jacob Hrbek wrote on 23 Sep 2022 13:15
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Ew0jTsZZyITyb5-4FRwWuq_qRMYo5TOm7VkIXL7QSwRzx0vtEOrf6w5ws1GW3_I3hyUHz4jteoArI4xKkoVBQN5L89qhVVRh4H3WBZUzEJ4=@rixotstudio.cz
Empty Message
Attachment: file
J
J
Jacob Hrbek wrote on 23 Sep 2022 13:16
[PATCH] python-protontricks: New package
(address . 58022@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220923111638.12166-1-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 473c3df26b..dc0bd0d931 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6408,6 +6408,27 @@ (define-public python-proto-matcher
@end table")
(license license:asl2.0)))

+(define-public python-protontricks
+ (package
+ (name "python-protontricks")
+ (version "1.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "protontricks" version))
+ (sha256
+ (base32
+ "0kbq52p51k9j98kr23ljzhzmpnxnl9g6x3dxj27gqkshvnsinmjg"))))
+ (build-system python-build-system)
+ (inputs (list python-setuptools python-vdf python-wheel
+ python-setuptools-scm))
+ (home-page "https://github.com/Matoking/protontricks")
+ (synopsis
+ "A simple wrapper for running Winetricks commands for Proton-enabled games.")
+ (description
+ "This package provides a simple wrapper for running Winetricks commands for
+Proton-enabled games.")
+ (license license:gpl3)))
+
(define-public python-matplotlib
(package
(name "python-matplotlib")

base-commit: 3c4024e9f50a064d6458875623eb199a882feb53
prerequisite-patch-id: b84b5a8fd3c19853234a20743b514158fe1d2812
--
2.37.3
J
J
Jacob Hrbek wrote on 23 Sep 2022 14:15
[PATCH 1/2] python-vdf: New package
(address . 58022@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220923121548.27503-1-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92e0c9dbe8..473c3df26b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15679,6 +15679,22 @@ (define-public python-multiprocessing-logging
main process so that they are handled correctly.")
(license license:lgpl3+)))

+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Library for working with Valve's VDF text format")
+ (description "Library for working with Valve's VDF text format")
+ (license license:expat)))
+
(define-public python-vobject
(package
(name "python-vobject")

base-commit: 3c4024e9f50a064d6458875623eb199a882feb53
--
2.37.3
J
J
Jacob Hrbek wrote on 23 Sep 2022 14:16
[PATCH 2/2] python-protontricks: New package
(address . 58022@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220923121548.27503-2-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 473c3df26b..dc0bd0d931 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6408,6 +6408,27 @@ (define-public python-proto-matcher
@end table")
(license license:asl2.0)))

+(define-public python-protontricks
+ (package
+ (name "python-protontricks")
+ (version "1.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "protontricks" version))
+ (sha256
+ (base32
+ "0kbq52p51k9j98kr23ljzhzmpnxnl9g6x3dxj27gqkshvnsinmjg"))))
+ (build-system python-build-system)
+ (inputs (list python-setuptools python-vdf python-wheel
+ python-setuptools-scm))
+ (home-page "https://github.com/Matoking/protontricks")
+ (synopsis
+ "A simple wrapper for running Winetricks commands for Proton-enabled games.")
+ (description
+ "This package provides a simple wrapper for running Winetricks commands for
+Proton-enabled games.")
+ (license license:gpl3)))
+
(define-public python-matplotlib
(package
(name "python-matplotlib")
--
2.37.3
L
L
Ludovic Courtès wrote on 29 Sep 2022 22:47
Re: bug#58022: [PATCH 0/2] python-protontricks: New packages + python-vdf dependency
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 58022@debbugs.gnu.org)
87r0zt9abn.fsf_-_@gnu.org
Hi,

Jacob Hrbek <kreyren@rixotstudio.cz> skribis:

Toggle quote (7 lines)
> + (synopsis
> + "A simple wrapper for running Winetricks commands for Proton-enabled games.")
> + (description
> + "This package provides a simple wrapper for running Winetricks commands for
> +Proton-enabled games.")

I did not understand much of this description so I dig a bit and found
that Winetricks is a requirement for Protontricks, and that Winetricks
is a script to download non-free Windows software¹. Did I get it right?

If that characterization is correct, we will not included in Guix as it
would contradict the Free System Distribution Guidelines (FSDG) that the
project follows, specifically the bit about not providing “recipes for
installation of particular nonfree programs”.

Thanks,
Ludo’.

J
J
Jacob Hrbek wrote on 1 Oct 2022 19:34
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58022@debbugs.gnu.org)
c7yg0Z0dCUvdbjNlx5LU4ezHoRN62xmlInACKvuD0g7U46ivynVIrPd-gqAs3JQ3R_qzY7zKgiuYMPo3yKNP18qjVogFhozdpyve_-_Z2eQ=@rixotstudio.cz
Fair, thanks for noticing it


-- Jacob "Kreyren" Hrbek

Sent with Proton Mail secure email.

------- Original Message -------
On Thursday, September 29th, 2022 at 10:47 PM, Ludovic Courtès <ludo@gnu.org> wrote:


Toggle quote (25 lines)
> Hi,
>
> Jacob Hrbek kreyren@rixotstudio.cz skribis:
>
> > + (home-page "https://github.com/Matoking/protontricks")
> > + (synopsis
> > + "A simple wrapper for running Winetricks commands for Proton-enabled games.")
> > + (description
> > + "This package provides a simple wrapper for running Winetricks commands for
> > +Proton-enabled games.")
>
>
> I did not understand much of this description so I dig a bit and found
> that Winetricks is a requirement for Protontricks, and that Winetricks
> is a script to download non-free Windows software¹. Did I get it right?
>
> If that characterization is correct, we will not included in Guix as it
> would contradict the Free System Distribution Guidelines (FSDG) that the
> project follows, specifically the bit about not providing “recipes for
> installation of particular nonfree programs”.
>
> Thanks,
> Ludo’.
>
> ¹ https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
L
L
Ludovic Courtès wrote on 3 Oct 2022 12:03
control message for bug #58022
(address . control@debbugs.gnu.org)
874jwl1axc.fsf@gnu.org
tags 58022 notabug
close 58022
quit
M
M
Maxime Devos wrote on 4 Oct 2022 18:46
Re: [bug#58022] [PATCH 2/2] python-protontricks: New package
8397e438-b7ba-e8fe-783d-4e7924661e1a@telenet.be
On 23-09-2022 14:16, Jacob Hrbek wrote:
Toggle quote (15 lines)
> + (method url-fetch)
> + (uri (pypi-uri "protontricks" version))
> + (sha256
> + (base32
> + "0kbq52p51k9j98kr23ljzhzmpnxnl9g6x3dxj27gqkshvnsinmjg"))))
> + (build-system python-build-system)
> + (inputs (list python-setuptools python-vdf python-wheel
> + python-setuptools-scm))
> + (home-page"https://github.com/Matoking/protontricks")
> + (synopsis
> + "A simple wrapper for running Winetricks commands for Proton-enabled games.")
> + (description
> + "This package provides a simple wrapper for running Winetricks commands for
> +Proton-enabled games.")
> + (license license:gpl3)))
The Winetricks contain non-free software, though (which additionally is
unlikely to be gpl3)? E.g., one of its main uses is to install
Microsoft's .NET implementation instead of Mono (this was at a time when
it didn't have a free license IIRC). More contemporary, going by
it downloads many other Microsoft things -- while some of them might be
free, I would expect most of them to be non-free.
To compare with another distro, in Debian, it is sorted in 'contrib'.
Also, going by a 'Re: Hostile takeover of the matrix room', you are
banned. That means you aren't allowed to send messages to Guix anymore.
Given there appear to be some technical problems involving debbugs, I'll
try setting up a local filter.
Greetings,
Maxime.
Attachment: OpenPGP_signature
?