[PATCH] gnu: Add ghc-9.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • itd
Owner
unassigned
Submitted by
itd
Severity
normal
I
(address . guix-patches@gnu.org)
87mtasornd.fsf@localhost
* gnu/packages/haskell.scm (ghc-9.0): New variable.
---
Hi,

this patch introduces GHC 9.0.2. (More recent than the latest GHC in Guix and
prerequisite to build newer GHC releases, to my understanding.)
Please consider applying it. Thanks!

Regards
itd

gnu/packages/haskell.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index effc6eeb1b..0afa4d1ce9 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1011,6 +1011,41 @@ (define-public ghc-8.10
(define-public ghc-8 ghc-8.10)
+(define-public ghc-9.0
+ (package
+ (inherit ghc-8.10)
+ (name "ghc-next")
+ (version "9.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.haskell.org/ghc/dist/" version
+ "/ghc-" version "-src.tar.xz"))
+ (sha256
+ (base32
+ "15wii8can2r3dcl6jjmd50h2jvn7rlmn05zb74d2scj6cfwl43hl"))))
+ (native-inputs `(("ghc-bootstrap" ,ghc-8.10)
+ ("ghc-testsuite"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-testsuite.tar.xz"))
+ (sha256
+ (base32
+ "1m5fzhr4gjn9ni8gxx7ag3fkbw1rspjzgv39mnfb0nkm5mw70v3s"))))
+ ("git" ,git-minimal/fixed) ;invoked during tests
+ ,@(filter (match-lambda
+ (("ghc-bootstrap" . _) #f)
+ (("ghc-testsuite" . _) #f)
+ (_ #t))
+ (package-native-inputs ghc-8.10))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))))
+
(define-public ghc ghc-8)
;;; haskell.scm ends here

base-commit: 04cad8e29ed85be838921c7fa05f7c5bce94b6d1
--
2.37.3
E
E
Efraim Flashner wrote on 2 Oct 2022 20:13
(name . itd)(address . itd@net.in.tum.de)(address . 58000-done@debbugs.gnu.org)
YznUw7UQHgrUUP7P@3900XT
On Thu, Sep 22, 2022 at 08:21:58AM +0200, itd wrote:
Toggle quote (11 lines)
> * gnu/packages/haskell.scm (ghc-9.0): New variable.
> ---
> Hi,
>
> this patch introduces GHC 9.0.2. (More recent than the latest GHC in Guix and
> prerequisite to build newer GHC releases, to my understanding.)
> Please consider applying it. Thanks!
>
> Regards
> itd

I added a comment that ghc-9.0.2 needs >= 8.8 to build and I removed the
extra git input (it was also inherited from 8.10). You might be
interested to know that when staging is eventually merged we've shorted
the bootstrap path slightly by trying to skip a few versions while
building out, so 9.2.x will hopefully also be buildable with 8.10.

Thanks! Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmM51L8ACgkQQarn3Mo9
g1HLOw/6A5e+aSzdwvcSEA0ehzpT5tGheKPvJ9gPFhzM9TjhwFOdqCgbSXP2NOAs
2Py0mG94JT4v4Tsswwp3ElWOgs+EDTm3XjtLKGKbM9G90YC+0vyBaZtS23hor8Do
tId8IwD2+leqWNf9ODWoFDwTsEyTAgmjqlJHI54f5FyPuII4PA1dkGQcOjpQASnF
A2nxJWlwlEBsdBxoCNrFIxsvoUaHbQR+5JAFEmtgD4/itzWwa6WMZP5HbNI3K9VD
lG31BHe4pMV1zePpS1rSRlGUk/0Ojc8UUPJzAmAf7XabOocLyoo5VXt4WTIP3u6+
UbMJvlsHExTXB9CeaIFa0LNqxp62ZxMTeZcMj84uwnIS03aQTc/w6wJVt3pe3tgw
nEU6aIsYdz/U/agr/5X1WTkQ+JjDbSd7UaBtMZSc9C/lUYkrvNBFGpf5FBKYCpu/
vsc6xmWuBim0BdeOwA7UZlRk5auVJW0xe1lF/aUhqnf4/zynk064SOTq02emyRM2
WSxKLjmvMfEtDOgWlHr6wzLSfX7zbGfBAx6eghCwU+OrGTKWcvZsd6aZ2Wagwf+w
MluySGC5yHsY21itxOtyTpIlyzLdV/YFWzouqY14Z4MvGhLuTmbRu3JsqXhoEIWu
16U3LlG4ZrrPPE9mShCNARqb6cAI3Qo1GbMwFgUyQiJL7v0y7Tk=
=grKJ
-----END PGP SIGNATURE-----


Closed
?