[PATCH 0/1] Change source for emacs-jsonrpc

  • Done
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Liliana Marie Prikler
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 21 Sep 2022 04:21
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220921022107.73691-1-plattfot@posteo.net
It seems that ELPA regenerated the archive for the source of emacs-jsonrpc, as
discoverd by Josselin Poiret in issue 57899[0]. Which breaks the package in
guix as now the hash mismatch.

This patch changes the source to using Emacs' Git repository. Which will
hopefully avoid this issue in the future.

**NOTE** I used https://github.com/emacs-mirror/emacswhen testing this, as
https://git.savannah.gnu.org/git/emacs.git/was dead slow for me (~16Mb/s vs
~50kb/s). But I figured it might just be a hickup on savannah and it is better
to use the original source than a mirror.


Fredrik Salomonsson (1):
gnu: emacs-jsonrpc: Change source.

gnu/packages/emacs-xyz.scm | 19 +++++++++++++++----
1 file changed, 15 insertions(+), 4 deletions(-)


base-commit: f256614891335e250207edab129bdf8601c22774
--
2.37.3
F
F
Fredrik Salomonsson wrote on 21 Sep 2022 04:23
[PATCH 1/1] gnu: emacs-jsonrpc: Change source.
(address . 57964@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220921022314.74064-1-plattfot@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-jsonrpc)
[source]: Change to Emacs' Git repository.
---
gnu/packages/emacs-xyz.scm | 19 +++++++++++++++----
1 file changed, 15 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32e4c33f16..889820350e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16345,12 +16345,23 @@ (define-public emacs-jsonrpc
(version "1.0.15")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "jsonrpc-" version ".tar"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/emacs.git/")
+ (commit "1231a601ebe1fd9fe454c504dbeb9267440242e7")))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1hx378rg12jz2zm105cvrqk0nqyzsn04l59d903l98d6lbd96rsw"))))
+ (base32
+ "00i5n150ibkdn2i3p8q3d1ag5jnikfc988f3hz2yfdk4z0ajj536"))))
(build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (mkdir "source")
+ (chdir "source")
+ (copy-file (string-append source "/lisp/jsonrpc.el") "jsonrpc.el"))))))
(home-page "http://elpa.gnu.org/packages/jsonrpc.html")
(synopsis "JSON-RPC library")
(description
--
2.37.3
J
J
Josselin Poiret wrote on 21 Sep 2022 08:35
Re: [bug#57964] [PATCH 0/1] Change source for emacs-jsonrpc
(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
87edw52q14.fsf@jpoiret.xyz
Hi Fredrik,

Fredrik Salomonsson <plattfot@posteo.net> writes:

Toggle quote (7 lines)
> It seems that ELPA regenerated the archive for the source of emacs-jsonrpc, as
> discoverd by Josselin Poiret in issue 57899[0]. Which breaks the package in
> guix as now the hash mismatch.
>
> This patch changes the source to using Emacs' Git repository. Which will
> hopefully avoid this issue in the future.

Builds and runs for me, and patch is clean!
Reviewed-by: Josselin Poiret <dev@jpoiret.xyz>

Best,
--
Josselin Poiret
F
F
Fredrik Salomonsson wrote on 24 Sep 2022 01:42
[PATCH 0/1] Correct hash
(address . 57964@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220923234200.156692-1-plattfot@posteo.net
Hi,

I saw that my patch was merged. But when I did a guix pull and built it
I got a hash mismatch again. Looks like when it got cleaned up to use
the commit which bumped jsonrpc.el to 1.0.15 the hash wasn't updated.

I added a patch to use the correct hash.

Fredrik Salomonsson (1):
gnu: emacs-jsonrpc: Correct hash.

gnu/packages/emacs-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 08d515233241ee0921b8b5ab706f98170c62437c
--
2.37.3
F
F
Fredrik Salomonsson wrote on 24 Sep 2022 01:42
[PATCH 1/1] gnu: emacs-jsonrpc: Correct hash.
(address . 57964@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220923234222.156722-1-plattfot@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-jsonrpc)[source]: Correct hash.
---
gnu/packages/emacs-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b98b435e9b..c413bc971c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16357,7 +16357,7 @@ (define-public emacs-jsonrpc
(file-name (git-file-name name version))
(sha256
(base32
- "0005n150ibkdn2i3p8q3d1ag5jnikfc988f3hz2yfdk4z0ajj536"))))
+ "0srwb171dxha1nfzppk6x9v4bdj3lk74pksqnhalw8jw9c67b72y"))))
(build-system emacs-build-system)
(arguments
(list #:phases
--
2.37.3
L
L
Liliana Marie Prikler wrote on 24 Sep 2022 07:20
db68b30226cf795cf4ec4d7c7c83c664cd5803a1.camel@gmail.com
Am Freitag, dem 23.09.2022 um 23:42 +0000 schrieb Fredrik Salomonsson:
Toggle quote (1 lines)
> * gnu/packages/emacs-xyz.scm (emacs-jsonrpc)[source]: Correct hash.
Sorry for not double-checking. Pushed!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch