[PATCH] gnu: clapack: Use position-independent code for use as a library.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 20 Sep 2022 14:40
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20220920124010.21646-1-ngraves@ngraves.fr
* gnu/packages/maths.scm (clapack): Use position-independent code for use as a library.
---
gnu/packages/maths.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 72d5e9a83a..0c4b7ada03 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -968,6 +968,7 @@ (define-public clapack
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DCMAKE_C_FLAGS=-fcommon -O2")
+ #:make-flags '("-fPIC")
#:phases
(modify-phases %standard-phases
;; These tests use a lot of stack variables and segfault without
--
2.37.3
N
N
Nicolas Graves wrote on 20 Sep 2022 14:58
Some details about why and see if there is no other solution.
(address . 57954@debbugs.gnu.org)
87wn9ykxrn.fsf@ngraves.fr
I am trying to get a vosk package to work for guix.
The build process is a bit tricky with replaced dependencies etc.

The team from vosk uses a version where they replace fortran by having
both openblas and clapack in libraries (which is incompatible in the
base kaldi configuration, so they have their own fork).

I don't know why exactly the library should be called from another
place, but when compiling kaldi with clapack, I get the following
message (and siblings):

ld: /gnu/store/yvc2w9mg554y6i4frvahjhacj0np9c7s-clapack-3.2.1/lib/liblapack.a(ssptrf.c.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

I actually does work when recompiling with this flag, but I've also read
that it might make the package a bit slower.

In case it might help to answer, here's where I am for this package,
although not done yet (I still do have to untangle some ffi segmentation
fault issue) :

What is the best option / course of action ?

--
Best regards,
Nicolas Graves
M
M
Maxime Devos wrote on 22 Sep 2022 17:48
a3646d18-71ee-28e9-8f44-2dea104c558b@telenet.be
On 20-09-2022 14:58, Nicolas Graves via Guix-patches via wrote:
Toggle quote (23 lines)
>
> I am trying to get a vosk package to work for guix.
> The build process is a bit tricky with replaced dependencies etc.
>
> The team from vosk uses a version where they replace fortran by having
> both openblas and clapack in libraries (which is incompatible in the
> base kaldi configuration, so they have their own fork).
>
> I don't know why exactly the library should be called from another
> place, but when compiling kaldi with clapack, I get the following
> message (and siblings):
>
> ld: /gnu/store/yvc2w9mg554y6i4frvahjhacj0np9c7s-clapack-3.2.1/lib/liblapack.a(ssptrf.c.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
>
> I actually does work when recompiling with this flag, but I've also read
> that it might make the package a bit slower.
>
> In case it might help to answer, here's where I am for this package,
> although not done yet (I still do have to untangle some ffi segmentation
> fault issue) :
> https://git.sr.ht/~ngraves/dotfiles/tree/main/item/packages/vosk.scm
>
> What is the best option / course of action ?
'kaldi' is compiled as a shared library. However, going by the error
message, it is linked to the (static!) clapack. IIUC, this is not a
problem per se (the static library would be embedded into the shared
library IIUC) -- however, shared libraries must be position-independent,
whereas static libraries aren't by default.
As such, there appear to be three potential solutions:
* compile the static library as -fPIC (your patch)
* let kaldi link to a shared clapack (which is -fPIC by default)
* let 'kaldi' (and its dependent, vosk) be a static library instead
of a shared library. Is likely problematic due to 'python-vosk'
though.
Both 'real' solutions have -fPIC (explicit or implied), so I don't think
we have to worry about performance. My default option for deciding
between static and shared is 'shared' (makes 'clapack' graftable, and
better interaction with "guix build --repair" and "guix gc --references").
Hence, my proposed (and untested) solution is to make 'kaldi' link to a
shared clapack.
Greetings,
Maxime.
Attachment: OpenPGP_signature
N
N
Nicolas Graves wrote on 24 Sep 2022 10:37
871qs15frx.fsf@ngraves.fr
Toggle quote (6 lines)
> * compile the static library as -fPIC (your patch)
> * let kaldi link to a shared clapack (which is -fPIC by default)

> Hence, my proposed (and untested) solution is to make 'kaldi' link to a
> shared clapack.

Thanks Maxime for your quick answer.

Just to be sure of what that would imply (using the second answer here:

1) We keep the version of clapack patched for -fPIC.
2) I need to make a package providing a shared version of clapack based
on this version of clapack compiled with -fPIC.

Also, my original patch is wrong, I'll send a corrected one once I
understand the process.

--
Best regards,
Nicolas Graves
M
M
Maxime Devos wrote on 24 Sep 2022 11:46
dd5cdd04-8721-4971-4312-eda4f070a1eb@telenet.be
On 24-09-2022 10:37, Nicolas Graves wrote:
Toggle quote (18 lines)
>
>> * compile the static library as -fPIC (your patch)
>> * let kaldi link to a shared clapack (which is -fPIC by default)
>
>> Hence, my proposed (and untested) solution is to make 'kaldi' link to a
>> shared clapack.
>
> Thanks Maxime for your quick answer.
>
> Just to be sure of what that would imply (using the second answer here:
> https://stackoverflow.com/questions/2649735/how-to-link-static-library-into-dynamic-library-in-gcc):
>
> 1) We keep the version of clapack patched for -fPIC.
> 2) I need to make a package providing a shared version of clapack based
> on this version of clapack compiled with -fPIC.
>
> Also, my original patch is wrong, I'll send a corrected one once I
> understand the process.
That should do it AFAIK.
However, going by
, you can ask CMake to do these steps instead.
Also, going by the descriptio of 'clapack': ‘"The CLAPACK library was
built using a Fortran to C conversion utility
called f2c. The entire Fortran 77 LAPACK library is run through f2c to
obtain C code, and then modified to improve readability. CLAPACK's goal
is to provide LAPACK for someone who does not have access to a Fortran
compiler.’
... it sounds like clapack could be replaced with lapack without any
problems (and even removed), and our 'lapack' package already makes
shared libraries, which seems like a simpler course of action.
Greetings,
Maxime
Attachment: OpenPGP_signature
N
N
Nicolas Graves wrote on 28 Sep 2022 14:19
8735cbbsis.fsf@ngraves.fr
Toggle quote (4 lines)
> ... it sounds like clapack could be replaced with lapack without any
> problems (and even removed), and our 'lapack' package already makes
> shared libraries, which seems like a simpler course of action.

You're absolutely right about this. I replaced clapack by lapack and
discarded the flag -lf2c during the build phase.

Everything works fine. I'm closing the issue.

The resulting packages are available in issue 58140.

--
Best regards,
Nicolas Graves
Closed
?