[PATCH] gnu: wpa-supplicant: enable OWE support

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Rammhold
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Andreas Rammhold
Severity
normal

Debbugs page

Andreas Rammhold wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andreas Rammhold)(address . andreas@rammhold.de)
20220919235956.1074718-1-andreas@rammhold.de
With OWE support users are enable to connect to "Opportunistic Wireless
Encryption" networks. This means users are able to have an encrypted
data channel in an otherwise open wireless network.

* gnu/packages/admin.scm (wpa-supplicant): Enable OWE support.

Signed-off-by: Andreas Rammhold <andreas@rammhold.de>
---
gnu/packages/admin.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5fb621e027..84819992c4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
+;;; Copyright © 2022 Andreas Rammhold <andreas@rammhold.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2133,6 +2134,12 @@ (define-public wpa-supplicant
CONFIG_CTRL_IFACE_DBUS_INTRO=y\n" port)
(close-port port))
#t))
+ (add-after 'configure 'enable-owe
+ (lambda _
+ (let ((port (open-file ".config" "al")))
+ (display "CONFIG_OWE=y\n" port)
+ (close-port port))
+ #t))
(add-after 'install-documentation 'install-dbus-conf
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))

base-commit: d845326b5cb33453a50b9c8fd8f21dfd8198a158
prerequisite-patch-id: b830a1b0573b55d8a8378338862dc5bfaac53117
prerequisite-patch-id: 59289da7b58eb3a1ea1f3b531261d0785b58dd36
prerequisite-patch-id: a761f12c1d69204330e6215a26ea110c281ea834
prerequisite-patch-id: fcc87d0b44e2c3597e9270e6d96c8f1e4beddcf6
--
2.37.2
Maxime Devos wrote 2 years ago
091125b8-f122-46cd-85ae-1aca0cacaf19@telenet.be
On 20-09-2022 01:59, Andreas Rammhold wrote:
Toggle quote (6 lines)
> + (add-after 'configure 'enable-owe
> + (lambda _
> + (let ((port (open-file ".config" "al")))
> + (display "CONFIG_OWE=y\n" port)
> + (close-port port))
> + #t))
(1) Why not do this in the 'configure' phase instead?
(2) Trailing #t in phases aren't required anymore since a long time, you
can remove them.
(3) You are not a committer (and you are the author), so you can't 'push
the commit on behalf on somebody else'. From (guix)Commit Access:
When pushing a commit on behalf of somebody else, please add a
‘Signed-off-by’ line at the end of the commit log message—e.g., with
‘git am --signoff’. This improves tracking of who did what.
The other meaning of 'Signed-off-by' I'm aware of, is for 'Developer
Certificate of Origin', but we don't do DCO in Guix (and if we did, it
would be mentioned in the contributing guidelines somewhere).
Greetings,
Maxime.
Attachment: OpenPGP_signature
Maxime Devos wrote 2 years ago
a3016374-486f-a4c1-446e-3388892a56c6@telenet.be
On 22-09-2022 21:14, Maxime Devos wrote:
Toggle quote (2 lines)
> (3) You are not a committer (and you are the author), so you can't 'push
> the commit on behalf on somebody else'.  From (guix)Commit Access:
(At least, AFAIK, .guix-authorizations doesn't mention names or e-mails
except for nicks)
Attachment: OpenPGP_signature
Ludovic Courtès wrote 2 years ago
Re: bug#57945: [PATCH] gnu: wpa-supplicant: enable OWE support
(name . Maxime Devos)(address . maximedevos@telenet.be)
875yh7fczl.fsf_-_@gnu.org
Hi,

Maxime Devos <maximedevos@telenet.be> skribis:

Toggle quote (15 lines)
> On 20-09-2022 01:59, Andreas Rammhold wrote:
>> + (add-after 'configure 'enable-owe
>> + (lambda _
>> + (let ((port (open-file ".config" "al")))
>> + (display "CONFIG_OWE=y\n" port)
>> + (close-port port))
>> + #t))
>
>
> (1) Why not do this in the 'configure' phase instead?
> (2) Trailing #t in phases aren't required anymore since a long time,
> you can remove them.
> (3) You are not a committer (and you are the author), so you can't
> 'push the commit on behalf on somebody else'. From (guix)Commit

Good points (perhaps somewhat intimidating for a newcomer).

Andreas, I applied a variant of the patch that accounts for the comments
Maxime made.

Thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57945@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57945
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help