[PATCH 1/2] gnu: Add gnome-text-editor

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 20 Sep 2022 06:13
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
wJKYD-IQATtDutQWaSGzGOKGqFl7ysgr8pIQxANvY5uflScFnmR9jvI5owL_WRkKO0tEbrs780OUM37ipdXIc2BGG3cRcoCKU8KyHyzBkJo=@proton.me
Empty Message
Attachment: file
From 03391b5eb619e248c4f55b22bd8f54c3866476ae Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:00:58 +0200
Subject: [PATCH 1/2] gnu: Add gnome-text-editor

* gnu/packages/gnome.scm (gnome-text-editor): New variable.
---
gnu/packages/gnome.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8a49040f4..c76b25d968 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5474,6 +5474,44 @@ (define-public gnome-terminal
keyboard shortcuts.")
(license license:gpl3+)))
+(define-public gnome-text-editor
+ (package
+ (name "gnome-text-editor")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-text-editor/"
+ (version-major version)
+ "/"
+ "gnome-text-editor-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "1nn53iv2a82kkqkg5jy0bqh2b2wzg7g4a6w8q3qsis5wvj64lvg5"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config
+ cmake
+ gettext-minimal
+ desktop-file-utils
+ appstream-glib
+ `(,glib "bin")
+ `(,gtk "bin")
+ itstool))
+ (inputs (list glib
+ gtk
+ gtksourceview
+ libadwaita
+ enchant))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-text-editor")
+ (synopsis "Simple text editor")
+ (description
+ "Text Editor is a simple text editor that focuses on session management.
+It works hard to keep track of changes and state even if you quit the
+application. You can come back to your work even if you've never saved it to a
+file.")
+ (license license:gpl3)))
+
(define-public colord-minimal
(package
(name "colord-minimal")
--
2.37.3
From 8142d2bc994e1b7cc61ad379f9ce13ee7e274ec0 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:08:05 +0200
Subject: [PATCH 2/2] gnu: Add gnome-console

* gnu/packages/gnome.scm (gnome-console): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c76b25d968..14e9c36fc6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5411,6 +5411,38 @@ (define-public gnome-sudoku
more fun.")
(license license:gpl2+)))
+(define-public gnome-console
+ (package
+ (name "gnome-console")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-console/"
+ (version-major version)
+ "/"
+ "gnome-console-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0jbh8g3hmc35fy5fbscqf0831xpg1kv66ci9hykpbia4hz0yc9kx"))))
+ (build-system meson-build-system)
+ (native-inputs (list desktop-file-utils
+ appstream-glib
+ `(,glib "bin")
+ gettext-minimal
+ sassc
+ pkg-config
+ cmake-minimal
+ `(,gtk+ "bin")))
+ (inputs (list gtk+ libhandy vte libgtop gsettings-desktop-schemas))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-console")
+ (synopsis "Simple user-friendly terminal emulator for the GNOME desktop")
+ (description
+ "Console is supposed to be a simple terminal emulator for the average user
+to carry out simple cli tasks and aims to be a ‘core’ app for GNOME/Phosh")
+ (license license:gpl3)))
+
(define-public gnome-terminal
(package
(name "gnome-terminal")
--
2.37.3
L
L
Liliana Marie Prikler wrote on 20 Sep 2022 07:14
dfd58a79181ddc57c4c08ac80c7146925f307015.camel@gmail.com
Hi,

Am Dienstag, dem 20.09.2022 um 04:13 +0000 schrieb Sughosha:

Toggle quote (7 lines)
> + (uri (string-append "mirror://gnome/sources/gnome-
> text-editor/"
> + (version-major version)
> + "/"
> + "gnome-text-editor-"
> + version
> + ".tar.xz"))
The format provided by the pretty-printer is, like, a suggestion.

Toggle quote (2 lines)
> + (build-system meson-build-system)
> + (native-inputs (list pkg-config
You're missing arguments here. At the very least #:glib-or-gtk? #t

Toggle quote (7 lines)
> + "Text Editor is a simple text editor that focuses on session
> management.
> +It works hard to keep track of changes and state even if you quit
> the
> +application. You can come back to your work even if you've never
> saved it to a
> +file."
You should probably call it GNOME Text Editor. The description is
fairly light on advertisments as far as copypasta descriptions go, so I
won't fault you for that here.

Toggle quote (1 lines)
> + (license license:gpl3)))
Should probably be gpl3+.

Toggle quote (7 lines)
> + (synopsis "Simple user-friendly terminal emulator for the GNOME
> desktop")
> + (description
> + "Console is supposed to be a simple terminal emulator for the
> average user
> +to carry out simple cli tasks and aims to be a ‘core’ app for
> GNOME/Phosh")
Ehhhhhh... I do want you to cut down on the ads here.

Toggle quote (2 lines)
> + (build-system meson-build-system)
> + (native-inputs (list desktop-file-utils
Missing arguments.

Toggle quote (1 lines)
Dead link is dead.

Toggle quote (1 lines)
> + (license license:gpl3)))
Also probably gpl3+.

Cheers
S
S
Sughosha wrote on 20 Sep 2022 11:12
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 57944@debbugs.gnu.org)
J4Pv76Szb_-uwrWO7DS4Lp5z55Xwk0iMQylkckmfSLDBOFJm5G4MMEqqfpLdSNa277GUMjnx6HZoweN1kWvwH2Z3avczDFsH8auPji8yabM=@proton.me
Thanks for reviewing. I made the changes with the corrections. Here are new patches with the fixes. But one thing I am not sure why gpl3+ was suggested, while in the GitLab repository it is mentioned as GNU GPLv3.

------- Original Message -------
Liliana Marie Prikler <liliana.prikler@gmail.com> schrieb am Dienstag, 20. September 2022 um 07:14:


Toggle quote (59 lines)
> Hi,
>
> Am Dienstag, dem 20.09.2022 um 04:13 +0000 schrieb Sughosha:
>
> > + (uri (string-append "mirror://gnome/sources/gnome-
> > text-editor/"
> > + (version-major version)
> > + "/"
> > + "gnome-text-editor-"
> > + version
> > + ".tar.xz"))
>
> The format provided by the pretty-printer is, like, a suggestion.
>
> > + (build-system meson-build-system)
> > + (native-inputs (list pkg-config
>
> You're missing arguments here. At the very least #:glib-or-gtk? #t
>
> > + "Text Editor is a simple text editor that focuses on session
> > management.
> > +It works hard to keep track of changes and state even if you quit
> > the
> > +application. You can come back to your work even if you've never
> > saved it to a
> > +file."
>
> You should probably call it GNOME Text Editor. The description is
> fairly light on advertisments as far as copypasta descriptions go, so I
> won't fault you for that here.
>
> > + (license license:gpl3)))
>
> Should probably be gpl3+.
>
> > + (synopsis "Simple user-friendly terminal emulator for the GNOME
> > desktop")
> > + (description
> > + "Console is supposed to be a simple terminal emulator for the
> > average user
> > +to carry out simple cli tasks and aims to be a ‘core’ app for
> > GNOME/Phosh")
>
> Ehhhhhh... I do want you to cut down on the ads here.
>
> > + (build-system meson-build-system)
> > + (native-inputs (list desktop-file-utils
>
> Missing arguments.
>
> > + (home-page "https://gitlab.gnome.org/GNOME/gnome-console")
>
> Dead link is dead.
>
> > + (license license:gpl3)))
>
> Also probably gpl3+.
>
> Cheers
From 03391b5eb619e248c4f55b22bd8f54c3866476ae Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:00:58 +0200
Subject: [PATCH 1/2] gnu: Add gnome-text-editor

* gnu/packages/gnome.scm (gnome-text-editor): New variable.
---
gnu/packages/gnome.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8a49040f4..c76b25d968 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5474,6 +5474,44 @@ (define-public gnome-terminal
keyboard shortcuts.")
(license license:gpl3+)))
+(define-public gnome-text-editor
+ (package
+ (name "gnome-text-editor")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-text-editor/"
+ (version-major version) "/"
+ "gnome-text-editor-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1nn53iv2a82kkqkg5jy0bqh2b2wzg7g4a6w8q3qsis5wvj64lvg5"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
+ (native-inputs (list pkg-config
+ cmake
+ gettext-minimal
+ desktop-file-utils
+ appstream-glib
+ `(,glib "bin")
+ `(,gtk "bin")
+ itstool))
+ (inputs (list gtk gtksourceview libadwaita enchant))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-text-editor")
+ (synopsis "GNOME text editor")
+ (description
+ "GNOME Text Editor is a simple text editor that focuses on session
+management. It keeps track of changes and state even if you quit the
+application. You can come back to your work even if you've never saved it to a
+file.")
+ (license license:gpl3+)))
+
(define-public colord-minimal
(package
(name "colord-minimal")
--
2.37.3
From 8142d2bc994e1b7cc61ad379f9ce13ee7e274ec0 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:08:05 +0200
Subject: [PATCH 2/2] gnu: Add gnome-console

* gnu/packages/gnome.scm (gnome-console): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c76b25d968..14e9c36fc6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5411,6 +5411,38 @@ (define-public gnome-sudoku
more fun.")
(license license:gpl2+)))
+(define-public gnome-console
+ (package
+ (name "gnome-console")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-console/"
+ (version-major version) "/"
+ "gnome-console-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0jbh8g3hmc35fy5fbscqf0831xpg1kv66ci9hykpbia4hz0yc9kx"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ `("-Dtests=true")))
+ (native-inputs (list `(,glib "bin")
+ gettext-minimal
+ sassc
+ pkg-config
+ `(,gtk+ "bin")
+ desktop-file-utils))
+ (inputs (list gtk+
+ libhandy
+ vte
+ libgtop
+ gsettings-desktop-schemas))
+ (home-page "https://gitlab.gnome.org/GNOME/console")
+ (synopsis "GNOME terminal emulator")
+ (description
+ "Console is a simple terminal emulator for GNOME desktop")
+ (license license:gpl3+)))
+
(define-public gnome-terminal
(package
(name "gnome-terminal")
--
2.37.3
S
S
Sughosha wrote on 20 Sep 2022 13:21
(address . liliana.prikler@gmail.com)(address . 57944@debbugs.gnu.org)
g-cXXPJW84tFhm3bAFXfktP0mcRz2IM47eOtQaq0fjiVADA5sqcYfIlFiLfJzdjNSVZ1VwxkSeKi2SoVGfC2tvplzia1dlrQiuQWCotpgqw=@proton.me
One more small correction, cmake as native-input was not necessary.
Attachment: file
From 03391b5eb619e248c4f55b22bd8f54c3866476ae Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:00:58 +0200
Subject: [PATCH 1/2] gnu: Add gnome-text-editor

* gnu/packages/gnome.scm (gnome-text-editor): New variable.
---
gnu/packages/gnome.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8a49040f4..c76b25d968 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5474,6 +5474,44 @@ (define-public gnome-terminal
keyboard shortcuts.")
(license license:gpl3+)))
+(define-public gnome-text-editor
+ (package
+ (name "gnome-text-editor")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-text-editor/"
+ (version-major version) "/"
+ "gnome-text-editor-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1nn53iv2a82kkqkg5jy0bqh2b2wzg7g4a6w8q3qsis5wvj64lvg5"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
+ (native-inputs (list pkg-config
+ cmake
+ gettext-minimal
+ desktop-file-utils
+ appstream-glib
+ `(,glib "bin")
+ `(,gtk "bin")
+ itstool))
+ (inputs (list gtk gtksourceview libadwaita enchant))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-text-editor")
+ (synopsis "GNOME text editor")
+ (description
+ "GNOME Text Editor is a simple text editor that focuses on session
+management. It keeps track of changes and state even if you quit the
+application. You can come back to your work even if you've never saved it to a
+file.")
+ (license license:gpl3+)))
+
(define-public colord-minimal
(package
(name "colord-minimal")
--
2.37.3
From 8142d2bc994e1b7cc61ad379f9ce13ee7e274ec0 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:08:05 +0200
Subject: [PATCH 2/2] gnu: Add gnome-console

* gnu/packages/gnome.scm (gnome-console): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c76b25d968..14e9c36fc6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5411,6 +5411,38 @@ (define-public gnome-sudoku
more fun.")
(license license:gpl2+)))
+(define-public gnome-console
+ (package
+ (name "gnome-console")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-console/"
+ (version-major version) "/"
+ "gnome-console-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0jbh8g3hmc35fy5fbscqf0831xpg1kv66ci9hykpbia4hz0yc9kx"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ `("-Dtests=true")))
+ (native-inputs (list `(,glib "bin")
+ gettext-minimal
+ sassc
+ pkg-config
+ `(,gtk+ "bin")
+ desktop-file-utils))
+ (inputs (list gtk+
+ libhandy
+ vte
+ libgtop
+ gsettings-desktop-schemas))
+ (home-page "https://gitlab.gnome.org/GNOME/console")
+ (synopsis "GNOME terminal emulator")
+ (description
+ "Console is a simple terminal emulator for GNOME desktop")
+ (license license:gpl3+)))
+
(define-public gnome-terminal
(package
(name "gnome-terminal")
--
2.37.3
L
L
Liliana Marie Prikler wrote on 21 Sep 2022 20:22
(name . Sughosha)(address . Sughosha@proton.me)(address . 57944-done@debbugs.gnu.org)
0e9ca00a53f49c84d866bfdbd36cb029a79dc664.camel@gmail.com
Am Dienstag, dem 20.09.2022 um 11:21 +0000 schrieb Sughosha:
Toggle quote (1 lines)
> One more small correction, cmake as native-input was not necessary.
You probably saw this already, but I pushed this series with the
nautilus extension to gnome-console.

Cheers
Closed
?